Topic
  • 1 reply
  • Latest Post - ‏2012-06-27T15:53:38Z by TravisBowen
TravisBowen
TravisBowen
2 Posts

Pinned topic Null Pointer Exception when instantiaing Node using JAI

‏2012-06-18T22:32:51Z |
When I try to instantiate a Node object using JAI I get:

Exception in thread "main" java.lang.NullPointerException
at java.util.ResourceBundle.getBundleImpl(Unknown Source)
at java.util.ResourceBundle.getBundle(Unknown Source)
at com.sterlingcommerce.cd.sdk.ConnectionInformation.setConnectionInformation(ConnectionInformation.java:658)
at com.sterlingcommerce.cd.sdk.ConnectionInformation.setConnectionInformation(ConnectionInformation.java:616)
at com.sterlingcommerce.cd.sdk.ConnectionInformation.<init>(ConnectionInformation.java:313)
at com.sterlingcommerce.cd.sdk.Node.<init>(Node.java:539)
at com.wellsfargo.ilmt.actreportgen.NDMHandler.sendFiles(NDMHandler.java:112)
at com.wellsfargo.ilmt.actreportgen.ACTReportGen.sendFiles(ACTReportGen.java:132)
at com.wellsfargo.ilmt.actreportgen.ACTReportGen.<init>(ACTReportGen.java:28)
at com.wellsfargo.ilmt.actreportgen.ACTReportGen.main(ACTReportGen.java:137)

The code I am using is:

NodeParms nodeParams = new NodeParms();
nodeParams.setNodeName(ndmServer);
nodeParams.setUserid(ndmID);
nodeParams.setPassword(ndmPwd.toCharArray());
nodeParams.setProtocol(PROTOCOL);

node = new Node(nodeParams);

The error seems to imply some bundle or resource is missing. I am using the jre installed with connect direct. Any idea why this is happening?

Thanks
Updated on 2012-06-27T15:53:38Z at 2012-06-27T15:53:38Z by TravisBowen
  • TravisBowen
    TravisBowen
    2 Posts

    Re: Null Pointer Exception when instantiaing Node using JAI

    ‏2012-06-27T15:53:38Z  
    I opened a PMR with IBM on this. Apparently using the NodeParams constructor caused the error, when using the parameterized constructor it works fine. Couldn't get an answer as to why the NodeParams constructor doesn't work. Seems like a poorly implemented and supported API.