3 replies Latest Post - ‏2013-05-30T13:54:10Z by jfletcher1
10 Posts

Pinned topic Problems instrumenting

‏2012-06-15T12:39:05Z |

I'm trying to instrument a program which includes, but purify generates an error:

Purify engine: While processing file /drive/new/external/ext/solaris_x86/oracle/11g/lib64/
Error: CreateNewInfo: Apparent overlapping of instructions detected at 0x5552fb (section 13), next offset by 2
Please visit and search
the support database using keywords from the error message.
If you are unable to resolve this issue, please submit
a problem report through Electronic Service Request at using your IBM Customer Number.
If you are evaluating this software,
please contact IBM Rational Support in your region.
You can find the contact information at
Please include the product name and version
(Purify 7.0.1 091008 Solaris x64 (64-bit)),
plus your compiler name and version, operating system version,
this and any preceding error messages and
a copy of any object or data files involved.
Thank you.
I checked the support database but only found a suggestion to update purify. I have the most recent version installed though.
When I exclude the library, ld fails and purify stops instrumenting...

CC -V: Sun C++ 5.10 SunOS_i386 2009/06/03
uname -a: SunOS solix1dev 5.10 Generic_147441-01 i86pc i386 i86pc

Can anyone help?

Updated on 2012-06-21T06:01:46Z at 2012-06-21T06:01:46Z by FransvanderReijden
  • SystemAdmin
    2948 Posts

    Re: Problems instrumenting

    ‏2012-06-15T16:55:30Z  in response to FransvanderReijden
    Hi Frans, is an Oracle library which has
    been somewhat troublesome for Purify over the years.
    I believe it's built with the Intel compiler and
    IBM has made numerous fixes to address these issues
    in the last few years. The latest official release
    on Linux/UNIX is 7.0.1 iFix 002, and it's available

    However, please contact IBM Tech Support to get access
    to even newer builds which may contain the fix you
    need. In the US/Canada, you can call 1-800-IBM-SERV.
    Be sure to have your IBM Customer Number when you call.

    • FransvanderReijden
      10 Posts

      Re: Problems instrumenting

      ‏2012-06-21T06:01:46Z  in response to SystemAdmin
      Thanks Don, that did the trick. can be instrumented with Purify 7.0.1 iFix 002.

      • This reply was deleted by jfletcher1 2013-05-30T13:52:51Z.
  • jfletcher1
    2 Posts

    Re: Problems instrumenting

    ‏2013-05-30T13:54:10Z  in response to FransvanderReijden
    Hi Don,

    I am also having similar kind of issue with purify plus instrumenting with oracle11g. 

    We used to have purifyplus perfectly working with our oracle 9 database, and we failed to make it work after we migrated our oracle to 11g. 

    I'm not sure whether I am doing something wrong or not. but it worked well with oracle 9x.

    Do i have to do something to get it worked with oracle 11g?

    here are some of the info about my configurations: 

    $ purify -version

    Version 100917 Solaris SPARC
    $ uname -a
    SunOS romulus 5.10 Generic_141414-07 sun4u sparc SUNW,SPARC-Enterprise
    $ cc -V
    cc: Sun C 5.9 SunOS_sparc Patch 124867-01 2007/07/12
    usage: cc [ options] files.  Use 'cc -flags' for details

    $echo $ORACLE_HOME



    please do needful.