Topic
  • 7 replies
  • Latest Post - ‏2013-02-27T06:59:04Z by SystemAdmin
SystemAdmin
SystemAdmin
9111 Posts

Pinned topic problems with the IBM x3650 M2 server

‏2012-06-15T06:33:46Z |
Hi all!

Every day receive the following notice from the Mega RAID Storage Manager: "Controller ID: 0 Battery has failed and cannot support data retention. Please replace the battery". But in the program the battery status is OK. All drivers are updated. The problem remained. The log is attached.

Thanks in advance.
Updated on 2013-02-27T06:59:04Z at 2013-02-27T06:59:04Z by SystemAdmin
  • wonbin
    wonbin
    31 Posts

    Re: problems with the IBM x3650 M2 server

    ‏2012-06-15T08:05:12Z  
    Hi Kayukov,

    I see you log and found your firmware were quite old. Please update some fw with below link
    1. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_sraidmr_m5000-12.12.0-0111_windows_32-64
    2. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_exp_6gb-sas-602a_windows_32-64
    3. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_exp_6gb-2500-60bg.02_windows_32-64
    4. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=qlgc_dd_fc_stor-9.1.9.25_windows_32-64
    5. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_mptsas_1.31.02.00_windows_32-64
    6. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_sraidmr_5.2.127_windows_32-64
    7. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_mpt2sas_2.00.45_windows_32-64

    Reboot your machine after update these fw.
    I hope you can fix this problem, otherwise replace the new battery for your Raid card.

    wonbin
  • SystemAdmin
    SystemAdmin
    9111 Posts

    Re: problems with the IBM x3650 M2 server

    ‏2012-06-15T11:43:53Z  
    • wonbin
    • ‏2012-06-15T08:05:12Z
    Hi Kayukov,

    I see you log and found your firmware were quite old. Please update some fw with below link
    1. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_sraidmr_m5000-12.12.0-0111_windows_32-64
    2. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_exp_6gb-sas-602a_windows_32-64
    3. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_exp_6gb-2500-60bg.02_windows_32-64
    4. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=qlgc_dd_fc_stor-9.1.9.25_windows_32-64
    5. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_mptsas_1.31.02.00_windows_32-64
    6. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_sraidmr_5.2.127_windows_32-64
    7. http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_mpt2sas_2.00.45_windows_32-64

    Reboot your machine after update these fw.
    I hope you can fix this problem, otherwise replace the new battery for your Raid card.

    wonbin
    1.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_sraidmr_m5000-12.12.0-0111_windows_32-64

    Update OK

    2.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_exp_6gb-sas-602a_windows_32-64

    Updated but after reboot installed version old 0.58 (I don’t know why)

    3.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_exp_6gb-2500-60bg.02_windows_32-64
    IBM 6Gb 2500 Series SAS Expander Card Installed version undetected (Why? Maybe I don’t have this device?)
    4.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=qlgc_dd_fc_stor-9.1.9.25_windows_32-64

    Updated but after reboot installed version old 9.1.8.6 (I don’t know why) and ql2300.sys (stopped)

    5.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_mptsas_1.31.02.00_windows_32-64

    The same like in previous one

    6.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_sraidmr_5.2.127_windows_32-64

    Update OK

    7.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_mpt2sas_2.00.45_windows_32-64

    IBM UXSP don’t know this driver

    I updated it from IBM UXSP and manual - the same result.

    New DSA log attached.

    the problem is not resolved
  • maguro
    maguro
    14 Posts

    Re: problems with the IBM x3650 M2 server

    ‏2012-06-15T15:58:23Z  
    1.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_sraidmr_m5000-12.12.0-0111_windows_32-64

    Update OK

    2.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_exp_6gb-sas-602a_windows_32-64

    Updated but after reboot installed version old 0.58 (I don’t know why)

    3.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_fw_exp_6gb-2500-60bg.02_windows_32-64
    IBM 6Gb 2500 Series SAS Expander Card Installed version undetected (Why? Maybe I don’t have this device?)
    4.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=qlgc_dd_fc_stor-9.1.9.25_windows_32-64

    Updated but after reboot installed version old 9.1.8.6 (I don’t know why) and ql2300.sys (stopped)

    5.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_mptsas_1.31.02.00_windows_32-64

    The same like in previous one

    6.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_sraidmr_5.2.127_windows_32-64

    Update OK

    7.http://www.ibm.com/support/fixcentral/systemx/quickorder?fixIds=ibm_dd_mpt2sas_2.00.45_windows_32-64

    IBM UXSP don’t know this driver

    I updated it from IBM UXSP and manual - the same result.

    New DSA log attached.

    the problem is not resolved
    The raw data from the M5015 controller shows that the battery needs to be replaced :

    BBU Firmware Status:

    Charging Status : None
    Voltage : OK
    Temperature : OK
    Learn Cycle Requested : No
    Learn Cycle Active : No
    Learn Cycle Status : OK
    Learn Cycle Timeout : No
    I2c Errors Detected : No
    Battery Pack Missing : No
    Battery Replacement required : Yes
    Remaining Capacity Low : No
    Periodic Learn Required : No

    Before you do anything, try forcing a manual relearn via Megaraid storage manager so that it can re-gauge the battery.
  • SystemAdmin
    SystemAdmin
    9111 Posts

    Re: problems with the IBM x3650 M2 server

    ‏2012-06-15T17:53:26Z  
    • maguro
    • ‏2012-06-15T15:58:23Z
    The raw data from the M5015 controller shows that the battery needs to be replaced :

    BBU Firmware Status:

    Charging Status : None
    Voltage : OK
    Temperature : OK
    Learn Cycle Requested : No
    Learn Cycle Active : No
    Learn Cycle Status : OK
    Learn Cycle Timeout : No
    I2c Errors Detected : No
    Battery Pack Missing : No
    Battery Replacement required : Yes
    Remaining Capacity Low : No
    Periodic Learn Required : No

    Before you do anything, try forcing a manual relearn via Megaraid storage manager so that it can re-gauge the battery.
    Okay, so why the OK status BBU in Mega raid manager?
  • SystemAdmin
    SystemAdmin
    9111 Posts

    Re: problems with the IBM x3650 M2 server

    ‏2012-07-25T09:31:17Z  
    Okay, so why the OK status BBU in Mega raid manager?
    Hi all. I did recharge the battery manually, but it did not help. Give FRU number of batteries to order please. My controller is ServerRAID M5015, server x3650 M2 7947-PJN. Thanks in advance.
  • SystemAdmin
    SystemAdmin
    9111 Posts

    Re: problems with the IBM x3650 M2 server

    ‏2012-09-22T07:10:28Z  
    Hi all. I did recharge the battery manually, but it did not help. Give FRU number of batteries to order please. My controller is ServerRAID M5015, server x3650 M2 7947-PJN. Thanks in advance.
    Hi, did battery replacement solved the problem?
  • SystemAdmin
    SystemAdmin
    9111 Posts

    Re: problems with the IBM x3650 M2 server

    ‏2013-02-27T06:59:04Z  
    Hi, did battery replacement solved the problem?
    Yes it solved the problem. IBM recommends replacing the battery after one (1) year of service.