Topic
  • 1 reply
  • Latest Post - ‏2012-06-15T19:45:56Z by SystemAdmin
BV8C_Michael_Tsay
BV8C_Michael_Tsay
3 Posts

Pinned topic Registring New OS Agents to Tivoli Environment

‏2012-06-14T00:44:27Z |
I've added OS Agents to several new LPARs, and am having difficulty getting them to appear in the warehouse.

The new OS agents are in the same Distribution Grouping on the TEP as the ones that do appear.

I've run the following

db2 -tf gen_resources.db2
db2 -td@ -vf populate_resources.db2

db2 call ITMUSER.POPULATE_OSAGENTS();
select * from ITMUSER.ManagedSystem

But the values in ITMUSER.ManagedSystem are only the systems that were there when I first installed.

Suggestions?
Updated on 2012-06-15T19:45:56Z at 2012-06-15T19:45:56Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    373 Posts

    Re: Registring New OS Agents to Tivoli Environment

    ‏2012-06-15T19:45:56Z  
    Hi,
    Like you've started, I think it's best to finish tracing the issue back. If ManagedSystem does not have the new values, have a look at where this table gets them from. The populate_resources.db2 script lists the 3 tables the hostnames come from:
    ITMUSER."Linux_IP_Address_DV"
    ITMUSER."UNIX_IP_Address_DV"
    ITMUSER."NT_Computer_Information_DV"
    Have a look at these tables for your host names. If they are in there, then the stored procedure isn't running correctly for some reason. If they are not in those 3 tables, then go back to ITM to see why it's not summarizing the data into those daily tables.
    I hope that helps, Dan Krissell