Topic
6 replies Latest Post - ‏2013-02-25T14:06:17Z by RafiqAli195
SystemAdmin
SystemAdmin
570 Posts
ACCEPTED ANSWER

Pinned topic HTTP Adapter Query

‏2012-05-14T12:25:39Z |
Hi,

I've just followed the tutorial to create a HTTP Adapter, but the output is not as I would have expected. When I click on 'Invoke Worklight Procedure' and execute either of the procedures created, I get this type of error message:

{
"errors": ,
"info": [],
"isSuccessful": false,
"warnings": []
}

whatever I try I get an UnknownHostException. Can somebody please help me out with this?

Thanks,

Steve
  • IdanAdar
    IdanAdar
    288 Posts
    ACCEPTED ANSWER

    Re: HTTP Adapter Query

    ‏2012-05-14T13:16:44Z  in response to SystemAdmin
    Are you refering to Module 5.2? (http://www.worklight.com/download/get-started/4.2.1/module-5.2)
    That module refers to cnn.com, while you point to engadget.

    How did you creat your adapter exactly, please?
  • SystemAdmin
    SystemAdmin
    570 Posts
    ACCEPTED ANSWER

    Re: HTTP Adapter Query

    ‏2012-05-14T13:24:17Z  in response to SystemAdmin
    Hi, yes I am referring to that one.

    In the example, the cnn rss feed works fine. The exercise at the end of that tutorial asks you to do it for engadget and provides the rss feed address, but it didn't work. I just wondered why it wasn't successful.

    Thanks.
  • IdanAdar
    IdanAdar
    288 Posts
    ACCEPTED ANSWER

    Re: HTTP Adapter Query

    ‏2012-05-14T15:22:59Z  in response to SystemAdmin
    And are you also using Worklight 4.2.1 or a different version?
  • SystemAdmin
    SystemAdmin
    570 Posts
    ACCEPTED ANSWER

    Re: HTTP Adapter Query

    ‏2012-05-14T15:35:28Z  in response to SystemAdmin
    I'm using 4.2.2
  • IdanAdar
    IdanAdar
    288 Posts
    ACCEPTED ANSWER

    Re: HTTP Adapter Query

    ‏2012-05-14T17:10:59Z  in response to SystemAdmin
    Is your attempt at creating the adapter the same as the solution provided in the zip file?
    • RafiqAli195
      RafiqAli195
      1 Post
      ACCEPTED ANSWER

      Re: HTTP Adapter Query

      ‏2013-02-25T14:06:17Z  in response to IdanAdar
      yes i'm also getting the same error and i'm using worklight 5.0.
      Could u lend some help?