Topic
1 reply Latest Post - ‏2012-04-27T16:19:06Z by SystemAdmin
SystemAdmin
SystemAdmin
570 Posts
ACCEPTED ANSWER

Pinned topic [Solved] http adapter troubleshooting with fiddler

‏2012-04-27T13:57:22Z |
I am trying to troubleshoot an http adapter I've written by sending adapter traffic through Fiddler, running on localhost port 8888. I've tried setting fiddler to "capture traffic" but this is not honored by the WL server running on my local workstation.

I've read the Developer Reference Guide for 4.2.1, and have tried this connection policy in my adapter XML. Still, no traffic through fiddler:


<connectivity> <connectionPolicy xsi:type=
"http:HTTPConnectionPolicyType"> <protocol>http</protocol> <domain>myhostname.mydomain.com</domain> <port>10039</port> <!-- send adapter traffic through fiddler --> <proxy> <protocol>http</protocol> <domain>localhost</domain> <port>8888</port> </proxy> </connectionPolicy> <loadConstraints maxConcurrentConnectionsPerNode=
"8" /> </connectivity>

Of course, myhost.mydomain.com is replaced with my actual local workstation hostname.

I have confirmed fiddler is accepting requests by using other applications and manually setting their proxy settings similar to the above. Fiddler is not set to require authentication; I have also tried (with no luck) setting an <authentication><basic/></authentication> block within <proxy>.

Any thoughts?

Thanks,

Scott H
  • SystemAdmin
    SystemAdmin
    570 Posts
    ACCEPTED ANSWER

    Re: [Solved] http adapter troubleshooting with fiddler

    ‏2012-04-27T16:19:06Z  in response to SystemAdmin
    The <proxy> configuration is working as documented in WL. The problem was my default fiddler configuration was filtering out WL process's requests.

    The problem was I didn't realize Fiddler was set (default) to filter out rows from non-browser processes (was set to "Web Browsers").

    Setting fiddler's process filter - in the status bar at the bottom of the screen - to "All processes" now shows me WL adapter requests.