Topic
5 replies Latest Post - ‏2012-04-11T08:04:43Z by IdanAdar
SystemAdmin
SystemAdmin
570 Posts
ACCEPTED ANSWER

Pinned topic Trainnig module 20.1 (SingleStepAdapterBasedAuthentication) issue

‏2012-04-11T04:24:10Z |
Hi There,
I'm trying to running the application provided within the training module 20.1, but when a preview the application from WL console, the SingleStepAdapterBasedAuthentication.html page is never ready (loading icon running forever.
Looking in the Firebug console I found this error:

wlclient init started
\$ is not defined
\$("AuthSubmitButton").observe('click', AuthSubmitButtonClicked);
auth.js (line 21)

For completeness' sake, I customized the authenticationConfig.xml in WL server and I've deployed the provided adapter.

Where the \$ reference should be defined?

Thanks, Giovanni
  • IdanAdar
    IdanAdar
    288 Posts
    ACCEPTED ANSWER

    Re: Trainnig module 20.1 (SingleStepAdapterBasedAuthentication) issue

    ‏2012-04-11T04:29:13Z  in response to SystemAdmin
    Can you please give us some information about your setup version? Which Worklight version and build is this?
    Trying to guess, I would say that you are running the interal jQuery edition and using samples that are not updated to work with jQuery. Am I in the right direction here?
  • SystemAdmin
    SystemAdmin
    570 Posts
    ACCEPTED ANSWER

    Re: Trainnig module 20.1 (SingleStepAdapterBasedAuthentication) issue

    ‏2012-04-11T06:44:46Z  in response to SystemAdmin
    Hi Idan,

    thanks for quick reply. When I saw "\$" I thought to jquery as well but because it's a WL module, I thought it was "self-contained"
    I'm running WL Studio 4.2.2.jq1290 and WL server Build Version: 4.2.2.1283.
    I've just downloaded and tested (with the same result) the module from this site:
    http://www.worklight.com/download/get-started/4.2.1/
    .
    Giovanni
  • IdanAdar
    IdanAdar
    288 Posts
    ACCEPTED ANSWER

    Re: Trainnig module 20.1 (SingleStepAdapterBasedAuthentication) issue

    ‏2012-04-11T07:11:54Z  in response to SystemAdmin
    You are using an internal version that contains partial work moving to jQquery. You are using it with samples that are not meant to work with jQuery, hence the failures. You are also using it with a mismatching Server version. Not all samples have yet to be ported to support jQuery... when the next official release comes, they will all work.
  • SystemAdmin
    SystemAdmin
    570 Posts
    ACCEPTED ANSWER

    Re: Trainnig module 20.1 (SingleStepAdapterBasedAuthentication) issue

    ‏2012-04-11T07:52:51Z  in response to SystemAdmin
    Thanks Idan,

    is that a version of the training module that I can use with this installation? My goal is to understand with an example how to use the adapter authentication and then apply that to another project.

    Cheers
  • IdanAdar
    IdanAdar
    288 Posts
    ACCEPTED ANSWER

    Re: Trainnig module 20.1 (SingleStepAdapterBasedAuthentication) issue

    ‏2012-04-11T08:04:43Z  in response to SystemAdmin
    For that purpose you install Worklight (Server and Studio) 4.2.1, or the 'regular' 4.2.2 and follow the modules in the Get Started page to better understand the Worklight feature set, including adapter authentication in the more advanced modules.