Topic
11 replies Latest Post - ‏2012-03-05T08:15:49Z by SystemAdmin
SystemAdmin
SystemAdmin
76 Posts
ACCEPTED ANSWER

Pinned topic sample application problem

‏2011-02-23T20:41:02Z |
I've made all like in instruction. Start application as android application and I have the web page file:///adroid_assets/... couldn't be loaded. What I missed?
  • SystemAdmin
    SystemAdmin
    76 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2011-02-23T20:46:29Z  in response to SystemAdmin
    My guess is that you have not yet run the command "build application on WorkLight server" (right click on the WorkLight App)
  • SystemAdmin
    SystemAdmin
    76 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2011-02-24T12:54:12Z  in response to SystemAdmin
    i've got another problem after running it application crashed with such message. Application is absolutely default. I've just added h1 message to message section in html
    2011-02-23 22:47:11 - ddmsnull
    java.lang.NullPointerException
    at com.android.ddmlib.JdwpPacket.writeAndConsume(JdwpPacket.java:213)
    at com.android.ddmlib.Client.sendAndConsume(Client.java:574)
    at com.android.ddmlib.HandleHello.sendHELO(HandleHello.java:142)
    at com.android.ddmlib.HandleHello.sendHelloCommands(HandleHello.java:65)
    at com.android.ddmlib.Client.getJdwpPacket(Client.java:671)
    at com.android.ddmlib.MonitorThread.processClientActivity(MonitorThread.java:317)
    at com.android.ddmlib.MonitorThread.run(MonitorThread.java:263)
  • IdanAdar
    IdanAdar
    19 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2011-02-25T12:24:54Z  in response to SystemAdmin
    Do you mean you have created the application by following the instructions, or are you using the provided solution and only added to it an H1 element?

    In either case, lets try this:
    1. Please create a new WorkLight project
    2. Create an app for the project
    3. Add Android environment
    4. Build the app
    5. Finally, run it using the Android simulator

    Do you still encounter issues with this app as well? Any additional error messages in the Eclipse Console?
  • SystemAdmin
    SystemAdmin
    76 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2011-02-25T15:40:27Z  in response to SystemAdmin
    yes I've made all those steps. Application is loading but that showing wait dialog and app is crashing. Application is absolutely empty. Error's I've posted in my previous message.
  • SystemAdmin
    SystemAdmin
    76 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2011-02-25T19:33:25Z  in response to SystemAdmin
    I've made all those operations again. I didn't modify source code. I just create sample application from scratch build it and run on android emulator. It shows me white screen from start than show's "loading" and died.
  • IdanAdar
    IdanAdar
    19 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2011-02-27T07:07:18Z  in response to SystemAdmin
    The HelloWorkLight sample applications is building and working properly in my development environment, so let us take a step back.

    The errors provided in your previous post are not coming from WorkLight, but from a component of the Android plug-in for Eclipse (DDMS), so let us be sure your environment is set-up properly.

    To be sure this is not coming from WorkLight, you can create in Eclipse a new Android application and run this application in the Android simulator. If this fails as well, there is indeed a problem in your development environment setup.

    In addition, if you could please provide us with the version numbers of the following (it is advised for them to be the latest released versions):

    WorkLight Server & plug-in
    Eclipse Helios JEE
    Android SDK and plug-in for Eclipse
  • SystemAdmin
    SystemAdmin
    76 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2012-03-05T07:09:14Z  in response to SystemAdmin
    Dear all,

    I get same error, I just create a blank application, nothing updated after wizard created the sample application, I just built all and deployed and then run it on an AVD.

    All coding are generated.

    == error log extracted from LogCat of ADT ==
    I/Database(599): sqlite returned: error code = 14, msg = cannot open file at source line 25467
    D/FirstApp(599): wlclient init started
    D/dalvikvm(599): GC_EXTERNAL_ALLOC freed 621K, 54% free 3104K/6727K, external 2061K/2137K, paused 89ms
    D/FirstApp(599): Read cookies: null
    D/FirstApp(599): CookieMgr read cookies: {}
    W/dalvikvm(599): JNI WARNING: jarray 0x40514190 points to non-array object (Ljava/lang/String;)
    I/dalvikvm(599): "WebViewCoreThread" prio=5 tid=8 NATIVE
    I/dalvikvm(599): | group="main" sCount=0 dsCount=0 obj=0x405202e8 self=0x29e2e0
    I/dalvikvm(599): | sysTid=606 nice=0 sched=0/0 cgrp=default handle=2755720
    I/dalvikvm(599): | schedstat=( 5647506798 1892590981 379 )
    I/dalvikvm(599): at android.webkit.JWebCoreJavaBridge.sharedTimerFired(Native Method)
    I/dalvikvm(599): at android.webkit.JWebCoreJavaBridge.sharedTimerFired(Native Method)
    I/dalvikvm(599): at android.webkit.JWebCoreJavaBridge.fireSharedTimer(JWebCoreJavaBridge.java:91)
    I/dalvikvm(599): at android.webkit.JWebCoreJavaBridge.handleMessage(JWebCoreJavaBridge.java:108)
    I/dalvikvm(599): at android.os.Handler.dispatchMessage(Handler.java:99)
    I/dalvikvm(599): at android.os.Looper.loop(Looper.java:123)
    I/dalvikvm(599): at android.webkit.WebViewCore\$WebCoreThread.run(WebViewCore.java:629)
    I/dalvikvm(599): at java.lang.Thread.run(Thread.java:1019)
    E/dalvikvm(599): VM aborting
  • IdanAdar
    IdanAdar
    19 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2012-03-05T07:32:58Z  in response to SystemAdmin
    Are you by chance using Android 2.3 as the OS of the AVD?
  • SystemAdmin
    SystemAdmin
    76 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2012-03-05T07:47:04Z  in response to SystemAdmin
    Hi, Idan,

    I'm using Android 2.3.3 as O/S of the AVD. Which Android Level expected?

    thanks.
    Daniel.
  • IdanAdar
    IdanAdar
    19 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2012-03-05T08:12:40Z  in response to SystemAdmin
    There is a documented bug by Google where Android v2.3 does not work in AVD.
    You can use v2.3 on a device and it will work well.
    You can also use any other version in the simulator and it will work as well.
  • SystemAdmin
    SystemAdmin
    76 Posts
    ACCEPTED ANSWER

    Re: sample application problem

    ‏2012-03-05T08:15:49Z  in response to SystemAdmin
    Hi, Idan,

    thanks, I just run it on Android 2.2 without exceptions.

    Daniel.