Topic
  • No replies
IdanAdar
IdanAdar
40 Posts

Pinned topic Installing the WorkLight Studio Eclipse plug-in fails

‏2011-03-24T14:40:25Z |
Installation of the WorkLight plug-in may fail, for various reasons.
This thread will be updated as scenarios are found, and a solution will be provided.

Problem: Java version
During installation of the WorkLight plug-in, an error occours with the following details:
An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
Solution: edit eclipse.ini for the new Java version number
If updating the installed java JDK after Eclipse has already been installed, it is also required to update eclipse.ini with the updated Java JDK version number.