Topic
8 replies Latest Post - ‏2012-04-06T13:21:49Z by SystemAdmin
SystemAdmin
SystemAdmin
106 Posts
ACCEPTED ANSWER

Pinned topic Couldn't deploy application to console.

‏2012-02-15T08:28:05Z |
I'm trying to build my first application follow http://www.worklight.com/download/get-started/4.2.1/module-3.
After I selected the app project and right clicked on it to click the "Build All and Deploy", nothing happened in my console. I need use Win7 instead of XP? or anything wrong with my browser? :shock:
  • IdanAdar
    IdanAdar
    40 Posts
    ACCEPTED ANSWER

    Re: Couldn't deploy application to console.

    ‏2012-02-15T08:35:34Z  in response to SystemAdmin
    Hi,

    1. Was anything printed in the Eclipse console after choosing to build and deploy?
    2. Can you please look at the server.log file, located in <serverInstallationDirectory>/server/logs and see what if anything was logged there?

    Thanks,
  • SystemAdmin
    SystemAdmin
    106 Posts
    ACCEPTED ANSWER

    Re: Couldn't deploy application to console.

    ‏2012-02-15T08:48:55Z  in response to SystemAdmin
    Hi Idan,
    1. Nothing printed in console of the Eclipse, I am using Eclipse GALILEO.
    2. You can see the server.log in attachment. No log in <serverInstallationDirectory>\\Worklight\\server\\log\\error and <serverInstallationDirectory>\\Worklight\\server\\log\\audit
  • IdanAdar
    IdanAdar
    40 Posts
    ACCEPTED ANSWER

    Re: Couldn't deploy application to console.

    ‏2012-02-15T09:09:07Z  in response to SystemAdmin
    ianli,

    We do not support Eclipse Galileo.
    Please install Eclipse Helios or Eclipse Indigo and see if the problem persists.
  • SystemAdmin
    SystemAdmin
    106 Posts
    ACCEPTED ANSWER

    Re: Couldn't deploy application to console.

    ‏2012-02-15T13:24:14Z  in response to SystemAdmin
    Hi Idan,
    Eclipse Helios works well. Thanks. ;)
  • IdanAdar
    IdanAdar
    40 Posts
    ACCEPTED ANSWER

    Re: Couldn't deploy application to console.

    ‏2012-02-15T13:29:41Z  in response to SystemAdmin
    Excellent news. :)
  • SystemAdmin
    SystemAdmin
    106 Posts
    ACCEPTED ANSWER

    Re: Couldn't deploy application to console.

    ‏2012-04-05T14:34:32Z  in response to SystemAdmin
    Good day to you!

    Our company decided to research this new feature platform.

    But I had the same problem on first tutorial steps. I had error for simple worklight application on build stage:
    2012-04-05 17:12:48 common build failed: Unable to copy file C:\Users\ADCEE~1.KUZ\AppData\Local\Temp\wlBuildResources\jslib\common\common\js\busy.js to C:\Users\ADCEE~1.KUZ\AppData\Local\Temp\worklightBuildcommon8194331308986470867\preview\default\common\js\busy.js

    Note:
    • All rights have been set for this Temp folder.
    • Eclipse has been run with Administrator rights.
    • I tried to run this example on friend's computers (Win7). But he had the same problem.
    • All worklight server's logs don't contain any error info about this.

    My Info:
    • Win7
    • Eclipse Indigo Release (20110615-0604) Java EE IDE for Web Developers.
    (Eclipse is out of C:\\Programs Files)

    Help please. Do you have any ideas about this magic?
    And where i can set path to worklight temp directory?
  • IdanAdar
    IdanAdar
    40 Posts
    ACCEPTED ANSWER

    Re: Couldn't deploy application to console.

    ‏2012-04-05T16:50:51Z  in response to SystemAdmin
    This doesn't sound like the same issue as the thread's opener question...

    According the Google, the temp folder is located here ;)
    C:\\Users\\<username>\\AppData\\Local\\Temp

    • try to delete this folder and re-build the application.
    • please elaborate what exactly you've done
    • pleae do this in a separate thread...
  • SystemAdmin
    SystemAdmin
    106 Posts
    ACCEPTED ANSWER

    Re: Couldn't deploy application to console.

    ‏2012-04-06T13:21:49Z  in response to SystemAdmin
    Created new thread
    viewtopic.php?f=6&t=1518&p=2524&sid=0e76d763cc6ae818de639d52436ed45f#p2524