Topic
3 replies Latest Post - ‏2011-03-24T13:53:52Z by SystemAdmin
SystemAdmin
SystemAdmin
106 Posts
ACCEPTED ANSWER

Pinned topic Error Installing Worklight Studio (An error occurred during the org.eclipse.equinox.internal.prov)

‏2010-09-06T11:04:18Z |
Dear Friends,

I was having challenges while installing worklight studio via my proxy, so I have to pass the proxy in order to move forward but during the course I had this error:

An error occurred during the org.eclipse.equinox.internal.provisional.p2.engine.phases.CheckTrust phase.
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.CheckTrust, operand=, action=).
One or more certificates rejected. Cannot proceed with installation
Kindly assist

Jude Orhotowho
  • SystemAdmin
    SystemAdmin
    106 Posts
    ACCEPTED ANSWER

    Re: Error Installing Worklight Studio (An error occurred during the org.eclipse.equinox.internal.prov)

    ‏2010-09-26T14:38:02Z  in response to SystemAdmin
    Hi Jude,

    Your problem relates to a known Eclipse bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=309059

    What Java version are you using?
    What Eclipse version are you using?

    Cheers,
    Alik.
  • SystemAdmin
    SystemAdmin
    106 Posts
    ACCEPTED ANSWER

    Re: Error Installing Worklight Studio (An error occurred during the org.eclipse.equinox.internal.prov)

    ‏2011-03-24T13:23:13Z  in response to SystemAdmin
    I am now having this same issue but am unable to resolve:

    An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
    session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).

    Eclipse Version is: Helios Service Release 2
    Java Version is: jdk1.6.0_21

    Any help?
  • SystemAdmin
    SystemAdmin
    106 Posts
    ACCEPTED ANSWER

    Re: Error Installing Worklight Studio (An error occurred during the org.eclipse.equinox.internal.prov)

    ‏2011-03-24T13:53:52Z  in response to SystemAdmin
    Finally got plug-in to install after I forced eclipse to Java 1.6
    -Dosgi.requiredJavaVersion=1.6
    and then ran Check for updates in Eclipse which must have pulled something down that fixed the eclipse issue