Topic
  • 7 replies
  • Latest Post - ‏2012-06-15T13:06:52Z by Sunit
SystemAdmin
SystemAdmin
3908 Posts

Pinned topic Unable access the application

‏2012-06-09T06:37:29Z |
Hi,

I have mapped the IHS 8.0 with WAS 8.0
And I have configured the IHS http port as 1085 instead of 80.
I'm unable to access the applications like snoop,hello and etc through the port 1085.
But I'm able access my application via port 80.

Kindly help me to resolve this problem.

Regards,
JagadesH L.
Updated on 2012-06-15T13:06:52Z at 2012-06-15T13:06:52Z by Sunit
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: Unable access the application

    ‏2012-06-09T11:14:33Z  
    you have to edit the default_host vhost in WAS to include the frontend port (1085) the request arrives on, otherwise the plugin will not think it's responsible for handling the incoming request.
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: Unable access the application

    ‏2012-06-09T11:38:08Z  
    you have to edit the default_host vhost in WAS to include the frontend port (1085) the request arrives on, otherwise the plugin will not think it's responsible for handling the incoming request.
    Hi Eric,

    Thanks for your reply.
    I have updated the plugin-cfg.xml by adding port 1085 in the virtual host.
    But still its not forwarding the incoming request to the corresponding appserver.
    Regards,
    JagadesH L.
  • Sunit
    Sunit
    196 Posts

    Re: Unable access the application

    ‏2012-06-09T13:36:31Z  
    Hi Eric,

    Thanks for your reply.
    I have updated the plugin-cfg.xml by adding port 1085 in the virtual host.
    But still its not forwarding the incoming request to the corresponding appserver.
    Regards,
    JagadesH L.
    What you have to do is:

    1. Add port 1085 to the virtual host in WAS admin console.
    2. Regenerate the plugin
    3. Copy the Regenerated plugin-cfg.xml file to the location usied by IHS.
    4. Restart WAS and IHS.

    • Sunit
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: Unable access the application

    ‏2012-06-09T13:59:27Z  
    • Sunit
    • ‏2012-06-09T13:36:31Z
    What you have to do is:

    1. Add port 1085 to the virtual host in WAS admin console.
    2. Regenerate the plugin
    3. Copy the Regenerated plugin-cfg.xml file to the location usied by IHS.
    4. Restart WAS and IHS.

    • Sunit
    Hi Sunit,

    I have followed these steps and still i'm unable to access the application in the port 1085.
    But I can access the home page of IHS (ie.,) http://localhost:1085/

    Kindly help me to resolve this situation.

    Regards,
    JagadesH L.
  • Sunit
    Sunit
    196 Posts

    Re: Unable access the application

    ‏2012-06-11T13:24:11Z  
    Hi Sunit,

    I have followed these steps and still i'm unable to access the application in the port 1085.
    But I can access the home page of IHS (ie.,) http://localhost:1085/

    Kindly help me to resolve this situation.

    Regards,
    JagadesH L.
    What do the plugin logs indicate?

    • Sunit
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: Unable access the application

    ‏2012-06-15T07:20:37Z  
    • Sunit
    • ‏2012-06-11T13:24:11Z
    What do the plugin logs indicate?

    • Sunit
    Hi Sunit,

    The log file "http_plugin.log" is not getting generated.
    Kindly guide me to resolve it.

    Regards,
    JagadesH L.
  • Sunit
    Sunit
    196 Posts

    Re: Unable access the application

    ‏2012-06-15T13:06:52Z  
    Hi Sunit,

    The log file "http_plugin.log" is not getting generated.
    Kindly guide me to resolve it.

    Regards,
    JagadesH L.
    Are you certain that you have configured the plugin correctly?

    Please post the httpd.conf file or the relevant lines from httpd.conf where the plugin load module is configured and the plgin-cfg.xml file it is pointing to. Also post the plugin-cfg.xml file you are using.

    • Sunit