Topic
  • 4 replies
  • Latest Post - ‏2012-11-20T15:42:02Z by SystemAdmin
vemorris
vemorris
3 Posts

Pinned topic Rational Developer for System z 8.0.3 and Ubuntu 11.10 Installation Issues

‏2012-06-07T20:52:33Z |
I'm attempting to install RDz 8.0.3 with Java on a fresh install of Ubuntu 11.10 and am seeing the following error:


The 

package IBM Rational Developer 

for System z with Java requires system library libstdc++.so.5 or libstdc++.so.6. Make sure libstdc++.so.5 or libstdc++.so.6 is available in the system library path before installing 

this package.


I had this issue before, posted on this forum, and was able to fix it via install of libstdc++5, but this does not fix my issue now.

Any assistance would be appreciated, thanks.

-Vance
Updated on 2012-11-20T15:42:02Z at 2012-11-20T15:42:02Z by SystemAdmin
  • vemorris
    vemorris
    3 Posts

    Re: Rational Developer for System z 8.0.3 and Ubuntu 11.10 Installation Issues

    ‏2012-06-07T20:56:57Z  
    I should add:

    
    vance@vance-ThinkPad-W520:/etc/ld.so.conf.d$ ldconfig -p | grep libstdc++ libstdc++.so.6 (libc6) => /usr/lib/i386-linux-gnu/libstdc++.so.6 libstdc++.so.5 (libc6) => /usr/lib/i386-linux-gnu/libstdc++.so.5
    


    This is the 32-bit version of the OS... any clues?
  • vemorris
    vemorris
    3 Posts

    Re: Rational Developer for System z 8.0.3 and Ubuntu 11.10 Installation Issues

    ‏2012-06-08T12:54:18Z  
    Fixed it.

    There needs to be a symlink to libstdc++ in /usr/lib for RDz to install properly.

    Before, I was seeing this:
    
    $ ldconfig -p | grep libstdc++ libstdc++.so.6 (libc6) => /usr/lib/i386-linux-gnu/libstdc++.so.6 libstdc++.so.5 (libc6) => /usr/lib/i386-linux-gnu/libstdc++.so.5
    

    The fix:
    
    sudo ln -s /usr/lib/i386-linux-gnu/libstdc++.so.6 /usr/lib sudo ln -s /usr/lib/i386-linux-gnu/libstdc++.so.6 /usr/lib sudo ldconfig
    

    Now I am seeing:
    
    $ ldconfig -p | grep libstdc++ libstdc++.so.6 (libc6) => /usr/lib/i386-linux-gnu/libstdc++.so.6 libstdc++.so.6 (libc6) => /usr/lib/libstdc++.so.6 libstdc++.so.5 (libc6) => /usr/lib/i386-linux-gnu/libstdc++.so.5 libstdc++.so.5 (libc6) => /usr/lib/libstdc++.so.5
    

    RDz installed without a hitch. Thanks!
  • jubincn
    jubincn
    1 Post

    Re: Rational Developer for System z 8.0.3 and Ubuntu 11.10 Installation Issues

    ‏2012-08-22T07:07:14Z  
    Thank you, it solves my problem.
  • SystemAdmin
    SystemAdmin
    1086 Posts

    Re: Rational Developer for System z 8.0.3 and Ubuntu 11.10 Installation Issues

    ‏2012-11-20T15:42:02Z  
    Hi all,

    I've encountered the same problem on the installation of IBM WebSphere Message Broker Toolkit v8 (Trial).

    The same resolution applies, creating the symbolic links for libstdc++.so.6 in /usr/lib
    Regards,
    Tiago Cavaleiro.