Topic
6 replies Latest Post - ‏2013-12-24T16:41:25Z by Myaso
JQDD_Zhu_Julie
JQDD_Zhu_Julie
1 Post
ACCEPTED ANSWER

Pinned topic Data Studio 3.1.1 and Subeclipse 1.8

‏2012-06-07T17:43:07Z |
I installed the latest version of Data Studio 3.1.1. Then I want to install Subeclipse 1.8, a plugin for Subversion, using the update site http://subclipse.tigris.org/update_1.8.x. I tried to do this twice. The first time, I installed the Mylyn 3.7.1 because the Subeclipse has an option to integrate with Mylyn. After Mylyn was installed, every time I opened the Data Studio, it closed by itself within a few second and popped up a window said "Error: Java was started but returned exit code=8096...". So I reinstalled the Data Studio and decided to install Subeclipse without the integration of Mylyn. Now I got another error that prevent me from installing it. Here is the error message.

Missing requirement: Platform Source Patch (bugzillas 337719,335860,342308,345760,342308,345549,355614,339360) 1.0.9 (org.eclipse.platform.source.R362patch.feature.group 1.0.9) requires 'org.eclipse.platform.source.feature.group http://3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi' but it could not be found
Cannot satisfy dependency:
From: Shared profile 1.0.0.1338941396997 (SharedProfile_bootProfile 1.0.0.1338941396997)
To: org.eclipse.platform.source.R362patch.feature.group http://1.0.9

I googled and found someone said it is the problem of using Eclipse 3.6. And he suggested to upgrade the Eclipse to 3.7. I don't know if this is the root cause and how to upgrade Eclipse within Data Studio.

Any suggestion is welcome!

Thanks,
Julie
Updated on 2012-12-05T20:00:57Z at 2012-12-05T20:00:57Z by frs
  • loicjulien
    loicjulien
    96 Posts
    ACCEPTED ANSWER

    Re: Data Studio 3.1.1 and Subeclipse 1.8

    ‏2012-06-07T18:40:40Z  in response to JQDD_Zhu_Julie
    Hi,

    I was able to install Subeclipse 1.6 => http://subclipse.tigris.org/update_1.6.x, luckily, this will have enough features for you. I do see the SVN perspective when I start; however, I did not do any extensive testing nor do I use subversion myself.

    If Subeclipse 1.8, requires Eclipse 3.7, this will be an issue as the Eclipse version for Data Studio cannot be updated.

    Hope this helps,
    ~Loic
    • loicjulien
      loicjulien
      96 Posts
      ACCEPTED ANSWER

      Re: Data Studio 3.1.1 and Subeclipse 1.8

      ‏2012-06-07T18:41:39Z  in response to loicjulien
      One additional note, I had to deselect Mylyn.
  • bugra
    bugra
    1 Post
    ACCEPTED ANSWER

    Re: Data Studio 3.1.1 and Subeclipse 1.8

    ‏2012-07-05T06:30:55Z  in response to JQDD_Zhu_Julie
    I assume you are trying to install subclipse on windows7. If so start Data Studio with administrator priviledges (Run as administrator) and install subclipse as usual. After the installation it will ask to restart Data Studio, disregard it and close the application. Now, when you re-start Data Studio as normal user then you will also have the Subclipse plugins available.

    Don't forget to install any subclipse upgrades also as Administrator.
    • frs
      frs
      20 Posts
      ACCEPTED ANSWER

      Re: Data Studio 3.1.1 and Subeclipse 1.8

      ‏2012-12-05T20:00:57Z  in response to bugra
      > bugra wrote:
      > I assume you are trying to install subclipse on windows7. If so start Data Studio with administrator priviledges (Run as administrator) and install subclipse as usual. After the installation it will ask to restart Data Studio, disregard it and close the application. Now, when you re-start Data Studio as normal user then you will also have the Subclipse plugins available.
      >
      > Don't forget to install any subclipse upgrades also as Administrator.

      I was also having problems installing Subclipse, and bugra's recommendation to run Data Studio as Administrator worked for me.
      My environment is 64-bit Windows 7, Data Studio 3.1.1, and Subclipse 1.8.

      Thanks for helping me solve this problem so quickly.
      -Fred
    • Myaso
      Myaso
      1 Post
      ACCEPTED ANSWER

      Re: Data Studio 3.1.1 and Subeclipse 1.8

      ‏2013-12-24T16:41:25Z  in response to bugra

      THANKS SO MUCH for this hint.

      I spent few hours playing with this silly stuff until realized this.

  • SystemAdmin
    SystemAdmin
    1632 Posts
    ACCEPTED ANSWER

    Re: Data Studio 3.1.1 and Subeclipse 1.8

    ‏2012-09-19T08:34:22Z  in response to JQDD_Zhu_Julie
    Try installing Eclipse Platform SDK.
    Regards,
    Goran