Topic
  • 15 replies
  • Latest Post - ‏2012-10-30T19:24:14Z by morganri
SystemAdmin
SystemAdmin
139 Posts

Pinned topic Can't create cloud provider on Image Construction and Composition Tools

‏2012-06-07T09:19:10Z |
Hi,

I'm trying creating VMware cloud provider using "create new cloud provider" wizard on ICCT but I get an error after clicking "Done" button.
The error message is "Failed to create cloud provider: Error: Unable to load /resources/cloudProviders status:500". Please refer to the attached file.

According to /opt/IBM/icon/icn.app/logs/access.log, it seems HTTP POST command causes this error.


10.7.12.3 - - 07/Jun/2012:18:09:42 +0900 "POST /resources/cloudProviders HTTP/1.1" 500 2238 "13673/CF-WRK: 17826064 : 1" 69930


Could you tell me any advice to create VMware cloud provider on ICCT?
Is there anyone who can create VMware cloud provider on ICCT?

My environment is as follows.

ICCT runs on RHEL 5.6 (x86-64)
ICCT: 1.1.1.39
VMware ESX Server 4.1 Update 1
Thanks in advance.
Updated on 2012-10-30T19:24:14Z at 2012-10-30T19:24:14Z by morganri
  • SystemAdmin
    SystemAdmin
    139 Posts

    Re: Can't create cloud provider on Image Construction and Composition Tools

    ‏2012-06-07T14:13:46Z  
    By setting DNS server, I can create VMware cloud provider.
    So this symptom was resolved.
  • morganri
    morganri
    109 Posts

    Re: Can't create cloud provider on Image Construction and Composition Tools

    ‏2012-06-07T14:45:14Z  
    By setting DNS server, I can create VMware cloud provider.
    So this symptom was resolved.
    Hello,

    Thanks for the update to your post. Just to be clear on my end, you are working from a SCAWS Service Instance or a regular SCE inetance when you built this?

    //Rich
  • SystemAdmin
    SystemAdmin
    139 Posts

    Re: Can't create cloud provider on Image Construction and Composition Tools

    ‏2012-06-28T02:30:56Z  
    • morganri
    • ‏2012-06-07T14:45:14Z
    Hello,

    Thanks for the update to your post. Just to be clear on my end, you are working from a SCAWS Service Instance or a regular SCE inetance when you built this?

    //Rich
    Sorry for my delay response.
    I'm using VMware ESX Server and ICCT in my lab. Not using public cloud sevices such as SCAWS and SCE.

    Actually, I have another problem which sychronization fails in VMware environment. I'll post a new thread later.

    Thanks,
  • PeteSoucek
    PeteSoucek
    1 Post

    Re: Can't create cloud provider on Image Construction and Composition Tools

    ‏2012-07-25T09:46:45Z  
    By setting DNS server, I can create VMware cloud provider.
    So this symptom was resolved.
    Hi Unicorn,

    I would like to ask you for help with ICCT 1.1 - I have the same error with creating the esxi cloud provider in ICCT.

    Please, how did you exactly solve that problem?

    Thank you very much

    Petr
  • Tomas.Lunak
    Tomas.Lunak
    2 Posts

    Re: Can't create cloud provider on Image Construction and Composition Tools

    ‏2012-07-31T08:27:09Z  
    Hi Unicorn,

    I would like to ask you for help with ICCT 1.1 - I have the same error with creating the esxi cloud provider in ICCT.

    Please, how did you exactly solve that problem?

    Thank you very much

    Petr
    Hi,

    please how do you solve problem with error message: "Failed to create cloud provider: Error: Unable to load /resources/cloudProviders status:500" ? I have same problem and I don´t know how solve it.

    Thanks, Thomas
  • SystemAdmin
    SystemAdmin
    139 Posts

    Re: Can't create cloud provider on Image Construction and Composition Tools

    ‏2012-08-08T08:34:58Z  
    Hi,

    please how do you solve problem with error message: "Failed to create cloud provider: Error: Unable to load /resources/cloudProviders status:500" ? I have same problem and I don´t know how solve it.

    Thanks, Thomas
    Hi PeteSoucek and Tomas.Lunak,

    In my environment, there is no error if DNS service are working.
    Do you have a DNS server and is it working?

    DNS server should have reverse DNS lookup.
    DNS server should resolve IP addresses to host names.

    For example, see the attached file. My DNS server resolve IP address to host name.
    10.7.12.52 -> vm01
    10.7.12.53 -> vm02
    10.7.12.54 -> vm03

    I hope this helps.
  • Tomas.Lunak
    Tomas.Lunak
    2 Posts

    Re: Can't create cloud provider on Image Construction and Composition Tools

    ‏2012-08-16T11:38:24Z  
    Hi PeteSoucek and Tomas.Lunak,

    In my environment, there is no error if DNS service are working.
    Do you have a DNS server and is it working?

    DNS server should have reverse DNS lookup.
    DNS server should resolve IP addresses to host names.

    For example, see the attached file. My DNS server resolve IP address to host name.
    10.7.12.52 -> vm01
    10.7.12.53 -> vm02
    10.7.12.54 -> vm03

    I hope this helps.
    Hi,

    in my case was problem with ESX settings. We have Resource Pools in our ESX and ICCT can't connect. So if you use resource pools you have to remove it.

    Bye and thanks Thomas
  • DheenuG
    DheenuG
    3 Posts

    Re: Can't provision only OS on Image Construction and Composition Tools

    ‏2012-10-03T05:40:37Z  
    Hi,

    in my case was problem with ESX settings. We have Resource Pools in our ESX and ICCT can't connect. So if you use resource pools you have to remove it.

    Bye and thanks Thomas
    Hi Team,

    I am using ICCT and I am unable to provision OS image alone.I tried to provision OS image alone and I am getting below error:

    CYOUI4020E: This validation is associated with a resolution that allows the state to be reset.

    Also I have attached the screenshot for your kind reference..Thank you in advance..
  • binnes
    binnes
    21 Posts

    Re: Can't provision only OS on Image Construction and Composition Tools

    ‏2012-10-04T12:12:05Z  
    • DheenuG
    • ‏2012-10-03T05:40:37Z
    Hi Team,

    I am using ICCT and I am unable to provision OS image alone.I tried to provision OS image alone and I am getting below error:

    CYOUI4020E: This validation is associated with a resolution that allows the state to be reset.

    Also I have attached the screenshot for your kind reference..Thank you in advance..
    Hello,

    I'd like to get a better understand of what you are doing, to best be able to assist you.

    Firstly can you tell me what version of ICCT you are running (Help -> About). The screen shot provided has a different style from the bundled version of ICCT supplied with the IBM Virtual Pattern Kit for Developers.

    If you are creating a virtual appliance that you want to deploy using the IBM Virtual Pattern Kit for Developers (VPKD), than can I suggest you switch to using the IWD cloud provider type. Using this cloud provider type allows you to link ICCT with the VPKD, where there is already a base image you can import into ICCT. This saves you having to do the required work to create the base image,

    If you do not want to adopt this approach then please provide the log file from your ICCT environment so I can see what the error is. You can get an archive containing the logs from the browser based UI by selecting Administer -> Download Logs, alternatively you can access the logs from the machine running the ICCT server in directory /drouter/ramdisk2/mnt/raid-volume/raid0/logs.

    It would also be useful of you could tell me what version of VMWare ESX you are running against, and confirm you have followed the instructions for creating a base image. (This rebook provides a lot of good information about creating base images : http://www.redbooks.ibm.com/abstracts/sg248042.html?Open )

    Regards,

    Brian
  • SystemAdmin
    SystemAdmin
    139 Posts

    Re: Can't provision only OS on Image Construction and Composition Tools

    ‏2012-10-29T14:19:48Z  
    • binnes
    • ‏2012-10-04T12:12:05Z
    Hello,

    I'd like to get a better understand of what you are doing, to best be able to assist you.

    Firstly can you tell me what version of ICCT you are running (Help -> About). The screen shot provided has a different style from the bundled version of ICCT supplied with the IBM Virtual Pattern Kit for Developers.

    If you are creating a virtual appliance that you want to deploy using the IBM Virtual Pattern Kit for Developers (VPKD), than can I suggest you switch to using the IWD cloud provider type. Using this cloud provider type allows you to link ICCT with the VPKD, where there is already a base image you can import into ICCT. This saves you having to do the required work to create the base image,

    If you do not want to adopt this approach then please provide the log file from your ICCT environment so I can see what the error is. You can get an archive containing the logs from the browser based UI by selecting Administer -> Download Logs, alternatively you can access the logs from the machine running the ICCT server in directory /drouter/ramdisk2/mnt/raid-volume/raid0/logs.

    It would also be useful of you could tell me what version of VMWare ESX you are running against, and confirm you have followed the instructions for creating a base image. (This rebook provides a lot of good information about creating base images : http://www.redbooks.ibm.com/abstracts/sg248042.html?Open )

    Regards,

    Brian
    Hi ,
    I've got the same error

    ICCT 1.2.0.0
    ESXi 5.0
    VClient 5.0

    CYOUI4020E: This validation is associated with a resolution that allows the state to be reset.

    I am trying to Synchronize a Base Image , and itś not work . In my logs :

    2012-10-29 13:24:15:931 CET 00000472 AddToCache2 E com.ibm.venture.vmware.ap
    pliance.actions.AddToCache2$ImageCallableForDatastore call Error creating cache
    directory on datastore
    java.util.concurrent.ExecutionException: java.lang.NullPointerException
    at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:233)
    at java.util.concurrent.FutureTask.get(FutureTask.java:94)
    at com.ibm.venture.vmware.appliance.actions.AddToCache2$ImageCallableForDatastore.call(AddToCache2.java:250)
    at com.ibm.venture.vmware.appliance.actions.AddToCache2$ImageCallableForDatastore.call(AddToCache2.java:148)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:314)
    at java.util.concurrent.FutureTask.run(FutureTask.java:149)
    at com.ibm.vespa.util.task.VSPLocalTaskHandle.run(VSPLocalTaskHandle.java:75)
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:897)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:919)

    Whatś wrong in my Cloud Providers ?
  • chrisahl
    chrisahl
    2 Posts

    Re: Can't provision only OS on Image Construction and Composition Tools

    ‏2012-10-29T15:21:59Z  
    Hi ,
    I've got the same error

    ICCT 1.2.0.0
    ESXi 5.0
    VClient 5.0

    CYOUI4020E: This validation is associated with a resolution that allows the state to be reset.

    I am trying to Synchronize a Base Image , and itś not work . In my logs :

    2012-10-29 13:24:15:931 CET 00000472 AddToCache2 E com.ibm.venture.vmware.ap
    pliance.actions.AddToCache2$ImageCallableForDatastore call Error creating cache
    directory on datastore
    java.util.concurrent.ExecutionException: java.lang.NullPointerException
    at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:233)
    at java.util.concurrent.FutureTask.get(FutureTask.java:94)
    at com.ibm.venture.vmware.appliance.actions.AddToCache2$ImageCallableForDatastore.call(AddToCache2.java:250)
    at com.ibm.venture.vmware.appliance.actions.AddToCache2$ImageCallableForDatastore.call(AddToCache2.java:148)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:314)
    at java.util.concurrent.FutureTask.run(FutureTask.java:149)
    at com.ibm.vespa.util.task.VSPLocalTaskHandle.run(VSPLocalTaskHandle.java:75)
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:897)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:919)

    Whatś wrong in my Cloud Providers ?
    Usually this issue is related to the VMware userid not having the proper permissions or ability to write to the selected datastore. Please check your VMware userid and verify that you have permission to write to the datastore.
  • DheenuG
    DheenuG
    3 Posts

    Re: Can't provision only OS on Image Construction and Composition Tools

    ‏2012-10-30T05:43:04Z  
    • chrisahl
    • ‏2012-10-29T15:21:59Z
    Usually this issue is related to the VMware userid not having the proper permissions or ability to write to the selected datastore. Please check your VMware userid and verify that you have permission to write to the datastore.
    Hello Team,

    To fix above issue ( provisioning of os image ), please try following method:

    Please try upgrading to latest version which has build 562.. ( ICCT version 1.2.0.0-562 ) ..This resolved the issue

    Thanks
    G.Dheenu
  • SystemAdmin
    SystemAdmin
    139 Posts

    Re: Can't provision only OS on Image Construction and Composition Tools

    ‏2012-10-30T13:28:01Z  
    • chrisahl
    • ‏2012-10-29T15:21:59Z
    Usually this issue is related to the VMware userid not having the proper permissions or ability to write to the selected datastore. Please check your VMware userid and verify that you have permission to write to the datastore.
    When I create my Cloud provider, 'VMware ESX', give the ESX`s credentials, root / password
    I suppose this user is using to access the DataStore, since during the synchronization does not ask me another validation.
  • SystemAdmin
    SystemAdmin
    139 Posts

    Re: Can't provision only OS on Image Construction and Composition Tools

    ‏2012-10-30T14:01:57Z  
    • DheenuG
    • ‏2012-10-30T05:43:04Z
    Hello Team,

    To fix above issue ( provisioning of os image ), please try following method:

    Please try upgrading to latest version which has build 562.. ( ICCT version 1.2.0.0-562 ) ..This resolved the issue

    Thanks
    G.Dheenu
    Where I can get ICCT version 1.2.0.0-562 ?
  • morganri
    morganri
    109 Posts

    Re: Can't provision only OS on Image Construction and Composition Tools

    ‏2012-10-30T19:24:14Z  
    Where I can get ICCT version 1.2.0.0-562 ?
    Hello,

    I believe Jennifer mentioned this earlier or on another thread. This forum is not the place for ICCT issues.

    Please see here....
    http://www.ibm.com/developerworks/forums/forum.jspa?forumID=2396&start=0