Topic
  • 4 replies
  • Latest Post - ‏2012-09-03T11:50:32Z by SystemAdmin
pglasgow4129
pglasgow4129
3 Posts

Pinned topic Error in WAS 8.0 Compute Grid Test Environment for RSA 8.0.0.4

‏2012-05-31T20:59:18Z |
I have been executing my Java Batch application without any issues for a couple of weeks until yesterday. I had to reimport some projects and did some cleaning and had made some code changes to my batch job. Then when I tried to execute it through the Job Mgmt Console, it would submit (status was submitted) but would not execute. I have tried deleting and recreating the server, deleting and recreating the profile and augmenting to the Compute Grid test environment, but I'm still getting the error below in the server SystemOut.log. Does anyone have any suggestions on why I'm getting it and what I can do to fix the problem? I'm running the Compute Grid test environment in WAS 8.0 with fixpack 1 installed.

5/31/12 15:41:48:382 CDT 00000030 XJCLPropertyS W could not resolve variable
5/31/12 15:41:48:382 CDT 00000030 XJCLPropertyS W could not resolve variable
5/31/12 15:41:49:053 CDT 00000085 WorkItemImpl I ASYN0090I: Work manager wm/BatchWorkManager is running work item GridWork Type = 100Job =
Content of com.ibm.ws.longrun.Job Object :
JobID = EE834Process:00001
Name = EE834Process
Job Class = Default
User = UNAUTHENTICATED
Application Name = MemberEligibilityBatchEAR
Application Type = j2ee
Transaction Class = null
Memory = 0
Module = null
Status Upd Count = 0
Msg Update Count = 0
Job Number = 00001
File Base = 20120531_154148
Scheduler Name = k204479Node04Cell/k204479Node04/server1
Job User Group =
jobId = nullsuspendTime = null later than expected. The work item was submitted at 0(Wed Dec 31 18:00:00 CST 1969) and is starting to run at 1338496909053(Thu May 31 15:41:49 CDT 2012).
5/31/12 15:41:49:381 CDT 00000086 WorkItemImpl I ASYN0090I: Work manager wm/default is running work item com.ibm.ws.batch.BatchJobControllerWork@20543a6 later than expected. The work item was submitted at 0(Wed Dec 31 18:00:00 CST 1969) and is starting to run at 1338496909381(Thu May 31 15:41:49 CDT 2012).
5/31/12 15:41:49:397 CDT 00000086 SystemOut O WCG is running in 32 JVM bit mode
5/31/12 15:41:49:397 CDT 00000086 SystemOut O WCG JVM current bit mode is 32
5/31/12 15:41:49:397 CDT 00000086 SystemOut O WCG is loading = WCGProcessCPU
5/31/12 15:41:49:553 CDT 00000086 batch E com.ibm.ws.batch.BatchJobControllerWork _cleanUpAndShutdownOnError ProcessCPU failed to initialize
java.lang.RuntimeException: ProcessCPU failed to initialize
at com.ibm.ws.xdcg.pmi.processcpu.ProcessCPUHelper.getInstance(ProcessCPUHelper.java:102)
at com.ibm.ws.gridcontainer.services.impl.WASUsageAccountingServiceImpl.init(WASUsageAccountingServiceImpl.java:97)
at com.ibm.ws.gridcontainer.services.ServicesManager._getServiceHelper(ServicesManager.java:663)
at com.ibm.ws.gridcontainer.services.ServicesManager.getService(ServicesManager.java:582)
at com.ibm.ws.batch.BatchJobControllerWork._initializeServices(BatchJobControllerWork.java:393)
at com.ibm.ws.batch.BatchJobControllerWork.run(BatchJobControllerWork.java:162)
at com.ibm.ws.asynchbeans.J2EEContext.run(J2EEContext.java:809)
at com.ibm.ws.asynchbeans.WorkWithExecutionContextImpl.go(WorkWithExecutionContextImpl.java:222)
at com.ibm.ws.asynchbeans.ABWorkItemImpl.run(ABWorkItemImpl.java:206)
at java.lang.Thread.run(Thread.java:737)

5/31/12 15:41:49:553 CDT 00000086 FfdcProvider W com.ibm.ws.ffdc.impl.FfdcProvider logIncident FFDC1003I: FFDC Incident emitted on C:\Program Files\ibm\WebSphere\AppServer\profiles\AppSrv03\logs\ffdc\server1_205ca4f_12.05.31_15.41.49.4917085026439610405670.txt com.ibm.ws.gridcontainer.services.impl.WASUsageAccountingServiceImpl 105
5/31/12 15:41:49:569 CDT 00000086 batch E Exception while performing cleanup
com.ibm.ws.gridcontainer.exceptions.GridContainerServiceException: Status for job EE834Process:00001 not found
at com.ibm.ws.gridcontainer.services.impl.JobStatusManagerImpl.updateJobStatus(JobStatusManagerImpl.java:373)
at com.ibm.ws.batch.BatchJobControllerWork._cleanUpAndShutdownOnError(BatchJobControllerWork.java:438)
at com.ibm.ws.batch.BatchJobControllerWork.run(BatchJobControllerWork.java:232)
at com.ibm.ws.asynchbeans.J2EEContext.run(J2EEContext.java:809)
at com.ibm.ws.asynchbeans.WorkWithExecutionContextImpl.go(WorkWithExecutionContextImpl.java:222)
at com.ibm.ws.asynchbeans.ABWorkItemImpl.run(ABWorkItemImpl.java:206)
at java.lang.Thread.run(Thread.java:737)
Caused by: java.lang.Exception: status.for.job.{0}.not.found
at com.ibm.ws.gridcontainer.services.impl.JobStatusManagerImpl.updateJobStatus(JobStatusManagerImpl.java:372)
... 6 more

5/31/12 15:41:49:585 CDT 00000086 batch E Exception occured while shutting down job related services
java.lang.NullPointerException
at com.ibm.ws.batch.BatchJobControllerWork._shutdown(BatchJobControllerWork.java:249)
at com.ibm.ws.batch.BatchJobControllerWork._cleanUpAndShutdownOnError(BatchJobControllerWork.java:450)
at com.ibm.ws.batch.BatchJobControllerWork.run(BatchJobControllerWork.java:232)
at com.ibm.ws.asynchbeans.J2EEContext.run(J2EEContext.java:809)
at com.ibm.ws.asynchbeans.WorkWithExecutionContextImpl.go(WorkWithExecutionContextImpl.java:222)
at com.ibm.ws.asynchbeans.ABWorkItemImpl.run(ABWorkItemImpl.java:206)
at java.lang.Thread.run(Thread.java:737)
Updated on 2012-09-03T11:50:32Z at 2012-09-03T11:50:32Z by SystemAdmin
  • pglasgow4129
    pglasgow4129
    3 Posts

    Re: Error in WAS 8.0 Compute Grid Test Environment for RSA 8.0.0.4

    ‏2012-05-31T21:03:59Z  
    In my previous post, I forgot to mention that I have also backed out my code changes and am still receiving the error ProcessCPU failed to initialize.

    Thanks.
  • pglasgow4129
    pglasgow4129
    3 Posts

    Re: Error in WAS 8.0 Compute Grid Test Environment for RSA 8.0.0.4

    ‏2012-06-05T18:39:30Z  
    In my previous post, I forgot to mention that I have also backed out my code changes and am still receiving the error ProcessCPU failed to initialize.

    Thanks.
    Correction for the error I received was to uninstall Compute Grid and reinstall.
  • SystemAdmin
    SystemAdmin
    783 Posts

    Re: Error in WAS 8.0 Compute Grid Test Environment for RSA 8.0.0.4

    ‏2012-08-29T07:20:58Z  
    Correction for the error I received was to uninstall Compute Grid and reinstall.
    did it work?
  • SystemAdmin
    SystemAdmin
    783 Posts

    Re: Error in WAS 8.0 Compute Grid Test Environment for RSA 8.0.0.4

    ‏2012-09-03T11:50:32Z  
    did it work?
    It turns out that compute grid 8 has a bug. It will not work on 64bit systems.
    The problem is described here in this link and we have to install fixpacks to resolve the issue

    http://www-01.ibm.com/support/docview.wss?uid=swg21504550

    I have installed fixpack 2 and it resolved the issue.