Topic
  • 2 replies
  • Latest Post - ‏2012-06-07T16:30:18Z by rossella
kenblake
kenblake
6 Posts

Pinned topic PXE booted compute node missing

‏2012-05-29T17:15:02Z |
I have 2 nodes that were PXE booted and "installed" as computed nodes. They are not showing up in iaas-describe-nodes nor are they showing up as hypervisor systems in the GUI. Is there someway to restart this process or figure out what went wrong?

Thanks
Ken
Updated on 2012-06-07T16:30:18Z at 2012-06-07T16:30:18Z by rossella
  • kenblake
    kenblake
    6 Posts

    Re: PXE booted compute node missing

    ‏2012-05-29T18:03:06Z  
    Ok, a little more info. Digging through the startup log, I found this:

    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package isaac-hyper-bots.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Processing Dependency: isaac-common >= 1.1 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    --> Processing Dependency: ibm-java-x86_64-sdk >= 6.0 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    --> Processing Dependency: isaac-ruby-c-p2pmessaging >= 1.1 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    --> Processing Dependency: isaac-zookeeper-adapter >= 1.1 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    --> Processing Dependency: isaac-virsh-utilities >= 1.1 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    ---> Package isaac-network-utilities.x86_64 0:2.1.0.0-201205022236 set to be updated
    ---> Package isaac-pdcollect.noarch 0:2.1.0.0-201205022236 set to be updated
    --> Running transaction check
    ---> Package ibm-java-x86_64-sdk.x86_64 0:6.0-10.0 set to be updated
    --> Processing Dependency: /usr/lib64/libstdc++.so.5 for package: ibm-java-x86_64-sdk-6.0-10.0.x86_64
    ---> Package isaac-common.noarch 0:2.1.0.0-201205022236 set to be updated
    ---> Package isaac-ruby-c-p2pmessaging.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Processing Dependency: libjvm.so()(64bit) for package: isaac-ruby-c-p2pmessaging-2.1.0.0-201205022236.x86_64
    ---> Package isaac-virsh-utilities.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Processing Dependency: libvirt-qemu.so.0()(64bit) for package: isaac-virsh-utilities-2.1.0.0-201205022236.x86_64
    ---> Package isaac-zookeeper-adapter.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Running transaction check
    ---> Package compat-libstdc++-33.x86_64 0:3.2.3-69.el6 set to be updated
    ---> Package isaac-virsh-utilities.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Processing Dependency: libvirt-qemu.so.0()(64bit) for package: isaac-virsh-utilities-2.1.0.0-201205022236.x86_64
    ---> Package libgcj.x86_64 0:4.4.4-13.el6 set to be updated
    --> Finished Dependency Resolution
    Error: Package: isaac-virsh-utilities-2.1.0.0-201205022236.x86_64 (isaac)
    Requires: libvirt-qemu.so.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    I thought this should have been installed when it was creating the pxe image. BTW, this is on RHEL 6.0
  • rossella
    rossella
    58 Posts

    Re: PXE booted compute node missing

    ‏2012-06-07T16:30:18Z  
    • kenblake
    • ‏2012-05-29T18:03:06Z
    Ok, a little more info. Digging through the startup log, I found this:

    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package isaac-hyper-bots.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Processing Dependency: isaac-common >= 1.1 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    --> Processing Dependency: ibm-java-x86_64-sdk >= 6.0 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    --> Processing Dependency: isaac-ruby-c-p2pmessaging >= 1.1 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    --> Processing Dependency: isaac-zookeeper-adapter >= 1.1 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    --> Processing Dependency: isaac-virsh-utilities >= 1.1 for package: isaac-hyper-bots-2.1.0.0-201205022236.x86_64
    ---> Package isaac-network-utilities.x86_64 0:2.1.0.0-201205022236 set to be updated
    ---> Package isaac-pdcollect.noarch 0:2.1.0.0-201205022236 set to be updated
    --> Running transaction check
    ---> Package ibm-java-x86_64-sdk.x86_64 0:6.0-10.0 set to be updated
    --> Processing Dependency: /usr/lib64/libstdc++.so.5 for package: ibm-java-x86_64-sdk-6.0-10.0.x86_64
    ---> Package isaac-common.noarch 0:2.1.0.0-201205022236 set to be updated
    ---> Package isaac-ruby-c-p2pmessaging.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Processing Dependency: libjvm.so()(64bit) for package: isaac-ruby-c-p2pmessaging-2.1.0.0-201205022236.x86_64
    ---> Package isaac-virsh-utilities.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Processing Dependency: libvirt-qemu.so.0()(64bit) for package: isaac-virsh-utilities-2.1.0.0-201205022236.x86_64
    ---> Package isaac-zookeeper-adapter.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Running transaction check
    ---> Package compat-libstdc++-33.x86_64 0:3.2.3-69.el6 set to be updated
    ---> Package isaac-virsh-utilities.x86_64 0:2.1.0.0-201205022236 set to be updated
    --> Processing Dependency: libvirt-qemu.so.0()(64bit) for package: isaac-virsh-utilities-2.1.0.0-201205022236.x86_64
    ---> Package libgcj.x86_64 0:4.4.4-13.el6 set to be updated
    --> Finished Dependency Resolution
    Error: Package: isaac-virsh-utilities-2.1.0.0-201205022236.x86_64 (isaac)
    Requires: libvirt-qemu.so.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    I thought this should have been installed when it was creating the pxe image. BTW, this is on RHEL 6.0
    It seems it did not manage to install qemu.

    Two options here:
    • check the content of RHEL*.iso
    • check the prerequisite RPMs (I found a few problems with broken version of livecdtool

    To try to recreate the setup, if you used the CLI just rerun firstbox_run after removing the content of /var/lib/tftpboot on the PXE server; if using the GUi just relaunch the installation wizard.