• 2 replies
  • Latest Post - ‏2012-05-23T14:25:58Z by SystemAdmin
253 Posts

Pinned topic Problem with FTP of file to RDz UT

‏2012-05-22T19:50:56Z |
A customer is attempting to ftp a file from PROD to RUT. The file is org=PS, RECFM=U, lrecl=0, blksize=32760. FDR support tells me I should be able to ftp this between z/OS images using type EBcdic and MODE Block. However, my ftp is failing with the error below. Have any of you ran into this before or do you have any recommendations? I’ve tried pre-allocating this file and I’ve tried sending the parms via the FTP, both have failed…..


IEC143I 213-rc,mod,jjj,sss, ddname-#,dev,volser,dsname( member)

Explanation: An error occurred during the processing of an OPEN macro instruction for a data set on a direct access device. This is probably a user error.

14 OPEN failed because the data set type was large format sequential, but the application program could not access the whole data set on the volume. Both of the following are true:

o The access method is either EXCP being opened for UPDAT or output processing or the access method is BSAM with the NOTE or POINT function requested and is being opened for output processing.

o BLOCKTOKENSIZE=LARGE is not specified on the DCBE.
Is you backup large format sequential. I know we support it, however, but apparently FTP does not.
Updated on 2012-05-23T14:25:58Z at 2012-05-23T14:25:58Z by SystemAdmin
  • RDzJohn
    302 Posts

    Re: Problem with FTP of file to RDz UT

    Suggest you move this to TCPIP or MVS forums. The FTP experts hang out there.

  • SystemAdmin
    253 Posts

    Re: Problem with FTP of file to RDz UT

    I have never ftped a PDS, rather the members but you have to be careful with RECFM=U and LRECL=0.
    My suggestion is that you xmit your dataset and then transfer it to the target computer and RECEIVE the file there.