Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
4 replies Latest Post - ‏2012-05-19T17:48:07Z by SystemAdmin
SystemAdmin
SystemAdmin
7754 Posts
ACCEPTED ANSWER

Pinned topic Problems compiling jobs with Transformer Stages

‏2012-05-18T21:49:46Z |
I am upgrading my system from DataStage 8.0.1 to 8.7. I just finished installing the software on RHEL 6.2 and am having issues getting jobs to compile. I have verified that all required libraries are installed and that the gcc compiler is installed and is on the PATH. These jobs compile and run just fine on my old, DataStage 8.0.1 server. I have expoerted the jobs via dsx from the old server and imported them on the new server.

Here is the error output:

Output from transformer compilation follows:

##I IIS-DSEE-TFCN-00001 17:41:10(000) <main_program>
IBM InfoSphere DataStage Enterprise Edition 8.7.0.6126
Copyright (c) 2001, 2005-2011 IBM Corporation. All rights reserved

##I IIS-DSEE-TFCN-00006 17:41:10(001) <main_program> conductor uname: -s=Linux; -r=2.6.32-220.17.1.el6.x86_64; -v=#1 SMP Thu Apr 26 13:37:13 EDT 2012; -n=dwstagedev1.bcbsvt.com; -m=x86_64
##I IIS-DSEE-TOSH-00002 17:41:11(000) <main_program> orchgeneral: loaded
##I IIS-DSEE-TOSH-00002 17:41:11(001) <main_program> orchsort: loaded
##I IIS-DSEE-TOSH-00002 17:41:11(002) <main_program> orchstats: loaded
##W IIS-DSEE-TOSH-00049 17:41:11(005) <main_program> Parameter specified but not used in flow: DSPXWorkingDir
##E IIS-DSEE-TBLD-00076 17:41:11(007) <main_program> Error when checking composite operator: Subprocess command failed with exit status 32,512.
##E IIS-DSEE-TFSR-00019 17:41:11(008) <main_program> Could not check all operators because of previous error(s)
##W IIS-DSEE-TFTM-00012 17:41:11(009) <transform> Error when checking composite operator: The number of reject datasets "0" is less than the number of input datasets "1".
##W IIS-DSEE-TBLD-00000 17:41:11(010) <main_program> Error when checking composite operator: Output from subprocess: sh: g++: command not found

##I IIS-DSEE-TBLD-00079 17:41:11(011) <transform> Error when checking composite operator: g++ -fPIC -O -I/opt/IBM/InformationServer/Server/PXEngine/include -c -O -fPIC -Wno-deprecated -m64 -mtune=generic -mcmodel=small /opt/IBM/InformationServer/Server/Projects/dstage1/RT_BP1.O/V184S2_jb_act129_echosurvey_extract_members_TRN_PROCESS.C -o /opt/IBM/InformationServer/Server/Projects/dstage1/RT_BP1.O/V184S2_jb_act129_echosurvey_extract_members_TRN_PROCESS.tmp.o.
##E IIS-DSEE-TCOS-00029 17:41:11(012) <main_program> Creation of a step finished with status = FAILED. (jb_act129_echosurvey_extract_members.TRN_PROCESS)

  • Internal Generated Transformer Code follows:
0001: //
0002: // Generated file to implement the V184S2_jb_act129_echosurvey_extract_members_TRN_PROCESS transform operator.
0003: //
0004:
0005: // define our input/output link names
0006: inputname 0 lnk_Read_Members;
0007: outputname 0 lnk_Write_Members_COMP22;
0008: outputname 1 lnk_Write_Members_COMP21;
0009:
0010: initialize {
0011: // define our control variables
0012: int8 RowRejected0;
0013: int8 NullSetVar0;
0014:
0015: // declare our intermediate variables for this section
0016: string InterVar0_0;
0017: string InterVar0_1;
0018:
0019: // initialise constant values which require conversion
0020: InterVar0_0 = "22";
0021: InterVar0_1 = "21";
0022: }
0023:
0024: mainloop {
0025:
0026: // initialise the rejected row variable
0027: RowRejected0 = 1;
0028:
0029: // evaluate constraint and columns for link: lnk_Write_Members_COMP22
0030: if ((lnk_Read_Members.COMPNO == InterVar0_0))
0031: {
0032: writerecord 0;
0033: RowRejected0 = 0;
0034: }
0035: // evaluate constraint and columns for link: lnk_Write_Members_COMP21
0036: if ((lnk_Read_Members.COMPNO == InterVar0_1))
0037: {
0038: writerecord 1;
0039: RowRejected0 = 0;
0040: }
0041: }
0042:
0043: finish {
0044: }
0045:
  • End of Internal Generated Transformer Code
Updated on 2012-05-19T17:48:07Z at 2012-05-19T17:48:07Z by SystemAdmin
  • RobertDickson
    RobertDickson
    33 Posts
    ACCEPTED ANSWER

    Re: Problems compiling jobs with Transformer Stages

    ‏2012-05-19T00:11:57Z  in response to SystemAdmin
    Hi Ron,

    Did you install a supported compiler: http://www-01.ibm.com/support/docview.wss?uid=swg27021833

    Did you modify the compiler options as per: http://publib.boulder.ibm.com/infocenter/iisinfsv/v8r7/index.jsp?topic=%2Fcom.ibm.swg.im.iis.productization.iisinfsv.install.doc%2Ftopics%2Fwsisinst_set_envars_cpp_gcc64.html
    • SystemAdmin
      SystemAdmin
      7754 Posts
      ACCEPTED ANSWER

      Re: Problems compiling jobs with Transformer Stages

      ‏2012-05-19T12:43:04Z  in response to RobertDickson
      I'm using GNU C++ 4.4, which is on the supported compilers list for RHEL x86_64 and my DataStage compiler configuration variables match those that are on the site you provided.
      • RobertDickson
        RobertDickson
        33 Posts
        ACCEPTED ANSWER

        Re: Problems compiling jobs with Transformer Stages

        ‏2012-05-19T13:13:35Z  in response to SystemAdmin
        Hi Ron,

        A few more things to try:
        • I found some steps specific to GNU 4.4 at http://www-01.ibm.com/support/docview.wss?uid=swg27021235, including APT_COMPILER, APT_LINKER, and stop/restart the DataStage services.
        • When logged in as the DataStage administrative user (usually dsadm), does 'rpm -qa | grep ++' show that you have gcc-c++ installed?
        • When logged in as the DataStage administrative user (usually dsadm), does 'g++ --version' return your version?
        • SystemAdmin
          SystemAdmin
          7754 Posts
          ACCEPTED ANSWER

          Re: Problems compiling jobs with Transformer Stages

          ‏2012-05-19T17:48:07Z  in response to RobertDickson
          Eureka!

          It was the g++-c++ package. Been banging my head against a wall for over a week... I didn't realize c++ support wasn't installed with gcc by default. Oh, well, I learned something.

          Thanks for your help.

          Ron