Topic
  • 1 reply
  • Latest Post - ‏2013-11-21T23:10:27Z by DJ2610
dpdeveloper
dpdeveloper
2 Posts

Pinned topic version compatible issues with datapower

‏2012-05-18T16:45:28Z |
Hi,

WTX is running on 8.3.0.4 and datapower's are running on 3.8.2.7.

I have create mapping tree's and they ran succesfully locally and on datapower from the WTX. But when I imported the .dpa file in to datapower, then I am getting below error.
xmlfirewall (wtx): dpa runtime error
xmlfirewall (wtx): dpa runtime error
xmlfirewall (wtx): request wtx_rule_0 #1 xformbin: 'Transforming (possibly binary) INPUT with local:///TEXT_TO_XML.dpa results stored in PIPE' failed: 21: Input valid but unknown data found.

I came across below link which says that 8.3.0.4 is compatible with datapower 4.0 versions and 8.3.0.3 is compatible with datapower 3.8.1 and 3.8.2 versions.

http://www-304.ibm.com/support/docview.wss?uid=swg21358525

We can't upgrade datapower devices to 4.0 due to several reasons. Is it possible to make any kind of changes in WTX maps to work on 3.8.2 versions as well or the only way is to downgrade WTX to 8.3.0.3.

Thanks.
  • DJ2610
    DJ2610
    2 Posts

    Re: version compatible issues with datapower

    ‏2013-11-21T23:10:27Z  

    I hope this issue might have resolved as the post is very old.

     

    But anyway you are facing PIPE' failed: 21: Input valid but unknown data found.because from backend or frontend the XMLFirewall is receiving the more length of data than expected by map.