Topic
4 replies Latest Post - ‏2012-08-17T11:19:21Z by Shikharani
Shikharani
Shikharani
29 Posts
ACCEPTED ANSWER

Pinned topic New line charcter between two strings.

‏2012-05-16T06:35:00Z |
We are using "
tag for adding new line between two strings. But after upgrade to WPF 7.0 it is not working.It is showing
character on my web page. what should I use now. I have tried " " but it is also not working.
Please suggest something..
Updated on 2012-08-17T11:19:21Z at 2012-08-17T11:19:21Z by Shikharani
  • DGawron
    DGawron
    76 Posts
    ACCEPTED ANSWER

    Re: New line charcter between two strings.

    ‏2012-05-16T18:04:44Z  in response to Shikharani
    You need to provide more detail about what the text is, where the text is stored in the app, and how it gets added to the page. My hunch is that you have an embedded <br> in some text and that text is now being encoded as a security measure when it's added to the page display.
    • Shikharani
      Shikharani
      29 Posts
      ACCEPTED ANSWER

      Re: New line charcter between two strings.

      ‏2012-06-01T08:53:50Z  in response to DGawron
      Hi,

      I am doing concatenation of the two string with
      in between and putting this concatenated string in the value tag of IXml variable. with WPF 6.0.1 it was working fine but after upgrade to 7.0 it is not working.
      • mburati
        mburati
        423 Posts
        ACCEPTED ANSWER

        Re: New line charcter between two strings.

        ‏2012-06-01T14:27:03Z  in response to Shikharani
        I think the forum software may be eating and not showing part of what you entered, or you missed something there.

        As Dave mentioned, we could use some more details as to what you're doing with this string (if you're then displaying this as text on the page and if so, how)... It's generally safer not to mix markup with text data, if that's what you're trying to do (in WPF/WEF text builders or in this forum or other similar web apps), since sneaking markup into text data is one way malicious users use to attempt to attack systems with XSS attacks. WEF 7.x by default disallows markup within text data output by the Text builder (which has a checkbox to allow you to disable that security feature) and via Data Page / page automation builders (for which there's a property to disable that feature, but it's not recommended).

        A better approach would be to figure out how to separate the two strings from the markup you're trying to introduce, and/or to get your data to wrap by length (eg, in text area with a certain size etc)...

        ..mb1