Topic
  • 47 replies
  • Latest Post - ‏2012-05-17T13:14:09Z by Carlos.Hernandez
satyaki.de
satyaki.de
35 Posts

Pinned topic Virtual directory for Webserver is not working

‏2012-05-11T17:05:03Z |
Hi Friends,

I've another problem regarding final step of Cognos Configuration during Virtual Directory creation in Linux.

Let's find the environment details -

1. Linux version (32 bit) ->


[cognos@pult ~]$ cat /proc/version Linux version 2.6.18-274.7.1.el5PAE (mockbuild@x86-007.build.bos.redhat.com) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-50)) #1 SMP Mon Oct 17 12:05:46 EDT 2011 [cognos@pult ~]$ [cognos@pult ~]$


2. Apache Server Details ->


[root@pult ~]# ps -ef|grep apache root      1860  1417  0 22:18 pts/0    00:00:00 grep apache apache   24580 17316  0 18:38 ?        00:00:00 /usr/sbin/httpd -k start apache   24581 17316  0 18:38 ?        00:00:00 /usr/sbin/httpd -k start apache   24582 17316  0 18:38 ?        00:00:00 /usr/sbin/httpd -k start apache   24583 17316  0 18:38 ?        00:00:00 /usr/sbin/httpd -k start apache   24584 17316  0 18:38 ?        00:00:00 /usr/sbin/httpd -k start apache   24585 17316  0 18:38 ?        00:00:00 /usr/sbin/httpd -k start apache   24586 17316  0 18:38 ?        00:00:00 /usr/sbin/httpd -k start apache   24587 17316  0 18:38 ?        00:00:00 /usr/sbin/httpd -k start cognos   25021 25020  0 May09 ?        00:01:56 /opt/jdk1.6.0_32/bin/java -Xmx768m -XX:MaxNewSize=384m -XX:NewSize=192m -XX:MaxPermSize=128m -classpath /home/cognos/c8/./bin/../tomcat4.1.27/bin/bootstrap.jar:/opt/jdk1.6.0_32/lib/tools.jar -Dcatalina.base=/home/cognos/c8/./bin/../tomcat4.1.27 -Dcatalina.home=/home/cognos/c8/./bin/../tomcat4.1.27 -Djava.io.tmpdir=/home/cognos/c8/./bin/../temp -Djava.endorsed.dirs=/opt/jdk1.6.0_32/lib/endorsed:/home/cognos/c8/./bin/../tomcat4.1.27/common/endorsed org.apache.catalina.startup.Bootstrap start [root@pult ~]#


3. Apache version


drwxr-xr-x 12 root   root     4096 May 11 15:37 httpd-2.2.22 [cognos@pult ~]$


When we type -> http://localhost/

The page is showing.

And, the following entries added -


[root@pult ~]# cd /usr/local/apache2/conf [root@pult conf]# [root@pult conf]# ls -lrt total 112 -rw-r--r-- 1 root root 49815 May 11 15:37 mime.types drwxr-xr-x 3 root root  4096 May 11 15:37 original -rw-r--r-- 1 root root 12958 May 11 15:37 magic drwxr-xr-x 2 root root  4096 May 11 15:37 extra -rw-r--r-- 1 root root 13778 May 11 17:47 httpd.conf_old -rw-r--r-- 1 root root 13923 May 11 18:37 httpd.conf [root@pult conf]# [root@pult conf]#   --Editing httpd.conf --Adding these lines Alias /cgi-bin 
"/home/cognos/c8/cgi-bin" <Directory 
"/home/cognos/c8/cgi-bin"> Options Indexes FollowSymLinks MultiViews ExecCGI AllowOverride All Order deny,allow Deny from all </Directory>   Alias /cognos8 
"/home/cognos/c8/webcontent" <Directory 
"/home/cognos/c8/webcontent"> Options Indexes FollowSymLinks MultiViews ReadCGI AllowOverride All Order deny,allow Deny from all </Directory>


After, these change we have issued the following command ->


[root@pult conf]# cd /usr/local/apache2/bin [root@pult bin]# [root@pult bin]# apachectl restart [root@pult bin]#


Then we've tried to check from the web browser. But, page is not coming.

I've tried the following ->

i) http://localhost/cgi-bin
ii) http://localhost/cognos8

I'm new to this. So, it may be very silly mistake in terms of configuration process. :(

What step am i missing?

And, so far I've checked many link suggested online along with the documentation provided from both apache & IBM. But, so far waiting for the final moment.

And, really appreciate your time to read this post.

Thanks again.
Updated on 2012-05-17T13:14:09Z at 2012-05-17T13:14:09Z by Carlos.Hernandez
  • yangling
    yangling
    268 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T17:14:16Z  
    Let us know the exact versions of your Cognos 8 and Linux; thank you.

    Ensure you are in the supported environments and the required patches applied; see here for 8.4 for example.
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T17:25:44Z  
    • yangling
    • ‏2012-05-11T17:14:16Z
    Let us know the exact versions of your Cognos 8 and Linux; thank you.

    Ensure you are in the supported environments and the required patches applied; see here for 8.4 for example.
    My Cognos version is ->

    Cognos 8.4.1 for Linux(32 bit)
    


    Already shared Linux version.

    Currently, checking your link.

    Thanks.
    Updated on 2014-03-25T07:50:11Z at 2014-03-25T07:50:11Z by iron-man
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T17:29:34Z  
    My Cognos version is ->

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr">Cognos 8.4.1 for Linux(32 bit) </pre>

    Already shared Linux version.

    Currently, checking your link.

    Thanks.
    More info about Linux is ->

    [root@pult bin]# uname -a
    Linux pult.in.ibm.com 2.6.18-274.7.1.el5PAE #1 SMP Mon Oct 17 12:05:46 EDT 2011 i686 i686 i386 GNU/Linux
    [root@pult bin]#
    [root@pult bin]# cat /etc/*release Red Hat Enterprise Linux Server release 5.7 (Tikanga) [root@pult bin]#
    


    Hope this will help.
    Updated on 2014-03-25T07:50:07Z at 2014-03-25T07:50:07Z by iron-man
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T17:47:03Z  
    • yangling
    • ‏2012-05-11T17:14:16Z
    Let us know the exact versions of your Cognos 8 and Linux; thank you.

    Ensure you are in the supported environments and the required patches applied; see here for 8.4 for example.
    In your link, I find the following ->

    Apache HTTP Server 2.2​ AIX, HP-UX, Linux, Solaris, Windows​ Active​

    What does it mean by Active?

    how to solve this in this case?

    Any idea!
  • DanielWagemann
    DanielWagemann
    411 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T17:58:45Z  
    In your link, I find the following ->

    Apache HTTP Server 2.2​ AIX, HP-UX, Linux, Solaris, Windows​ Active​

    What does it mean by Active?

    how to solve this in this case?

    Any idea!
    I think you are missing the scripalias on your CGI-BIN

    Alias /cgi-bin "/home/cognos/c8/cgi-bin"
    ScriptAlias /ibmcognos/cgi-bin " c8_location /cgi-bin"
    Alias /ibmcognos " c8_location /webcontent"
    For more details see:
    http://publib.boulder.ibm.com/infocenter/cbi/v10r1m1/index.jsp?topic=%2Fcom.ibm.swg.ba.cognos.c8pp_inst.10.1.1.doc%2Ft_gwapache22orihs7.html
  • DanielWagemann
    DanielWagemann
    411 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T18:00:20Z  
    I think you are missing the scripalias on your CGI-BIN

    Alias /cgi-bin "/home/cognos/c8/cgi-bin"
    ScriptAlias /ibmcognos/cgi-bin " c8_location /cgi-bin"
    Alias /ibmcognos " c8_location /webcontent"
    For more details see:
    http://publib.boulder.ibm.com/infocenter/cbi/v10r1m1/index.jsp?topic=%2Fcom.ibm.swg.ba.cognos.c8pp_inst.10.1.1.doc%2Ft_gwapache22orihs7.html
    LOL! scripalias = script alias
  • yangling
    yangling
    268 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T18:29:45Z  
    In your link, I find the following ->

    Apache HTTP Server 2.2​ AIX, HP-UX, Linux, Solaris, Windows​ Active​

    What does it mean by Active?

    how to solve this in this case?

    Any idea!
    Active means actively supported.

    Provided that your alias was set correctly and it is still having issues, take notes that Red Hat Enterprise Linux Server release 5.7 was not supported in that list you checked...
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T18:59:53Z  
    I think you are missing the scripalias on your CGI-BIN

    Alias /cgi-bin "/home/cognos/c8/cgi-bin"
    ScriptAlias /ibmcognos/cgi-bin " c8_location /cgi-bin"
    Alias /ibmcognos " c8_location /webcontent"
    For more details see:
    http://publib.boulder.ibm.com/infocenter/cbi/v10r1m1/index.jsp?topic=%2Fcom.ibm.swg.ba.cognos.c8pp_inst.10.1.1.doc%2Ft_gwapache22orihs7.html
    As per your link - i've done the following entry ->

    ScriptAlias /ibmcognos/cgi-bin "/home/cognos/c8/cgi-bin"
     
    Alias /ibmcognos "/home/cognos/c8/webcontent"
     
    <Directory "/home/cognos/c8/webcontent">
     
    Options Indexes MultiViews
     
    </Directory>
     
    ScriptAlias /ibmcognos/cgi-bin "/home/cognos/c8/cgi-bin"
     
    Alias /ibmcognos "/home/cognos/c8/webcontent"
     
    <Directory "/home/cognos/c8/webcontent">
     
    Options Indexes MultiViews
     
    AllowOverride None
     
    Options None
     
    Order allow,deny
     
    Allow from all
     
    </Directory>
     
    <Directory "/home/cognos/c8/cgi-bin">
     
    AllowOverride None
     
    Options None
     
    Order allow,deny
     
    Allow from all
     
    </Directory>
     
    <Location /ibmcognos/cgi-bin/diag_cognos_module>
      SetHandler cognos-handler
    Order allow,deny
    Allow from all
    </Location>
    


    And, restart the server.

    Tried with the following ->

    http://pult.in.ibm.com:5562/ibmcognos/cgi-bin/cognos_module

    But, Now it is showing the following message ->

    Not Found
     
    The requested URL /ibmcognos/cgi-bin/cognos_module was not found on this server.
    Apache/2.2.3 (Red Hat) Server at pult.in.ibm.com Port 80
    


    Any idea?
    Updated on 2014-03-25T07:50:03Z at 2014-03-25T07:50:03Z by iron-man
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T19:13:09Z  
    As per your link - i've done the following entry ->

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr">ScriptAlias /ibmcognos/cgi-bin "/home/cognos/c8/cgi-bin" Alias /ibmcognos "/home/cognos/c8/webcontent" <Directory "/home/cognos/c8/webcontent"> Options Indexes MultiViews </Directory> ScriptAlias /ibmcognos/cgi-bin "/home/cognos/c8/cgi-bin" Alias /ibmcognos "/home/cognos/c8/webcontent" <Directory "/home/cognos/c8/webcontent"> Options Indexes MultiViews AllowOverride None Options None Order allow,deny Allow from all </Directory> <Directory "/home/cognos/c8/cgi-bin"> AllowOverride None Options None Order allow,deny Allow from all </Directory> <Location /ibmcognos/cgi-bin/diag_cognos_module> SetHandler cognos-handler Order allow,deny Allow from all </Location> </pre>

    And, restart the server.

    Tried with the following ->

    http://pult.in.ibm.com:5562/ibmcognos/cgi-bin/cognos_module

    But, Now it is showing the following message ->

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr">Not Found The requested URL /ibmcognos/cgi-bin/cognos_module was not found on this server. Apache/2.2.3 (Red Hat) Server at pult.in.ibm.com Port 80 </pre>

    Any idea?
    Also, the following part there ->

    <Location /ibmcognos/cgi-bin/cognos_module>
      SetHandler cognos-handler
    Order allow,deny
    Allow from all
    </Location>
    


    failed to post it.
    Updated on 2014-03-25T07:49:57Z at 2014-03-25T07:49:57Z by iron-man
  • DanielWagemann
    DanielWagemann
    411 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T19:17:00Z  
    As per your link - i've done the following entry ->

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr">ScriptAlias /ibmcognos/cgi-bin "/home/cognos/c8/cgi-bin" Alias /ibmcognos "/home/cognos/c8/webcontent" <Directory "/home/cognos/c8/webcontent"> Options Indexes MultiViews </Directory> ScriptAlias /ibmcognos/cgi-bin "/home/cognos/c8/cgi-bin" Alias /ibmcognos "/home/cognos/c8/webcontent" <Directory "/home/cognos/c8/webcontent"> Options Indexes MultiViews AllowOverride None Options None Order allow,deny Allow from all </Directory> <Directory "/home/cognos/c8/cgi-bin"> AllowOverride None Options None Order allow,deny Allow from all </Directory> <Location /ibmcognos/cgi-bin/diag_cognos_module> SetHandler cognos-handler Order allow,deny Allow from all </Location> </pre>

    And, restart the server.

    Tried with the following ->

    http://pult.in.ibm.com:5562/ibmcognos/cgi-bin/cognos_module

    But, Now it is showing the following message ->

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr">Not Found The requested URL /ibmcognos/cgi-bin/cognos_module was not found on this server. Apache/2.2.3 (Red Hat) Server at pult.in.ibm.com Port 80 </pre>

    Any idea?
    Out of curiosity what happens when you hit http://pult.in.ibm.com:5562/ibmcognos/cgi-bin/cognos.cgi

    The module not found error could be caused by an invalid name or extension. I don't know what modules you have within your CGI-BIN. Cross reference the module names with the ones in your CGI-BIN directory. If you are still having issues maybe you can post your CGI-BIN file listings.
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T19:21:55Z  
    Out of curiosity what happens when you hit http://pult.in.ibm.com:5562/ibmcognos/cgi-bin/cognos.cgi

    The module not found error could be caused by an invalid name or extension. I don't know what modules you have within your CGI-BIN. Cross reference the module names with the ones in your CGI-BIN directory. If you are still having issues maybe you can post your CGI-BIN file listings.
    Same error ->

    Not Found
     
    The requested URL /ibmcognos/cgi-bin/cognos.cgi was not found on this server.
    Apache/2.2.3 (Red Hat) Server at pult.in.ibm.com Port 80
    
    Updated on 2014-03-25T07:49:53Z at 2014-03-25T07:49:53Z by iron-man
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T19:27:29Z  
    Out of curiosity what happens when you hit http://pult.in.ibm.com:5562/ibmcognos/cgi-bin/cognos.cgi

    The module not found error could be caused by an invalid name or extension. I don't know what modules you have within your CGI-BIN. Cross reference the module names with the ones in your CGI-BIN directory. If you are still having issues maybe you can post your CGI-BIN file listings.
    Are you looking for this information?

    [cognos@pult cgi-bin]$ ls -lrt cognos*
    -rw-r--r-- 1 cognos cognos8   1219 Oct 23  2009 cognoscgiMsg_en.bmf
    -rwxr-xr-x 1 cognos cognos8 377918 Oct 23  2009 cognos.cgi
    -r--r--r-- 1 cognos cognos8    737 Oct 23  2009 cognoscgi.conf.sample
    -rwxr-xr-x 1 cognos cognos8   1316 Oct 27  2009 cognoscgiMsg_de.bmf
    -rwxr-xr-x 1 cognos cognos8   1323 Oct 27  2009 cognoscgiMsg_fr.bmf
    -rwxr-xr-x 1 cognos cognos8   1537 Oct 27  2009 cognoscgiMsg_ja.bmf
    -rwxr-xr-x 1 cognos cognos8   1270 Oct 27  2009 cognoscgiMsg_nl.bmf
    -rwxr-xr-x 1 cognos cognos8   1313 Oct 27  2009 cognoscgiMsg_es.bmf
    -rwxr-xr-x 1 cognos cognos8   1180 Oct 27  2009 cognoscgiMsg_fi.bmf
    -rwxr-xr-x 1 cognos cognos8   1277 Oct 27  2009 cognoscgiMsg_it.bmf
    -rwxr-xr-x 1 cognos cognos8   1297 Oct 27  2009 cognoscgiMsg_pt.bmf
    -rwxr-xr-x 1 cognos cognos8   1512 Oct 27  2009 cognoscgiMsg_ru.bmf
    -rwxr-xr-x 1 cognos cognos8   1211 Oct 27  2009 cognoscgiMsg_sv.bmf
    -rwxr-xr-x 1 cognos cognos8   1124 Oct 27  2009 cognoscgiMsg_zh-cn.bmf
    -rwxr-xr-x 1 cognos cognos8   1125 Oct 27  2009 cognoscgiMsg_zh-tw.bmf
    -rwxr-xr-x 1 cognos cognos8   1339 Oct 27  2009 cognoscgiMsg_ko.bmf
    -rwxr-xr-x 1 cognos cognos8   1247 Oct 27  2009 cognoscgiMsg_cs.bmf
    -rwxr-xr-x 1 cognos cognos8   1249 Oct 27  2009 cognoscgiMsg_hu.bmf
    -rwxr-xr-x 1 cognos cognos8   1259 Oct 27  2009 cognoscgiMsg_pl.bmf
    -rwxr-xr-x 1 cognos cognos8   1305 Oct 27  2009 cognoscgiMsg_ro.bmf
    -rwxr-xr-x 1 cognos cognos8   1244 Oct 27  2009 cognoscgiMsg_tr.bmf
    [cognos@pult cgi-bin]$ pwd
    /home/cognos/c8/cgi-bin
    [cognos@bpcatapult cgi-bin]$
    
    Updated on 2014-03-25T07:49:49Z at 2014-03-25T07:49:49Z by iron-man
  • DanielWagemann
    DanielWagemann
    411 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T19:49:41Z  
    Same error ->

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr">Not Found The requested URL /ibmcognos/cgi-bin/cognos.cgi was not found on this server. Apache/2.2.3 (Red Hat) Server at pult.in.ibm.com Port 80 </pre>
    The cognos.cgi is there in your listing. The error is referencing port 80 while your URL is going to a different port. Is this expected?
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T20:07:56Z  
    The cognos.cgi is there in your listing. The error is referencing port 80 while your URL is going to a different port. Is this expected?
    I've already using port 80. But, so far no luck.

    I've also set the following ->

    LD_LIBRARY_PATH as mentioned in your link.

    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/cognos/c8/cgi-bin
    


    And, checked both server name & port is correct.

    # To be able to use the functionality of a module which was built as a DSO you
    # have to place corresponding `LoadModule' lines at this location so the
    # directives contained in it are actually available _before_ they are used.
    # Statically compiled modules (those listed by `httpd -l') do not need
    # to be loaded here.
    #
    # Example:
    # LoadModule foo_module modules/mod_foo.so
    #
     
    LoadModule cognos_module "/home/cognos/c8/cgi-bin/mod2_2_cognos.so"
    .
    .
    .
    #
    # ServerName gives the name and port that the server uses to identify itself.
    # This can often be determined automatically, but we recommend you specify
    # it explicitly to prevent problems during startup.
    #
    # If your host doesn't have a registered DNS name, enter its IP address here.
    #
    ServerName pult.in.ibm.com:80
    .
    .
    .
    


    And, tried to run with the following ->

    http://bpcatapult.in.ibm.com:80/ibmcognos/cgi-bin/cognos_module

    But, again - No Luck. :(
    Updated on 2014-03-25T07:49:44Z at 2014-03-25T07:49:44Z by iron-man
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T20:10:02Z  
    I've already using port 80. But, so far no luck.

    I've also set the following ->

    LD_LIBRARY_PATH as mentioned in your link.

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr">export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/cognos/c8/cgi-bin </pre>

    And, checked both server name & port is correct.

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr"># To be able to use the functionality of a module which was built as a DSO you # have to place corresponding `LoadModule' lines at this location so the # directives contained in it are actually available _before_ they are used. # Statically compiled modules (those listed by `httpd -l') do not need # to be loaded here. # # Example: # LoadModule foo_module modules/mod_foo.so # LoadModule cognos_module "/home/cognos/c8/cgi-bin/mod2_2_cognos.so" . . . # # ServerName gives the name and port that the server uses to identify itself. # This can often be determined automatically, but we recommend you specify # it explicitly to prevent problems during startup. # # If your host doesn't have a registered DNS name, enter its IP address here. # ServerName pult.in.ibm.com:80 . . . </pre>

    And, tried to run with the following ->

    http://bpcatapult.in.ibm.com:80/ibmcognos/cgi-bin/cognos_module

    But, again - No Luck. :(
    Sorry tried with this ->

    http://pult.in.ibm.com:80/ibmcognos/cgi-bin/cognos_module

    But, no luck.
  • DanielWagemann
    DanielWagemann
    411 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T20:33:51Z  
    Sorry tried with this ->

    http://pult.in.ibm.com:80/ibmcognos/cgi-bin/cognos_module

    But, no luck.
    You are really all over the map with your ports and servernames. Based on your last post, you updated the model to the module name mod2_2_cognos.so.

    Assuming your port and servername are correct, try the following:

    http://pult.in.ibm.com:80/ibmcognos/cgi-bin/mod2_2_cognos.so
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T20:38:51Z  
    You are really all over the map with your ports and servernames. Based on your last post, you updated the model to the module name mod2_2_cognos.so.

    Assuming your port and servername are correct, try the following:

    http://pult.in.ibm.com:80/ibmcognos/cgi-bin/mod2_2_cognos.so
    Same Result - I'm afraid. :(

    What am I missing?
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T20:43:55Z  
    Same Result - I'm afraid. :(

    What am I missing?
    Also, tried switching ServerName with IP address in httpd.conf file.

    But, result is same.
  • DanielWagemann
    DanielWagemann
    411 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T20:48:26Z  
    Also, tried switching ServerName with IP address in httpd.conf file.

    But, result is same.
    Can you post the conf file please?
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T20:54:51Z  
    Can you post the conf file please?
    Kindly find the conf file attached here.

    Attachments

  • yangling
    yangling
    268 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T20:57:07Z  
    Are you looking for this information?

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr">[cognos@pult cgi-bin]$ ls -lrt cognos* -rw-r--r-- 1 cognos cognos8 1219 Oct 23 2009 cognoscgiMsg_en.bmf -rwxr-xr-x 1 cognos cognos8 377918 Oct 23 2009 cognos.cgi -r--r--r-- 1 cognos cognos8 737 Oct 23 2009 cognoscgi.conf.sample -rwxr-xr-x 1 cognos cognos8 1316 Oct 27 2009 cognoscgiMsg_de.bmf -rwxr-xr-x 1 cognos cognos8 1323 Oct 27 2009 cognoscgiMsg_fr.bmf -rwxr-xr-x 1 cognos cognos8 1537 Oct 27 2009 cognoscgiMsg_ja.bmf -rwxr-xr-x 1 cognos cognos8 1270 Oct 27 2009 cognoscgiMsg_nl.bmf -rwxr-xr-x 1 cognos cognos8 1313 Oct 27 2009 cognoscgiMsg_es.bmf -rwxr-xr-x 1 cognos cognos8 1180 Oct 27 2009 cognoscgiMsg_fi.bmf -rwxr-xr-x 1 cognos cognos8 1277 Oct 27 2009 cognoscgiMsg_it.bmf -rwxr-xr-x 1 cognos cognos8 1297 Oct 27 2009 cognoscgiMsg_pt.bmf -rwxr-xr-x 1 cognos cognos8 1512 Oct 27 2009 cognoscgiMsg_ru.bmf -rwxr-xr-x 1 cognos cognos8 1211 Oct 27 2009 cognoscgiMsg_sv.bmf -rwxr-xr-x 1 cognos cognos8 1124 Oct 27 2009 cognoscgiMsg_zh-cn.bmf -rwxr-xr-x 1 cognos cognos8 1125 Oct 27 2009 cognoscgiMsg_zh-tw.bmf -rwxr-xr-x 1 cognos cognos8 1339 Oct 27 2009 cognoscgiMsg_ko.bmf -rwxr-xr-x 1 cognos cognos8 1247 Oct 27 2009 cognoscgiMsg_cs.bmf -rwxr-xr-x 1 cognos cognos8 1249 Oct 27 2009 cognoscgiMsg_hu.bmf -rwxr-xr-x 1 cognos cognos8 1259 Oct 27 2009 cognoscgiMsg_pl.bmf -rwxr-xr-x 1 cognos cognos8 1305 Oct 27 2009 cognoscgiMsg_ro.bmf -rwxr-xr-x 1 cognos cognos8 1244 Oct 27 2009 cognoscgiMsg_tr.bmf [cognos@pult cgi-bin]$ pwd /home/cognos/c8/cgi-bin [cognos@bpcatapult cgi-bin]$ </pre>
    Please keep in mind that Red Hat 5.7 is even not supported for Cognos 10.1 (confirm here. Which means Cognos 8.4 and 10.1 both were never tested in 5.7 OS.

    Good luck!
  • satyaki.de
    satyaki.de
    35 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T21:03:22Z  
    • yangling
    • ‏2012-05-11T20:57:07Z
    Please keep in mind that Red Hat 5.7 is even not supported for Cognos 10.1 (confirm here. Which means Cognos 8.4 and 10.1 both were never tested in 5.7 OS.

    Good luck!
    Thanks for Good Wish!

    As suggested, I'll follow it up with Linux Guy.

    Before that, I just want to ensure that nothing from our end is overlooked in order to solve it.

    Thanks.
  • DanielWagemann
    DanielWagemann
    411 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T21:36:27Z  
    Thanks for Good Wish!

    As suggested, I'll follow it up with Linux Guy.

    Before that, I just want to ensure that nothing from our end is overlooked in order to solve it.

    Thanks.
    I had a quick poke around and for some reason you have double of everything in there. I made a few changes to the attached file. But I am not sure I caught everything.

    If it still does not work ... following the step by step again located at:
    http://publib.boulder.ibm.com/infocenter/c8fpm/v8r4m0/index.jsp?topic=/com.ibm.swg.im.cognos.inst_cr_winux.8.4.1.doc/inst_cr_winux_id8864ConfigureApachegateway.html

    You will need to pay attention to the details and the fine print. In your conf file you still had references to the placeholder cognos_module.
  • yangling
    yangling
    268 Posts

    Re: Virtual directory for Webserver is not working

    ‏2012-05-11T21:42:52Z  
    Thanks for Good Wish!

    As suggested, I'll follow it up with Linux Guy.

    Before that, I just want to ensure that nothing from our end is overlooked in order to solve it.

    Thanks.
    Reading your httpd.conf file it seems you missed directory definition for /home/cognos/c8/cgi-bin

    change this
    </Directory>
    ScriptAlias /ibmcognos/cgi-bin "/home/cognos/c8/cgi-bin"

    Alias /ibmcognos "/home/cognos/c8/webcontent"

    <Directory "/home/cognos/c8/webcontent">

    to
    </Directory>
    ScriptAlias /ibmcognos/cgi-bin "/home/cognos/c8/cgi-bin"

    Alias /ibmcognos "/home/cognos/c8/cgi-bin"

    <Directory "/home/cognos/c8/cgi-bin">

    If this still did not work, then it could be versiion of OS you are on.