Topic
  • 5 replies
  • Latest Post - ‏2012-05-12T04:23:03Z by T0TB_Michael_Henderson
T0TB_Michael_Henderson
6 Posts

Pinned topic Cannot get syndicator to manually syndicate- All is automatic

‏2012-05-10T23:30:55Z |
Linux Redhat v6x Portal/WAS V7.0.0.17 WCM CF4

We had a power outage last week at a Data Center. The WCM authoring, QA and Portal servers all went down. Everything recovered fine in all respects. But I noticed that when I create a piece of content with the authoring portlet, it automatically syndicates to QA. To be sure, this was what we originally wanted. But about one month back we set it to manual syndication from auth to Qa and prod. The connect.moduleconfig.syndication.inittasks = false but it does not matter. I have rebooted the dmgr, nodes, and portal. I have reset the event logs. I have deleted the syndicators and made new ones. I have run tasks to set the wcmconfig.properties from a shell script. I have run the syncNode.sh tasks Nothing fixes this.

Any ideas i have some content not found erors but that is the least of my worries at the moment.

5/10/12 18:18:05:523 CDT] 000000bb PackageGenera I createIceItemMove():: p_items length = 0
5/10/12 18:18:05:524 CDT 000000bb PackageGenera I createIceItemRemove():: p_items length = 132
5/10/12 18:18:05:533 CDT 000000bb PackageGenera I createIceProjectItemUpdates():: p_items length = 0
5/10/12 18:18:05:533 CDT 000000bb PackageGenera I createIceProjectItemRemoves():: p_items length = 0
5/10/12 18:18:05:638 CDT 000000bb SyndicatorTas I Partial update for subscription: IceId: <685c59e6-23ee-41df-a698-28b0aa9dad23> Current State: <247f8cd9-4073-4327-9f7f-107faee338e0:1336691826520,8a533d63-76f6-4e0f-b91d-ea401264cd6e:1336681400126> is active.
5/10/12 18:18:08:131 CDT 000000c0 ResponseBL I Performing response for sender: b061ba2f-0339-4914-bbc4-09ddcc06558f
5/10/12 18:18:08:224 CDT 000000c0 SyndicatorTas I Subscription: IceId: <685c59e6-23ee-41df-a698-28b0aa9dad23> Current State: <247f8cd9-4073-4327-9f7f-107faee338e0:1336691826520,8a533d63-76f6-4e0f-b91d-ea401264cd6e:1336681400126> updated successfully.
5/10/12 18:18:17:118 CDT 000000c0 CoreQueries W Retrieval of items from repository failed with error javax.jcr.ItemNotFoundException: /contentRoot/icm:libraries22/Content/aww/annc/h. d. smith news/a5c931c6-e76f-45bb-98fd-8009a06481b1
5/10/12 18:18:17:326 CDT 000000c0 CoreQueries W Retrieval of items from repository failed with error javax.jcr.ItemNotFoundException: /contentRoot/icm:libraries22/Content/aww/annc/obx announcements/a5c931c6-e76f-45bb-98fd-8009a06481b1
5/10/12 18:18:19:449 CDT 000000c0 CoreQueries W Retrieval of items from repository failed with error javax.jcr.ItemNotFoundException: /contentRoot/icm:libraries22/Content/aww/annc/technology newsflash/a5c931c6-e76f-45bb-98fd-8009a06481b1

Thanks
Updated on 2012-05-12T04:23:03Z at 2012-05-12T04:23:03Z by T0TB_Michael_Henderson
  • T0TB_Michael_Henderson
    6 Posts

    Re: Cannot get syndicator to manually syndicate- All is automatic

    ‏2012-05-11T01:55:09Z  
    After making changes to the interval, I found that it doesnt matter whether it is 0 30 or 300 it still automatically syndicates. ???? So it seems the wcmconfigservices settings in the DMGR are being ignored.
  • T0TB_Michael_Henderson
    6 Posts

    Re: Cannot get syndicator to manually syndicate- All is automatic

    ‏2012-05-11T12:41:58Z  
    After making changes to the interval, I found that it doesnt matter whether it is 0 30 or 300 it still automatically syndicates. ???? So it seems the wcmconfigservices settings in the DMGR are being ignored.
    Next steps. I cleared the temp, wstemp, and tranlog folders. I reset the event log on the Authoring server, I recreated the subscribers and syndicators. I rebooted both servers, nodes and dmgrs,then created content with the wcmconfigservice setting connect.moduleconfig.syndication.inittasks=false and deployment.subscriberOnly=false on authoring server. The wcmconfigservice setting connect.moduleconfig.syndication.inittasks=false and deployment.subscriberOnly=true on QA subscriber server.

    Still I created a piece of content on auth, saved it and in 30 secs it automatically syndicated. I am at wits end. Traces to follow
  • T0TB_Michael_Henderson
    6 Posts

    Re: Cannot get syndicator to manually syndicate- All is automatic

    ‏2012-05-11T13:33:38Z  
    Next steps. I cleared the temp, wstemp, and tranlog folders. I reset the event log on the Authoring server, I recreated the subscribers and syndicators. I rebooted both servers, nodes and dmgrs,then created content with the wcmconfigservice setting connect.moduleconfig.syndication.inittasks=false and deployment.subscriberOnly=false on authoring server. The wcmconfigservice setting connect.moduleconfig.syndication.inittasks=false and deployment.subscriberOnly=true on QA subscriber server.

    Still I created a piece of content on auth, saved it and in 30 secs it automatically syndicated. I am at wits end. Traces to follow
    Attached is a trace log with syndicator on manual but responding as if automatic.
  • T0TB_Michael_Henderson
    6 Posts

    Re: Cannot get syndicator to manually syndicate- All is automatic

    ‏2012-05-12T04:14:20Z  
    Attached is a trace log with syndicator on manual but responding as if automatic.
    Here is another trace log that starts the new traces at the line "5/11/12 16:15:22:097 CDT 000000ae ManagerAdmin I TRAS0018I: The trace state has changed. The new trace state is "
    The "Production-obx" syndicator is disabled but seems to be in the logs. The "QA" syndicator is the one in question.
  • T0TB_Michael_Henderson
    6 Posts

    Re: Cannot get syndicator to manually syndicate- All is automatic

    ‏2012-05-12T04:23:03Z  
    Here is another trace log that starts the new traces at the line "5/11/12 16:15:22:097 CDT 000000ae ManagerAdmin I TRAS0018I: The trace state has changed. The new trace state is "
    The "Production-obx" syndicator is disabled but seems to be in the logs. The "QA" syndicator is the one in question.
    Sorry Here is what I enabled for tracing:
    com.ibm.aptrix.pluto.cmpnt.*=all:
    com.ibm.workplace.wcm.services.eventlog.*=all:
    com.ibm.workplace.wcm.services.transaction.steps.eventlog.*=all:
    com.ibm.workplace.wcm.services.repository.*=all:
    com.ibm.workplace.wcm.services.content.*=all
    com.aptrix.deployment.*=all:com.aptrix.syndication.*=all:

    The attachment may be too big to post. If so these last two threads are meaningless.