Topic
No replies
SystemAdmin
SystemAdmin
253 Posts
ACCEPTED ANSWER

Pinned topic SMF configuration issue

‏2012-05-10T18:38:21Z |
This problem was encountered by one of my RDz UT customers:

We have a batch process that uses an assembler program to write a SMF record. This is program is abending with an abend=SFDF, an abend code I’ve never seen before. When I issue /d SMF it doesn’t look like SMF is working on RUT…. Can someone aid me in getting this working?

IBMUSER 00000290 D SMF
00000090 IEE351I SMF SYS1.MAN RECORDING NOT BEING USED

Jerry Wawrzyniak, a mainframe solutions engineer with our business partner Sirius, provided the following recommendation:

Here are a couple of SYS1.PARMLIB members that you should review on your current production system and set something like them up on the RUT system in USER.PARMLIB.

SMFPRMxx
IEASYSyy for the SMF=xx entry (xx on this line should match ‘xx’ from the live above

You will need to allocate the SMF datasets that are named within the SMFPRMxx parm, they probably are called SYS1.MANx. You can allocate them similar to your production system. You probably don’t need very big ones on the RUT system and should be able to get by with two of them.

Then if you don’t want to keep the SMF data on the RUT system, you should have a job like this one to clear out the SMF files when they fill up.

//S41GWAST JOB (362X,TSP0),'SMFINIT J900',CLASS=B,
//* TYPRUN=HOLD,
// NOTIFY=S41GWA,MSGCLASS=T
//* S41GWA.JCL.CNTL(SMFINIT) - 08/22/06
/*JOBPARM ROOM=J900
//STEP010 EXEC PGM=IFASMFDP
//SYSPRINT DD SYSOUT=*
//SYSUT1 DD DSN=SYS1.MAN4,TST2,DISP=SHR
//SYSIN DD *
INDD(SYSUT1,OPTIONS(CLEAR))

Once you have all of the above set up, you probably will need to IPL the RUT system, but you could issue the ‘T SMF=xx’ (xx would match the suffix of the SMFPRMxx member) command to see if it will take effect.

FYI for everyone who uses this forum SMF is enabled by default for RD&T v8.5.