Topic
  • 7 replies
  • Latest Post - ‏2012-08-16T00:59:17Z by DanielWagemann
ali.khalil
ali.khalil
3 Posts

Pinned topic Error Message details messing Cognos connection

‏2012-05-10T10:30:46Z |
Hi,

I have installed and configured Cognos 10.1.1 (bisrvr_win64h_10.1.1) with Success
on Windows server 64bits.
But while I'm creating a data source on Cognos connection I notice that If i got an error when I test the connection
I cannot click on the message to see more details as on Cognos 8.4.1 (see the attached file).
Did I miss something while installing ?
Is there any fix pack for this?

Please advise

Kind Regards

Ali
Updated on 2012-08-16T00:59:17Z at 2012-08-16T00:59:17Z by DanielWagemann
  • DanielWagemann
    DanielWagemann
    850 Posts

    Re: Error Message details messing Cognos connection

    ‏2012-05-10T12:29:29Z  
    There may be more information in the cogserver.log file. If I had to venture a guess, I would say that the 32 bit Oracle client is not installed or it is installed but your system path statement does not reference it.

    The BibusTKServerMain, which performs the data access, is a 32 bit application, regardless whether or not you have installed the 32 bit or 64 bit version of the product.
  • ali.khalil
    ali.khalil
    3 Posts

    Re: Error Message details messing Cognos connection

    ‏2012-05-10T14:06:40Z  
    Hi,
    I know that I need Oracle client 32 bit on my server to establish the connection to the database, that's not the question
    my question was why i cannot see more details as in cognos 8.4.1 or Cognos 10.1.1 installed on windows xp ......
  • DanielWagemann
    DanielWagemann
    850 Posts

    Re: Error Message details messing Cognos connection

    ‏2012-05-10T14:51:21Z  
    Hi,
    I know that I need Oracle client 32 bit on my server to establish the connection to the database, that's not the question
    my question was why i cannot see more details as in cognos 8.4.1 or Cognos 10.1.1 installed on windows xp ......
    I did not get that from your original post. I thought you needed help with setting up the connection itself.

    I would report the missing error link to IBM Cognos Customer Support.

    The strange thing is that if I create a JDBC connection to be used with Dynamic Query Mode and test both connections. Compatible query mode gives me the error with no link or details; while Dynamic Query Mode gives me the link and details as expected.
  • ali.khalil
    ali.khalil
    3 Posts

    Re: Error Message details messing Cognos connection

    ‏2012-05-11T09:28:37Z  
    Hi Daniel,

    do you have any update on this?

    thank's
  • DanielWagemann
    DanielWagemann
    850 Posts

    Re: Error Message details messing Cognos connection

    ‏2012-05-11T12:34:02Z  
    Hi Daniel,

    do you have any update on this?

    thank's
    As stated above, please report this issue to IBM Cognos Customer support based on the fact the behavior is different between the two query modes when testing.
  • MalathiM
    MalathiM
    4 Posts

    Re: Error Message details messing Cognos connection

    ‏2012-08-15T22:47:40Z  
    As stated above, please report this issue to IBM Cognos Customer support based on the fact the behavior is different between the two query modes when testing.
    Hi Daniel/Ali,

    We are in the same situation where the data source is failing with no message for compatible mode and are successful in dynamic mode when we switched from 64 to 32 bit(data sources were failing for compatible mode with prior setting of 64 bit though). The reports are failing with the error "RQP-DEF-0068 Unable to connect to at least one database during a multi-database attach to 1 database....." when tried to use this data source.
    Please help us in resolving this issue.

    Thanks,
    Malathi
  • DanielWagemann
    DanielWagemann
    850 Posts

    Re: Error Message details messing Cognos connection

    ‏2012-08-16T00:59:17Z  
    • MalathiM
    • ‏2012-08-15T22:47:40Z
    Hi Daniel/Ali,

    We are in the same situation where the data source is failing with no message for compatible mode and are successful in dynamic mode when we switched from 64 to 32 bit(data sources were failing for compatible mode with prior setting of 64 bit though). The reports are failing with the error "RQP-DEF-0068 Unable to connect to at least one database during a multi-database attach to 1 database....." when tried to use this data source.
    Please help us in resolving this issue.

    Thanks,
    Malathi
    Its is not clear from your post what it is you are after.

    The fact that the error message is not displayed should be reported to IBM Cognos Customer support.

    The 64 bit Report Server only supports Dynamic Query Mode data sources. So if the 64 bit report server is set then it does not matter that compatiable throws an error as you cannot use the compatible connections anyway.

    If you are set to a 32 bit report server and need help troubleshooting the connection issue, please start another thread with the following details.

    The database version and type you are connecting to.
    The type of connection being defined in Cognos Administration.
    The version of the database client install on the IBM Cognos BI system and whether or not you can make a connection from its native tool. For example, if you are using Oracle are you able to connect through SQL PLUS on the BI Server.

    The bit depth 32 or 64 bit of the Cognos Install, Operating System and Native DB client installed.

    A helpful trace would be the ipfudaclientconfig.xml.sample renamed and implemented for a single failed connection attempt.