Topic
  • 4 replies
  • Latest Post - ‏2012-05-07T15:04:05Z by chr78
chr78
chr78
143 Posts

Pinned topic clarification needed on the Backward compatibility problem in GPFS 3.4.0.12

‏2012-05-05T14:56:32Z |
is the issue also present in remote cluster configurations ?
I.e. a 3.3 cluster that does a remote mount of 3.4.0.12 filesystem ?

thanks.
Updated on 2012-05-07T15:04:05Z at 2012-05-07T15:04:05Z by chr78
  • dlmcnabb
    dlmcnabb
    1012 Posts

    Re: clarification needed on the Backward compatibility problem in GPFS 3.4.0.12

    ‏2012-05-06T02:45:01Z  
    This has nothing to do with filesystem versions. This is a code compatibility problem with 3.4.0.12 nodes interacting with any node that is running 3.4.0.6 or older code. Install 3.4.0.13 instead of 3.4.0.12 while doing a rolling migration from 3.3 or old 3.4 code versions, or have clusters running different versions of code.
  • chr78
    chr78
    143 Posts

    Re: clarification needed on the Backward compatibility problem in GPFS 3.4.0.12

    ‏2012-05-07T07:37:38Z  
    • dlmcnabb
    • ‏2012-05-06T02:45:01Z
    This has nothing to do with filesystem versions. This is a code compatibility problem with 3.4.0.12 nodes interacting with any node that is running 3.4.0.6 or older code. Install 3.4.0.13 instead of 3.4.0.12 while doing a rolling migration from 3.3 or old 3.4 code versions, or have clusters running different versions of code.
    Dan, I should indeed have written "remote cluster version" and not file system version.
    Just to fully understand your answer - the problem also exists in remote cluster
    configurations where e.g. a 3.3 cluster connects to a cluster containing 3.4.0.12 nodes.

    thanks again.
  • dlmcnabb
    dlmcnabb
    1012 Posts

    Re: clarification needed on the Backward compatibility problem in GPFS 3.4.0.12

    ‏2012-05-07T14:33:36Z  
    • chr78
    • ‏2012-05-07T07:37:38Z
    Dan, I should indeed have written "remote cluster version" and not file system version.
    Just to fully understand your answer - the problem also exists in remote cluster
    configurations where e.g. a 3.3 cluster connects to a cluster containing 3.4.0.12 nodes.

    thanks again.
    Correct, if any node is the cluster (local or remote) is running 3.3, or 3.4.0.6 or earlier, then it can cause the node running 3.4.0.12 to die with an assertion failure, and in rare cases cause filesystem corruption.
  • chr78
    chr78
    143 Posts

    Re: clarification needed on the Backward compatibility problem in GPFS 3.4.0.12

    ‏2012-05-07T15:04:05Z  
    thanks alot, Dan!