Topic
  • 2 replies
  • Latest Post - ‏2012-05-04T14:15:48Z by ENO2010
ENO2010
ENO2010
134 Posts

Pinned topic [RBD 8.0.1] : Headless deploy

‏2012-05-04T09:49:41Z |
Hi,

on the EGL Blog, I read an article about "headless deploy" https://www.ibm.com/developerworks/mydeveloperworks/blogs/3e2b35ae-d3b1-4008-adee-2b31d4be5c92/entry/headless_hint_deploy?lang=it
I downloaded the "headlessDeployFiles.zip" and changed the variable value in SetRBDEnvironment to match my RBD configuration.
Running the cmd file "deployFromCMDFile.cmd", I received the next errors :

C:\temp\headlessDeployFiles>
"C:\Program Files (x86)\IBM\SDP\jdk\jre\bin\java.exe" EGLCMD myRUIProject/deployCMDFile.xml -data 
"C:\workspace8\EGLCourse" IWN.VAL.3999.e - \myRUIProject\deployCMDFile.xml - 4/79 - XML Validation Error - org.xml.sax.SAXParseException: Le type d
'‚l‚ment "deploy" doit ˆtre d‚clar‚. - in file \myRUIProject\deployCMDFile.xml IWN.VAL.3999.e - \myRUIProject\deployCMDFile.xml - 5/15 - XML Validation Error - org.xml.sax.SAXParseException: Le contenu du type d
'‚l‚ment "EGLCOMMANDS" doit correspondre … "(generate)*". - in file \myRUIProject\deployCMDFile.xml


the problem seems to be the "deploy" tag.


<?xml version=
"1.0" encoding=
"UTF-8"?> <!DOCTYPE EGLCOMMANDS PUBLIC 
"-//IBM//DTD EGLCOMMANDS 5.1//EN" 
""> <EGLCOMMANDS> <deploy deploymentDescriptorFile=
"myRUIProject\EGLSource\myRUIProject.egldd"></deploy> </EGLCOMMANDS>


some idea??

Eric
Updated on 2012-05-04T14:15:48Z at 2012-05-04T14:15:48Z by ENO2010
  • Paul_Hoffman
    Paul_Hoffman
    134 Posts

    Re: [RBD 8.0.1] : Headless deploy

    ‏2012-05-04T14:12:18Z  
    Hi Eric,

    My French is not strong, but I'm thinking the error messages are saying the EGLCMD command must start with "generate."

    The EGLCMD support for deploy was added in 8.0.1.2.

    Is it possible you are trying to use it on an earlier version?

    Paul
  • ENO2010
    ENO2010
    134 Posts

    Re: [RBD 8.0.1] : Headless deploy

    ‏2012-05-04T14:15:48Z  
    Hi Eric,

    My French is not strong, but I'm thinking the error messages are saying the EGLCMD command must start with "generate."

    The EGLCMD support for deploy was added in 8.0.1.2.

    Is it possible you are trying to use it on an earlier version?

    Paul
    Hi Paul,
    I'm using RBD 8.0.1 I will install the fix and try again.

    thank you

    Eric