Topic
  • 1 reply
  • Latest Post - ‏2012-05-24T18:19:01Z by SachinTalreja
SachinTalreja
SachinTalreja
2 Posts

Pinned topic Indefinitely running verify orchestration tab | No instance of result visbl

‏2012-05-03T17:37:04Z |
I have created an orchestration which is not showing any instance of result when I am running the orchestration.

Endpoint:
Source : Database endpoint in CI (Microsoft SQL server)
Target : Netsuite

CI version used: 6.1.0.6

Requirement:
The orchestration must do the following
Whenever a data is inserted or updated or deleted in the database it should update the record type in the Netsuite.

Orchestration:

Pick-->Get X row Activity(DB)--> Y record(NS)

Where, X= Get inserted/updated/deleted row activity
Y=add/update/delete record activity

I tried using the pick activity followed by the get inserted/updated/deleted row activity, this was followed by the add update and delete record activities of Netsuite.

Issue:
The issue is that when I click on verify the orchestration it starts running but no instance of result is created/visible.It runs for an indefinite period.
I tried updating and inserting the record when the orchestration was running but it behaved the same way as mentioned above.

Can you please suggest a possible solution to this problem?
Is it possible to use poll activity?

PS:I tried using the Execute query in the orchestration and its working fine. It is inserting the record on the Netsuite Endpoint.
It would be really very helpful if any one can provide a solution to this problem.

Thanks.
Sachin
Updated on 2012-05-24T18:19:01Z at 2012-05-24T18:19:01Z by SachinTalreja
  • SachinTalreja
    SachinTalreja
    2 Posts

    Re: Indefinitely running verify orchestration tab | No instance of result visbl

    ‏2012-05-24T18:19:01Z  
    Hi All,

    Found the solution to this.

    Whenever we run the orchestration we have to RECREATE the table and the three buffer triggers
    i.e.
    Buffer Table
    Insert trigger
    Update trigger
    Delete trigger

    First time: Click on CREATE the table and after that Recreate it or drop and create it again.

    Regards,
    Sachin