Topic
  • 5 replies
  • Latest Post - ‏2012-05-04T09:02:21Z by SystemAdmin
HansGr
HansGr
3 Posts

Pinned topic Licence Metric Tool 7.5 Installation problem on windows

‏2012-04-18T18:24:36Z |
I have managed to install the License Metric tool 7.5 (and fixpack) on a Windows 2008 server but having problems to configure the problem.
After logging into the Integrated console on the server with the Tipadmin account setup during installation I am unable to see menu options which should appear according to the documentation. For example according to the documentation I should have the following: 1.In the navigation bar, click Administration > Import Software Catalog. In my enviroment I do not have an Administration selection and If I choose "IBM License Metric tool" in the console Default view selection I get the following error: "form's onsubmit threw an error: Function expected"
Thankful for any help to find a solution before I try a re-installation. Thanks Hans
Updated on 2012-05-04T09:02:21Z at 2012-05-04T09:02:21Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: Licence Metric Tool 7.5 Installation problem on windows

    ‏2012-04-19T12:41:45Z  
    Hello Hans,
    May I know what kind of web browser do you use?

    Regards,
    Michał Klak
  • HansGr
    HansGr
    3 Posts

    Re: Licence Metric Tool 7.5 Installation problem on windows

    ‏2012-04-20T12:41:29Z  
    Thanks for feedback. I have tested both with IE9 on the server and IE8 on my client.
    Have attached a sceenshot of how it looks. The difference between IE8 & IE9 is that in IE8
    I do not get the "form's unsubmit" error message that I wrote in my original post. But the "Licence metric tool" menu
    section is still totally blank. see attached screenshot
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: Licence Metric Tool 7.5 Installation problem on windows

    ‏2012-04-20T14:13:45Z  
    • HansGr
    • ‏2012-04-20T12:41:29Z
    Thanks for feedback. I have tested both with IE9 on the server and IE8 on my client.
    Have attached a sceenshot of how it looks. The difference between IE8 & IE9 is that in IE8
    I do not get the "form's unsubmit" error message that I wrote in my original post. But the "Licence metric tool" menu
    section is still totally blank. see attached screenshot
    Hello Hans,

    IE9 is not supported but if on IE8 it looks as you sent, I believe there were some installation problems, maybe during the main installation, maybe during the TIP fix installation (I assume from your previous post that you took the mandatory step and you run Patch Installer after ILMT 7.5 installation).

    I would suggest to open PMR against this issue. IBM support will have to take a look into your installation logs. But before doing this, you may perform the last check - try if it works for you on Firefox 3.6 (available to download from here:
    http://www.oldapps.com/firefox.php?old_firefox=72
    ). In this way, we will eliminate the possibility that your particular IE8 version is somehow incompatible with TIP.

    Regards,
    Michał Klak
  • HansGr
    HansGr
    3 Posts

    Problem solved Metric Tool 7.5 Installation problem on windows

    ‏2012-05-03T08:08:09Z  
    I opened a PMR towards and was suggested to connect all available roles to the tipadmin user.
    After logging in again the missing menus appeared. I did not get info about exactly which roles were needed but I was happy it was working.
    Thanks for the other tips i received. //Hans
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: Problem solved Metric Tool 7.5 Installation problem on windows

    ‏2012-05-04T09:02:21Z  
    • HansGr
    • ‏2012-05-03T08:08:09Z
    I opened a PMR towards and was suggested to connect all available roles to the tipadmin user.
    After logging in again the missing menus appeared. I did not get info about exactly which roles were needed but I was happy it was working.
    Thanks for the other tips i received. //Hans
    Hello Hans,

    It sounds strange for me. tipadmin gets all the roles from the beginning.
    Indeed, you may create new users, and assign predefined roles to them (iscadmins, administrator, inventoryadministrator, softwareassetmanager) and depends on those roles, such users will see different options in the menu after logging to the TIP. But because tipadmin has all the roles, you should have been able to see the full menu from the very beginning.
    Two possible explanaitons of your situations come to my mind now:
    a) during the ILMT installation the default name of the TIP administrator (tipadmin) has been changed to different one and that user got all the priviledges instead of tipadmin
    b) someone removed the roles from tipadmin after the installation via standard functionality
    c) actually there is no c - c means as I started this post "strange"
    Thanks for your input,
    Michal Klak

    References:
    http://publib.boulder.ibm.com/infocenter/tivihelp/v53r1/topic/com.ibm.lmt75.doc/com.ibm.license.mgmt.security.doc/t_assigning_users_to_roles.html