Topic
  • No replies
SystemAdmin
SystemAdmin
9 Posts

Pinned topic WAS on AIX does not find the IBM NameWorks JNI library

‏2012-04-18T14:11:41Z |
Hi,

I have an application (which uses GNR) that is installed on WAS on AIX. This app depends on a JAR that calls some native methods through JNI (NameWorks - libscoring.so). My question is: how can I setup my application on WAS to make JNI work?

It looks like WAS does not find the native library (whis is named libscoring.so). I tried to provide a -Djava.library.path property to the server JVM, pointing to the directory where the library is stored. It didn't work. I also tried to create a shared library on WAS and it did not work either.

In the code, when I call System.loadLibrary("scoring") it throws an UnsatisfiedLinkError, saying that the library could not be found. The same application works perfectly fine on Windows (i.e. installed on WAS running on a Windows OS).

I am using a 64 bits NameWorks library and AIX is 64 bits as well.

When I print the value of java.library.path property, I can see the directory where the library is. But WAS does not find it. I also granted 777 permission to the file and directory, so I am sure it's not a permission problem.

Any ideas?

Thanks!