Topic
  • 7 replies
  • Latest Post - ‏2013-08-20T23:00:54Z by daixtr
tmours
tmours
2 Posts

Pinned topic NMON/TOPAS fails after alt_disk migration to AIX 6.1 from AIX 5.3

‏2012-04-18T14:11:05Z |
NMON/TOPAS fails after alt_disk migration to AIX 6.1
I'm getting the following when starting either one:
moxb8f,root:/# topas -i1
ERROR: Assert Failure in file="nmonDisplay.c" in function="init_cpu_stats" at line=3259
ERROR: Reason=System call returned -1
ERROR: Expression=[cpudata = perfstat_cpu(&perfid, p->cpus, sizeof_perfstat_cpu_t, absolute_max_cpus)]
ERROR: errno=109
ERROR: errno means : Function not implemented
ERROR: Sizeof cpu=616 cpu_total=696 disk=496 diskadapter=200 diskpath=312 disktotal=192, memory=352 netbuff=128 netif=224 netiftotal=80 paging=248 partition=624 protocol=728
moxb8f,root:/# nmon -s1
ERROR: Assert Failure in file="nmonDisplay.c" in function="init_cpu_stats" at line=3259
ERROR: Reason=System call returned -1
ERROR: Expression=[cpudata = perfstat_cpu(&perfid, p->cpus, sizeof_perfstat_cpu_t, absolute_max_cpus)]
ERROR: errno=109
ERROR: errno means : Function not implemented
ERROR: Sizeof cpu=616 cpu_total=696 disk=496 diskadapter=200 diskpath=312 disktotal=192, memory=352 netbuff=128 netif=224 netiftotal=80 paging=248 partition=624 protocol=728
moxb8f,root:/distribution/sudo # lslpp -l
moxb8f,root:/distribution/sudo # lslpp -L bos.perf.tools
Fileset Level State Type Description (Uninstaller)

bos.perf.tools 6.1.7.2 C F Base Performance Tools
Updated on 2012-10-03T03:55:31Z at 2012-10-03T03:55:31Z by SystemAdmin
  • pacynka
    pacynka
    8 Posts

    Re: NMON/TOPAS fails after alt_disk migration to AIX 6.1 from AIX 5.3

    ‏2012-04-19T07:25:48Z  
    Maybe sill question, but I get similliar error after simple cd migration:
    Did you restart AIX after migration has completed?
  • tmours
    tmours
    2 Posts

    Re: NMON/TOPAS fails after alt_disk migration to AIX 6.1 from AIX 5.3

    ‏2012-04-19T13:30:25Z  
    • pacynka
    • ‏2012-04-19T07:25:48Z
    Maybe sill question, but I get similliar error after simple cd migration:
    Did you restart AIX after migration has completed?
    Hi, Yes, several times. My migration took the system to TL 4. I then applied the maintenance to take it to TL 7 SP3 & re-booted. I didn't realize that nmon-topas wasn't working till a couple days later.
  • SystemAdmin
    SystemAdmin
    2402 Posts

    Re: NMON/TOPAS fails after alt_disk migration to AIX 6.1 from AIX 5.3

    ‏2012-07-23T11:43:50Z  
    • tmours
    • ‏2012-04-19T13:30:25Z
    Hi, Yes, several times. My migration took the system to TL 4. I then applied the maintenance to take it to TL 7 SP3 & re-booted. I didn't realize that nmon-topas wasn't working till a couple days later.
    Did you find any solution?
    I've got the same error after upgrade from 6.1 TL4 to TL7.
  • Jordi_Santanes
    Jordi_Santanes
    1 Post

    Re: NMON/TOPAS fails after alt_disk migration to AIX 6.1 from AIX 5.3

    ‏2012-10-01T15:28:43Z  
    Did you find any solution?
    I've got the same error after upgrade from 6.1 TL4 to TL7.
    We had the same problem.

    After migration in AIX6.1 from TL4 to TL7.

    The procedure we followed to solve this issue was:

    1 - check the os_uuid, with the command
    lsattr -l sys0 -a os_uuid -E

    if the result is like this output:
    os_uuid N/A True

    you have to recreate de id with this command:
    chdev -l sys0 -a os_uuid=""

    check again and you will see something like that:

    os_uuid 234259f-4243-5363-51f4-0987654321f1 N/A True

    2 - reboot the system

    3 - Topas and nmon should work now.

    I hope this can help.
  • SystemAdmin
    SystemAdmin
    2402 Posts

    Re: NMON/TOPAS fails after alt_disk migration to AIX 6.1 from AIX 5.3

    ‏2012-10-03T03:55:31Z  
    Hi Jordi_Santanes,

    Your post quickly helps me! Have encountered the same and resolved upon reading your post.

    Regards
  • Mesal
    Mesal
    2 Posts

    Re: NMON/TOPAS fails after alt_disk migration to AIX 6.1 from AIX 5.3

    ‏2013-05-12T07:10:39Z  

    Hi all

    am facing the same issue with little difference, please advise the bellow:

    bash-4.2# topas
    ERROR: Assert Failure in file="nmonDisplay.c" in function="init_network_stats" at line=3420
    ERROR: Reason=System call returned -1
    ERROR: Expression=[[perfstat_netinterface(&perfid, p->ifnets, sizeof(perfstat_netinterface_t), networks)]]
    ERROR: errno=109
    ERROR: errno means : Function not implemented
    ERROR: Sizeof cpu=608 cpu_total=672 disk=488 diskadapter=200 diskpath=312 disktotal=80, memory=336 netbuff=128 netif=216 netiftotal=72 paging=248 partition=608 protocol=728

    The lsattr -l sys0 -a os_uuid -E output is:

    bash-4.2# lsattr -l sys0 -a os_uuid -E
    lsattr: 0514-528 The "os_uuid" attribute does not exist in the predefined
            device configuration database.

    Updated on 2013-05-12T07:11:27Z at 2013-05-12T07:11:27Z by Mesal
  • daixtr
    daixtr
    1 Post

    Re: NMON/TOPAS fails after alt_disk migration to AIX 6.1 from AIX 5.3

    ‏2013-08-20T23:00:54Z  

    i'm getting the same case as Mesal when i ran `lsattr -l sys0 -a os_uuid -E`.  Is there a definitive answer to this error message?