Topic
  • 3 replies
  • Latest Post - ‏2012-04-19T09:20:36Z by svmanoj
svmanoj
svmanoj
2 Posts

Pinned topic QSH environment variable access problem

‏2012-04-18T13:05:26Z |
Hi

We have two development Iseries systems. When I run QSH on both the systems i can see two major differences this creating problem in running same program on these systems.

First system
1. When i run command QSH, i am getting '$' prompt.
2. I can access environment variable like $XXXX in the shell commands.

Second System
1. When i run command QSH, I am getting '¢' prompt.
2. I am unable to use '$' symbol to access the environment variables, instead if I use '¢' system i could able to access them without problem (example ¢XXXX).
I have written CL program in first system, which is not working on second system even though both are having same OS version. After investigation I understood that i can not use '$' to access environment variable on the second system.

Can i change something on second system to use '$' instead of '¢' symbol in order access environment variables in shell commands? This helps me to run same CL program contains shell commands on both these systems.

Please help me. Thanks in advance.

Manoj
Updated on 2012-04-19T09:20:36Z at 2012-04-19T09:20:36Z by svmanoj
  • barbara_morris
    barbara_morris
    385 Posts

    Re: QSH environment variable access problem

    ‏2012-04-18T15:22:46Z  
    Hi Manoj, this is the RPG forum. You might get a better response if you post questions about QSH in the more general IBM i forum http://www.ibm.com/developerworks/forums/forum.jspa?forumID=2675.
  • scott_klement
    scott_klement
    244 Posts

    Re: QSH environment variable access problem

    ‏2012-04-18T21:04:00Z  
    Hi Manoj,

    Unix systems normally use $ as a prompt, and they always use $ to identify variables. They NEVER use ¢, it's not even a possibility to change them to work that way.

    So, I'm thinking that this isn't a problem with "QShell configured for ¢", but rather, the problem is that QShell is sending $ as normal, but it looks like a ¢ on your display. That implies that you have a misconfiguration somewhere, most likely with the CCSID settings somewhere.

    I would suggest that you make sure your system and job CCSID settings are correct. I would also make sure that you've followed the "National Language Support Considerations" that IBM suggests in the QShell manual. Here's a link to that page of the manual:
    http://publib.boulder.ibm.com/infocenter/iseries/v7r1m0/topic/rzahz/rzahznls.htm
  • svmanoj
    svmanoj
    2 Posts

    Re: QSH environment variable access problem

    ‏2012-04-19T09:20:36Z  
    Hi Manoj,

    Unix systems normally use $ as a prompt, and they always use $ to identify variables. They NEVER use ¢, it's not even a possibility to change them to work that way.

    So, I'm thinking that this isn't a problem with "QShell configured for ¢", but rather, the problem is that QShell is sending $ as normal, but it looks like a ¢ on your display. That implies that you have a misconfiguration somewhere, most likely with the CCSID settings somewhere.

    I would suggest that you make sure your system and job CCSID settings are correct. I would also make sure that you've followed the "National Language Support Considerations" that IBM suggests in the QShell manual. Here's a link to that page of the manual:
    http://publib.boulder.ibm.com/infocenter/iseries/v7r1m0/topic/rzahz/rzahznls.htm
    Thank you very much scott.

    Yes, it is to do with CCSID. My emulator has CCSID 037 and my iseries CCSID is 285. This created problem, i changed my emulator CCSID to 285 then it worked perfectly.

    Thanks again.