Topic
3 replies Latest Post - ‏2012-04-18T15:28:34Z by Novikov_Alexander
jkirc
jkirc
4 Posts
ACCEPTED ANSWER

Pinned topic Cisco 3012 (OS-CIGESM-18SFP-I) problem with disabled interface

‏2012-04-17T11:55:06Z |
We moved a Bladecenter along with a bunch of other servers to a new datacenter 3 days ago. When powering everything up we found that one external interface on one of the two switches would not come up.

The cisco configuration is as follows (and has not been changed! We simply shut everything down, moved it and then powered it up again at the new location):

The Bladecenter H (w/ AMM) has two Cisco 3012 switches in IO bay 1 and 2. Ports 19 and 20 of each are connected to external Procurve switches (trunked aka etherchannel). IOS (tm) CIGESM Software (CIGESM-I6Q4L2-M), Version 12.1(22)EA13, RELEASE SOFTWARE (fc2)

On switch #2 everything works fine, on switch #1 port 19 would not come up - and I can't do "no shutdown" on it, even when I remove the port from the portchannel.

on the procurves the config is simple and unchanged, the config of both ciscos in the Bladecenter is identical... I am confused?! they only use ciscos at the datacentre and have some experts tehre, but they are confused, too?

I read that I could disable the external ports with the AMM, but as far as I understand that is a global configuration and since only one port is not working that can't be it? besides, I don't see the option in my AMM (there is only "External management over all ports", but no option "External ports").

right now it works with only one interface in the portchannel active...

Any ideas? Thanks. Jan
bl1-cisco1(config)#int gi 0/19
bl1-cisco1(config-if)#no shut
% Shutdown not allowed on this interface.

bl1-cisco1(config-if)#end
bl1-cisco1#show int gig 0/19
GigabitEthernet0/19 is administratively down, line protocol is down (disabled)
Hardware is Gigabit Ethernet, address is 0015.c6cc.fe53 (bia 0015.c6cc.fe53)
Description: uplink Procurve1
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto-duplex, Auto-speed, media type is SX
input flow-control is off, output flow-control is off
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 2d21h, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
interface Port-channel1
description "Trunk to Procurve"
switchport trunk allowed vlan 1-50
switchport mode trunk
switchport nonegotiate
flowcontrol receive on
flowcontrol send off

!
interface GigabitEthernet0/19
description uplink Procurve1
switchport trunk allowed vlan 1-50
switchport mode trunk
switchport nonegotiate
shutdown
flowcontrol receive on
auto qos voip trust
macro description cisco-switch | cisco-switch
channel-group 1 mode on
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/20
description uplink Procurve2
switchport trunk allowed vlan 1-50
switchport mode trunk
switchport nonegotiate
flowcontrol receive on
auto qos voip trust
macro description cisco-switch | cisco-switch
channel-group 1 mode on
spanning-tree link-type point-to-point
!
Updated on 2012-04-18T15:28:34Z at 2012-04-18T15:28:34Z by Novikov_Alexander
  • Novikov_Alexander
    Novikov_Alexander
    1147 Posts
    ACCEPTED ANSWER

    Re: Cisco 3012 (OS-CIGESM-18SFP-I) problem with disabled interface

    ‏2012-04-17T18:23:47Z  in response to jkirc
    Dear Jan,

    > I don't see the option in my AMM (there is only "External management over all ports", but no option "External ports").

    you can find option "External ports" on page I/O Module Tasks -> Admin/Power/Restart -> I/O Module Advanced Setup :

    http://www-947.ibm.com/systems/support/reflib/simulators/options/amm4.5/sw_pwr.html
    http://www-947.ibm.com/systems/support/reflib/simulators/options/amm4.5/main.html

    Regards,
    Alexander Novikov
    Russia, Moscow
    • jkirc
      jkirc
      4 Posts
      ACCEPTED ANSWER

      Re: Cisco 3012 (OS-CIGESM-18SFP-I) problem with disabled interface

      ‏2012-04-18T08:02:44Z  in response to Novikov_Alexander
      Alexander,
      Thank you, it works! The external ports option was disabled for both switches.
      my documentation is somewhat old and that must have changed with an AMM firmware update.

      But what I don't understand: Why did some external ports work? i.e. Port 20 was working, 17-19 were "disabled"?! Although that option was set wrong in the AMM? And why did that option change as we powered everything down?!

      Jan
      • Novikov_Alexander
        Novikov_Alexander
        1147 Posts
        ACCEPTED ANSWER

        Re: Cisco 3012 (OS-CIGESM-18SFP-I) problem with disabled interface

        ‏2012-04-18T15:28:34Z  in response to jkirc
        Hi Jan,

        looks like software bug. Update all software on AMM, blade-modules and blade-servers.

        Regards,
        Alexander Novikov
        Russia, Moscow