Topic
  • 1 reply
  • Latest Post - ‏2012-04-16T02:11:49Z by SystemAdmin
SystemAdmin
SystemAdmin
40 Posts

Pinned topic No contents on index.html and found Java Exception in TIP SystemOut

‏2012-04-14T15:27:22Z |
I have done the following steps, but I can not find any contents on https://<TIP_Server>:16311/ibm/tivoli/apm/rest/apm/index.html other than dark gray background.

- Installed APM war
- Configured ITM V6.2.3 SOAP Server
- Enabled REST Service on TEPS

I checked the SystemOut.log of TIP jvm and found some Java Exception messages.

Can I have any advice to solve this ?
Updated on 2012-04-16T02:11:49Z at 2012-04-16T02:11:49Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    40 Posts

    Re: No contents on index.html and found Java Exception in TIP SystemOut

    ‏2012-04-16T02:11:49Z  
    1. Firstly please ensure you use IE ver 9 or above or FireFox ver 10 or above to view the APM. They are currently supported by APM.
    2. After you installed APM with wsadmin in TIP server, have you seen any exception messages and then restarted the TIP server?
    3. Please check if port 16311 is listening(suppose you didn't change the config) after restart TIP: "netstat -an|grep 16311"
    4. From the log, I can see the JSONObject can't be found which is required by APM:
    4/15/12 0:01:43:557 JST 0000000c InjectionProc W CWNEN0050W: Resource annotations on the methods of the com.ibm.tivoli.apm.rest.util.AbstractRestServlet class will be ignored. The com.ibm.tivoli.apm.rest.util.AbstractRestServlet class is being processed for annotations because it is referenced by the com.ibm.tivoli.apm.rest.WidgetsRestServlet application class. The annotations could not be obtained because of the exception : java.lang.NoClassDefFoundError : com.ibm.json.java.JSONObject.
    The json lib shall be located in /opt/IBM/tivoli/tipv2/profiles/TIPProfile/installedApps/TIPCell/isc.ear/JSON4J.jar and /opt/IBM/tivoli/tipv2/profiles/TIPProfile/installedApps/TIPCell/isc.ear/TIPChangePasswd.war/WEB-INF/lib/JSON4J.jar.
    Please check it.
    If they are there and the problem still exists, please try to export CLASSPATH=$CLASSPATH:*/JSON4J.jar listed above before starting TIP server again.