Topic
  • 3 replies
  • Latest Post - ‏2012-05-04T10:26:57Z by UserSpanish
UserSpanish
UserSpanish
21 Posts

Pinned topic Problem with service invoke.

‏2012-04-12T15:32:20Z |
Hi,

I'm trying to call a service with "Service Invoke". This service is a called to PL/SQL. When I only execute this module which I have used an JDBC Adapter, I don't have any problem, but when I've added this service inside of my mediation flow I get an exceptión but I don't know why.

Could someone help me??

Thank you!

CWSXM0201E: El flujo de mediación ha devuelto una excepción del componente ModuloPL en el módulo ModuloPL: CWSXM3300E: La primitiva 'Fail5', componente 'ModuloPL', módulo 'ModuloPL', interfaz '{http://WebServiceTestOracle/WebServiceTestOracle}WebServiceTestOracleGenerico', operación 'testModulo', generó una FailFlowException. El mensaje de error proporcionado es '12/04/12 17:13, A71E11B2-0136-4000-E000-0E4CAC18167C, Fail5, ModuloPL, <failInfo xmlns:ns0="http://www.ibm.com/websphere/sibx/smo/v6.0.1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="ns0:FailInfoType">
<failureString>java.lang.NullPointerException</failureString>
<origin>ServiceInvoke1</origin>
<invocationPath>
<primitive inTerminal="in" name="XSLTransformation1" outTerminal="out"/>
<primitive inTerminal="in" name="ServiceInvoke1" outTerminal="fail"/>
</invocationPath>
</failInfo>
, 7'.
Updated on 2012-05-04T10:26:57Z at 2012-05-04T10:26:57Z by UserSpanish
  • UserSpanish
    UserSpanish
    21 Posts

    Re: Problem with service invoke.

    ‏2012-04-13T07:21:39Z  
    I attach the image of my flow.

    So, how can I invoke this module from another flow?? I think that it must be pretty easy!, but I think that there's something what I don't know :(
  • Ronn78
    Ronn78
    12 Posts

    Re: Problem with service invoke.

    ‏2012-04-16T15:52:47Z  
    I attach the image of my flow.

    So, how can I invoke this module from another flow?? I think that it must be pretty easy!, but I think that there's something what I don't know :(
    Put trace after XSLT map (before invoke) and make sure you are moving all required fields that are needed for this service call. There may be other reason but I would check this as my 1st step to troubleshoot this.
    Thanks.
  • UserSpanish
    UserSpanish
    21 Posts

    Re: Problem with service invoke.

    ‏2012-05-04T10:26:57Z  
    • Ronn78
    • ‏2012-04-16T15:52:47Z
    Put trace after XSLT map (before invoke) and make sure you are moving all required fields that are needed for this service call. There may be other reason but I would check this as my 1st step to troubleshoot this.
    Thanks.
    Thank you, I got it.