Topic
  • 3 replies
  • Latest Post - ‏2012-04-12T11:43:32Z by SystemAdmin
ey344
ey344
15 Posts

Pinned topic Install VIOS on a Power 770 (MMC) with a 5901 SAS adapter PCI card

‏2012-04-10T21:55:49Z |
Hello All,

Has anyone had experience of installing a VIOS partition whose hdisks are on a 5901 SAS adapter which is located in a 5877?

I am installing VIOS from a 2.2 Install DVD. The partition profile owns two 5901 SAS adapters which are attached via an X cable to a 5887 disk drawers each with a 146GB disk for VIOS.

The install keeps falling over because it can't find any disks to boot. I'm pretty sure it's cabled properly. It's not that it falls over straight away, I get through SMS reading the DVD, starting the kernal and select language etc.

Firmware / HMC for the MMC is OK.

Thanks in advance for help..

Ed
Updated on 2012-04-12T11:43:32Z at 2012-04-12T11:43:32Z by SystemAdmin
  • sajjadhashimi
    sajjadhashimi
    10 Posts

    Re: Install VIOS on a Power 770 (MMC) with a 5901 SAS adapter PCI card

    ‏2012-04-11T17:23:54Z  
    Do you see the disk(s) in SMS under either VIO? If not, its definately a configuration/cabling issue.
  • ey344
    ey344
    15 Posts

    Re: Install VIOS on a Power 770 (MMC) with a 5901 SAS adapter PCI card

    ‏2012-04-11T22:32:04Z  
    Do you see the disk(s) in SMS under either VIO? If not, its definately a configuration/cabling issue.
    A bit more research and there was a cable issue. Replacing X cables with YO cables and setting up as per Infocenter, sorted that out.

    For VIOS to be installed on disk in a 5887, you need an install image of 2.2.1.x.

    I can now boot from the tape drive (which is a backupios of a system at 2.2.1.1) and select hdisk0.

    However the BOS Install keeps failing with:

    0516-404 allocp: Not enough PP to create an LV.
    0516-822

    These are fresh 146GB install disks, so I am now at a loss for these messages.

    Any further assistance greatly appreciated.
  • SystemAdmin
    SystemAdmin
    1743 Posts

    Re: Install VIOS on a Power 770 (MMC) with a 5901 SAS adapter PCI card

    ‏2012-04-12T11:43:32Z  
    • ey344
    • ‏2012-04-11T22:32:04Z
    A bit more research and there was a cable issue. Replacing X cables with YO cables and setting up as per Infocenter, sorted that out.

    For VIOS to be installed on disk in a 5887, you need an install image of 2.2.1.x.

    I can now boot from the tape drive (which is a backupios of a system at 2.2.1.1) and select hdisk0.

    However the BOS Install keeps failing with:

    0516-404 allocp: Not enough PP to create an LV.
    0516-822

    These are fresh 146GB install disks, so I am now at a loss for these messages.

    Any further assistance greatly appreciated.
    Hi,

    Where does the backupios image come from ? Is it from another VIO with mirrored rootvg ?
    In that case, maybe the solution is to modify image.data and bosinst.data files to match install environment, or try to select a number of disks matching the mirroring on original configuration.