Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
7 replies Latest Post - ‏2012-04-25T07:44:58Z by SystemAdmin
VFV0_Camilo_Alcantara
3 Posts
ACCEPTED ANSWER

Pinned topic Bringing up TS 4.2 Trial version CICS test regions and getting SOS

‏2012-04-09T17:54:34Z |
Trying to bring up a CICS TS 4.2 Trial test region, running z/OS 1.11 but getting a short on storage
condition.

DFHWB1007 CICSSS11 Initializing CICS Web environment.
DFHSM0133 CICSSS11 CICS is under stress (short on storage above 16MB).

Any clues as to what I may have missed? SIT parm settings, additional z/OS 1.11 PTFs required or other related upgrades?
Updated on 2012-04-25T07:44:58Z at 2012-04-25T07:44:58Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    124 Posts
    ACCEPTED ANSWER

    Re: Bringing up TS 4.2 Trial version CICS test regions and getting SOS

    ‏2012-04-10T09:05:14Z  in response to VFV0_Camilo_Alcantara
    Hello,

    It sounds like the EDSALIM SIT parameter for your CICS region is low. What do you have this set at? If you increase this value that should hopefully allow you to bring up the CICS region.

    Cheers

    Adam Coulthard
    • VFV0_Camilo_Alcantara
      3 Posts
      ACCEPTED ANSWER

      Re: Bringing up TS 4.2 Trial version CICS test regions and getting SOS

      ‏2012-04-10T12:30:47Z  in response to SystemAdmin
      Adam

      Here are the storage related settings that we have for the region that I am trying to bring up. Even if I set EDSALIM=500M, it still gets the same SOS condition
      DSALIM=5M
      EDSALIM=300M
      MEMLIMIT=50G
      TSMAINLIMIT=64M
      TRTABSZ=10000

      Regards,

      Camilo
      • SystemAdmin
        SystemAdmin
        124 Posts
        ACCEPTED ANSWER

        Re: Bringing up TS 4.2 Trial version CICS test regions and getting SOS

        ‏2012-04-10T17:15:50Z  in response to VFV0_Camilo_Alcantara
        Hi Camilo,

        Sorry to hear that the changes to the storage settings have not solved the issue. Looking at your values you have posted they seem to be reasonable for a CICS region to start up. Just wondering have you tried running the CICS IVP to ensure that this starts correctly (this uses a standard set of SIT parameters), if that works then it sounds like its one of the SIT options that you have specified that is causing the issue. Also I assume this is a CICS region rather than a CMAS / LMAS.

        If you are familiar with formatting CICS System Dumps then it should be possible to identify which storage pool is using the storage and this might help narrow down what is happening during startup. If you format the SM part of the dump and look at the main areas this should identify initially which ExDSA is using the storage and then from that you can look at which subpools are using the storage.

        Hope that helps

        Adam Coulthard
        • SystemAdmin
          SystemAdmin
          124 Posts
          ACCEPTED ANSWER

          Re: Bringing up TS 4.2 Trial version CICS test regions and getting SOS

          ‏2012-04-17T16:08:38Z  in response to SystemAdmin
          Hi Camilo,

          Just wondering how you are getting on with this issue and whether you have managed to get a CICS TS V4.2 Developer Trial up and running.

          Cheers

          Adam
          • VFV0_Camilo_Alcantara
            3 Posts
            ACCEPTED ANSWER

            Re: Bringing up TS 4.2 Trial version CICS test regions and getting SOS

            ‏2012-04-24T21:35:23Z  in response to SystemAdmin
            Adam,

            All is well. I found the culprit, an old DFHWBTC sitting in one of the override libraries in theDFHRPL concatenation. Currently testing TS 4.2
            with vendor products we have upgraded for compatibility.

            Thanks.
            • SystemAdmin
              SystemAdmin
              124 Posts
              ACCEPTED ANSWER

              Re: Bringing up TS 4.2 Trial version CICS test regions and getting SOS

              ‏2012-04-25T07:44:58Z  in response to VFV0_Camilo_Alcantara
              Hi,

              Glad you got to the route of the problem and CICS TS 4.2 Developer Trial is up and working.

              Cheers

              Adam Coulthard
  • BNYMKixsSupport
    BNYMKixsSupport
    3 Posts
    ACCEPTED ANSWER

    Re: Bringing up TS 4.2 Trial version CICS test regions and getting SOS

    ‏2012-04-11T18:15:15Z  in response to VFV0_Camilo_Alcantara
    My first shot would be to remove the Web from Initializing.. and see what happens.. Crude but effective...