Topic
  • 2 replies
  • Latest Post - ‏2012-04-05T14:29:03Z by SystemAdmin
SystemAdmin
SystemAdmin
403 Posts

Pinned topic Automatic restart on out-of-memory

‏2012-04-05T13:29:21Z |
For the purposes of automation and ensuring scans are completed without human intervention, I'd like AppScan to restart on its own without human intervention when AppScan's memory threshold is reached. Is there any way to do this?

Here's what I've done so far: I configured AppScan to restart when it reaches it's max memory threshold. I was expecting AppScan to restart automatically, but instead I just get a warning saying the threshold has been reached. Nothing else happens. When I attempt to continue, though, AppScan says it will automatically try to fix the problem, it saves the scan, and then successfully restarts.

Using AppScan 8.5.
Updated on 2012-04-05T14:29:03Z at 2012-04-05T14:29:03Z by SystemAdmin
  • bbrazeau
    bbrazeau
    148 Posts

    Re: Automatic restart on out-of-memory

    ‏2012-04-05T13:50:01Z  
    How long is the scan running before you encounter this message. It may be you need to set the PerformanceMonitor.MinScanTimeDurationForRestart option to a lower value. The default value is set to 30 minutes before the automatic restart is enabled.

    -B
  • SystemAdmin
    SystemAdmin
    403 Posts

    Re: Automatic restart on out-of-memory

    ‏2012-04-05T14:29:03Z  
    • bbrazeau
    • ‏2012-04-05T13:50:01Z
    How long is the scan running before you encounter this message. It may be you need to set the PerformanceMonitor.MinScanTimeDurationForRestart option to a lower value. The default value is set to 30 minutes before the automatic restart is enabled.

    -B
    Hi. I've set it to 1, 5, 10, and I'm pretty sure the scans have been running for at least the 1 minute duration. Am I correct in assuming, then, that the restart should happen automatically if the configuration is correct and the scan has met the requirements? If so, I'll go back and double-check everything and set up a more reliable test.

    Thanks for your reply.