• 1 reply
  • Latest Post - ‏2012-04-05T12:36:03Z by SystemAdmin
1 Post

Pinned topic Websphere Smash Installation Errors

‏2012-04-04T15:01:22Z |

I've installed the WebSphere sMash Command Line Interface by following the instructions here:

But now when I try to start the App Builder by typing "appbuilder open" I get this error:

CWPZT0537W: Resolve could not find the following dependencies
CWPZT0601E: Error: Command create failed
ERROR: Failed to create the AppBuilder application at C:\Users\IBM_ADMIN\Docume
The process cannot access the file because it is being used by another process.

Also, if I try to run a demo app by typing "zero create demo", "cd demo", "zero start" then I get this error:

CWPZC8029E: ZSO could not be located for the current platform of OS=windows, arc
CWPZT0601E: Error: Command start failed

Any advice on what I've done wrong with the installation would be much appreciated.


Updated on 2012-04-05T12:36:03Z at 2012-04-05T12:36:03Z by SystemAdmin
  • SystemAdmin
    9224 Posts

    Re: Websphere Smash Installation Errors

    The P8.lib dependency has platform and architecture-specific requirements. Its comparing what it finds on the system against the available versions of that library and not finding a suitable match. This suggests that you are using an unexpected JDK or installing on an unexpected platform. Most often it means you've got a 64-bit JDK installed. 'zero version' will confirm which JDK sMash thinks it is using. Update your pathing and/or JAVA_HOME environment variable and try again.