Topic
  • 4 replies
  • Latest Post - ‏2012-04-10T20:45:47Z by zlek131a
zlek131a
zlek131a
4 Posts

Pinned topic HTTP Server will not come up after 6.1.0.41 upgrade

‏2012-04-03T22:15:52Z |
Hello. I was wondering if anyone else has come across this error. I recently upgraded WebSphere and HTTP server from 6.1.0.35 to Fix Pack 6.1.0.41. WebSphere came up just fine after the upgrade however the HTTP server will not. The error that’s beeing thrown in /usr/IBMHttpServer61/IHS/logs/error_log is:

SSL0193W: Error setting GSK_ALLOW_ONLY_EXTENDED_RENEGOTIATION to 0 (701)
Error retrieving GSKit defaults from VirtualHost pepr:0, using hard-coded defaults

When I back out Fix Pack 43, the error goes away and the web server comes up fine. I am running on AIX 6.1. Thank you in advance for any help/input on this issue.

Matt L.
Updated on 2012-04-10T20:45:47Z at 2012-04-10T20:45:47Z by zlek131a
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: HTTP Server will not come up after 6.1.0.41 upgrade

    ‏2012-04-04T00:41:11Z  
    It means the global GSKit upgrade included in the fixpack is not getting applied. Maybe you're installing a fixpack to a non-root IHS and not running the GSkitImage/gskit.sh it installs as root to install the global GSkit?

    Or, your fixpack apply failed to apply a new global Gskit for some other reason.
  • zlek131a
    zlek131a
    4 Posts

    Re: HTTP Server will not come up after 6.1.0.41 upgrade

    ‏2012-04-04T03:21:51Z  
    Thanks for the feedback. The puzzling part is that I upgraded the dev env first in the exact same way and had no issues. This issue surfaced on the devTest env after the same upgrade. Owner of the HTTP server files on both envs happens to be "was1" but the HTTP server is always stared via sudo from another id. I'll take a close look on file ownership tomorrow between the two env's and see if I can see something. Thanks again. Matt.
  • zlek131a
    zlek131a
    4 Posts

    Re: HTTP Server will not come up after 6.1.0.41 upgrade

    ‏2012-04-09T21:48:28Z  
    Turns out the reason the GSKit is not being installed is because the ID I am installing the fix pack under is a non-root id and not part of the Admin group.
  • zlek131a
    zlek131a
    4 Posts

    Re: HTTP Server will not come up after 6.1.0.41 upgrade

    ‏2012-04-10T20:45:47Z  
    Running the installer with sudo fixed the issue.