Topic
  • 5 replies
  • Latest Post - ‏2013-07-04T20:11:56Z by Bill_Hudacek
SystemAdmin
SystemAdmin
1807 Posts

Pinned topic Upgrade problem for Rational Functional Tester 8.2

‏2012-04-02T15:45:58Z |
I currently have RFT 8.2 along with RSA 8.0.4 installed on a RedHat Enterprise Linux 6.1 system.

Unfortunately RFT 8.2 has problems trying to detect that Firefox 3.5+ is installed so I cannot successfully run any existing test scripts that use a web browser. I found a patch file for detecting Firefox 3.5+ but it requires a higher version of RFT. However, in the IBM Installation Manager when I try to update to 8.2.1.1, I get an error stating that RFT requires libstdc++.so.5 and libXp.so.6 (see screenshot). I have them installed from what I can determine:

root /usr/lib 1022 # ll libstdc++.so.5*
lrwxrwxrwx. 1 root root 18 Feb 22 2011 libstdc++.so.5 -> libstdc++.so.5.0.7
-rwxr-xr-x. 1 root root 733292 Jun 28 2010 libstdc++.so.5.0.7

root /usr/lib 1023 # find . -name 'libXp.so.6'
./openmotif-compat/libXp.so.6

The "Next" and "Update" buttons are disabled so I cannot do the RFT upgrade. How can I get the 8.2.1.1 upgrade installed?
Updated on 2012-04-04T22:22:13Z at 2012-04-04T22:22:13Z by Powell
  • Powell
    Powell
    51 Posts

    Re: Upgrade problem for Rational Functional Tester 8.2

    ‏2012-04-04T22:22:13Z  
    I googled and found this: http://www.ibm.com/developerworks/rational/library/09/configurerationalfunctionaltestertorunonlinux/index.html

    See the instructions on the page:

    3. You need to install the 32-bit libXp library for the Rational Functional Tester graphical interface to work correctly. Enter this command:
    1. yum install libXp.i386
  • Bill_Hudacek
    Bill_Hudacek
    3 Posts

    Re: Upgrade problem for Rational Functional Tester 8.2

    ‏2013-06-12T01:46:13Z  
    • Powell
    • ‏2012-04-04T22:22:13Z
    I googled and found this: http://www.ibm.com/developerworks/rational/library/09/configurerationalfunctionaltestertorunonlinux/index.html

    See the instructions on the page:

    3. You need to install the 32-bit libXp library for the Rational Functional Tester graphical interface to work correctly. Enter this command:
    1. yum install libXp.i386

    sorry to say that won't work for debian-based systems like ubuntu or mint. The packages are installed, but there is no 'rpm' database.

     

    I have not found a solution. IM does not support arguments that configure installations to ignore needless or inaccurate pre-requisite checking...........................

     

  • Powell
    Powell
    51 Posts

    Re: Upgrade problem for Rational Functional Tester 8.2

    ‏2013-06-12T19:50:02Z  

    sorry to say that won't work for debian-based systems like ubuntu or mint. The packages are installed, but there is no 'rpm' database.

     

    I have not found a solution. IM does not support arguments that configure installations to ignore needless or inaccurate pre-requisite checking...........................

     

    I saw http://www-01.ibm.com/support/docview.wss?uid=swg21441829

    What version of the IM are you running, Help > About will tell you.

  • Bill_Hudacek
    Bill_Hudacek
    3 Posts

    Re: Upgrade problem for Rational Functional Tester 8.2

    ‏2013-06-12T20:47:49Z  
    • Powell
    • ‏2013-06-12T19:50:02Z

    I saw http://www-01.ibm.com/support/docview.wss?uid=swg21441829

    What version of the IM are you running, Help > About will tell you.

    That's technote shows exactly the problem I'm facing, Powell. Thanks.

    However, there is no easy resolution as this is not an rpm-based distro.  I suspect it's using 'rpm -q -i libstdc++' and since my 'apt'-based system would only show it if you ran 'dpkg -s libstdc++', it reports that it's not installed.My only workaround would be to install rpm, and install libstdc++ via that route.  That's not going to work for various reasons.

    I realize this is "not a supported platform" - but the tools run 100% fine for me, and have for years.  It's only when some misguided attempt installer makes insatllation impossible that customers can't install a product.

    If it just prompted for confirmation, I could check a box.  By making it a black-box operation where I cannot override it, the product is completely unavailable.  And the platforms become severely limited.

    If you have any ideas for a workaround, please suggest.  Thanks!

    /Bill

  • Bill_Hudacek
    Bill_Hudacek
    3 Posts

    Re: Upgrade problem for Rational Functional Tester 8.2

    ‏2013-07-04T20:11:56Z  

    That's technote shows exactly the problem I'm facing, Powell. Thanks.

    However, there is no easy resolution as this is not an rpm-based distro.  I suspect it's using 'rpm -q -i libstdc++' and since my 'apt'-based system would only show it if you ran 'dpkg -s libstdc++', it reports that it's not installed.My only workaround would be to install rpm, and install libstdc++ via that route.  That's not going to work for various reasons.

    I realize this is "not a supported platform" - but the tools run 100% fine for me, and have for years.  It's only when some misguided attempt installer makes insatllation impossible that customers can't install a product.

    If it just prompted for confirmation, I could check a box.  By making it a black-box operation where I cannot override it, the product is completely unavailable.  And the platforms become severely limited.

    If you have any ideas for a workaround, please suggest.  Thanks!

    /Bill

    For those who follow in my footsteps, I found  a workaround, but a far more serious issue arises right afterward.  Needing to install RFT 8.5 today.  Get around the brain-dead installer in this way: find your real libraries, and create links to files where this tool looks for them.

    sudo  ln -s /usr/lib/i386-linux-gnu/libstdc++.so.5 /usr/lib

    sudo ln -s /usr/lib/i386-linux-gnu/libXp.so.6 /usr/lib

    You must use 32-bit libraries; as RFT itself is not 64-bit.

    I was fortunate in that IM does not run 'rpm' to check, it simply looks for the files on disk.  A trace of the process showed this, and creation of a dummy /usr/bin/rpm was never executed....

    The next step, specifying a shared resources directory, throws no errors.  But the very next step, specifying a package group, states that RFT can't be installed into a "64-bit package group". This is patent nonsense, as it's just a directory - and since I cleaned off old versions and specified two new, empty directories, the error can only mean that this installer refuses to install RFT on /any/ 64-bit Linux.

    As I have many 32-bit software packages running happily, I'm at a loss to explain, and I have no choice but to give up and walk away. This is a truly serious limitation, if true - I'm more inclined to believe that the installer is just very poor...... but I have no evidence one way or the other.

    If anyone finds a solution to this, please add to this thread - I believe I'll be notified (I hope!).