Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
4 replies Latest Post - ‏2013-03-20T09:54:51Z by Jeroen Weeda
SystemAdmin
SystemAdmin
172 Posts
ACCEPTED ANSWER

Pinned topic Error with Charts and ITM

‏2012-03-27T21:39:24Z |
Hi,
I am Trying to create a IBM chart on a TBSM pages. I've enabled TIP Web Service for Tivoli Integrated Portal charts and I've configured a conection with the ITM server and I specify in this conection the port 15200 and the service name TIPWebServiceHttpRouter. I can acces to select one group but when i select a graphic type and press finish, it show me the next error message:

CTGTD1000E
An error occurred while processing the request to the server.
Detail: NullPointerException

Please, someone help me with this error...

Thanks-
Updated on 2013-03-20T09:54:51Z at 2013-03-20T09:54:51Z by Jeroen Weeda
  • DarrenDunne
    DarrenDunne
    3 Posts
    ACCEPTED ANSWER

    Re: Error with Charts and ITM

    ‏2012-04-11T12:05:14Z  in response to SystemAdmin
    Hi Gloria -

    We are seeing a similar error and are currently working on identifying the source of the problem with Support.

    I will post a follow up when we determine the solution.

    Thanks,
    Darren Dunne
    • SystemAdmin
      SystemAdmin
      172 Posts
      ACCEPTED ANSWER

      Re: Error with Charts and ITM

      ‏2013-02-11T06:17:31Z  in response to DarrenDunne
      Hi Darren,

      I am getting the same error.

      Could you please tell me what was the steps for resolution.

      Regards,
      Avi
  • blainemeyer@us.ibm.com
    2 Posts
    ACCEPTED ANSWER

    Re: Error with Charts and ITM

    ‏2012-04-11T14:04:04Z  in response to SystemAdmin
    There a potenial fix for this problem. Please follow these step asn see if the problem is fixed.

    1. On the TBSM dashboard server run the following command :

    tipcli.bat ITMLogin --hostname <your itm fully qualified host name or ip address> --port 15200

    or

    ./tipcli.sh ITMLogin --hostname <your itm fully qualified host name or ip address> --port 15200

    this command can be foud in <tbsm_install_dir>\tipv2\profiles\TIPProfile\bin or <tbsm_install_dir>/tipv2/profiles/TIPProfile/bin

    2. Restart the TBSM Dashboard.

    This fix assume that the "TIP Web Service for Tivoli Integrated Portal charts" has been enabled on your ITM TEPS server. See the ITM admin guide for more details.
    • Jeroen Weeda
      Jeroen Weeda
      2 Posts
      ACCEPTED ANSWER

      Re: Error with Charts and ITM

      ‏2013-03-20T09:54:51Z  in response to blainemeyer@us.ibm.com
      hi,

      I tried this workaround but still the exact same error as before (CTGTD1000E, An error occurred while processing the request to the server. Detail: IndexOutOfBoundsException Index: 0, Size: 0)

      root@NLASD-TIP1 bin# ./tipcli.sh ITMLogin --hostname 10.213.230.6 --port 15200
      Writing file: /opt/IBM/tivoli/tipv2Components/BIRTExtension/integration/properties/itm.properties

      After which I stopped/started TIP.

      Any other suggestions anyone?