Topic
10 replies Latest Post - ‏2012-08-06T17:51:28Z by NoelIzquierdo
Sammy1984
Sammy1984
46 Posts
ACCEPTED ANSWER

Pinned topic Users in Object server comes back after deleting

‏2012-03-27T20:15:03Z |
Hello Everyone,

I am facing weird situation in Netcool Omnibus 7.3.1 FP1 on RHEL 5.5 64-bit operating system.

Issue is, when ever I delete any user from the object server, it comes back after some time. It automatically creates duplicate tipadmin user in object server, and because of this very reason I am unable to login to ITNM web console as tipadmin user, as tipadmin user already exists in defaultWIMfilebasedrepository. So everytime I have delete tipadmin user from the object server and then login as tipadmin user.

It is not just tipadmin user I am facing problem with, but also there are some users which comes back automatically after deleting.

Any suggestions or help to fix this issue is really appreciated.
Thank you.
Updated on 2012-08-06T17:51:28Z at 2012-08-06T17:51:28Z by NoelIzquierdo
  • Sammy1984
    Sammy1984
    46 Posts
    ACCEPTED ANSWER

    Re: Users in Object server comes back after deleting

    ‏2012-03-29T05:01:33Z  in response to Sammy1984
    Please help me out in fixing this issue...

    Awaiting reply from all Netcool experts..
    Thank you.
    • SystemAdmin
      SystemAdmin
      1283 Posts
      ACCEPTED ANSWER

      Re: Users in Object server comes back after deleting

      ‏2012-04-10T16:19:16Z  in response to Sammy1984
      Hi,
      I am not sure your issue resolved yet, but though I will throw some hints to find the issue.

      Make sure you are making the change in the primary Objectserver and it is in proper sync with the backup objectserver.

      Maybe the backup objectsever causing the issue or the synchronization between them.

      Thanks,
      Raji.
      • Sammy1984
        Sammy1984
        46 Posts
        ACCEPTED ANSWER

        Re: Users in Object server comes back after deleting

        ‏2012-04-11T04:23:16Z  in response to SystemAdmin
        Hi Raji,

        Thank you for your response.

        We don't have secondary object server running in our environment. There is only one object server (Primary) in our environment which fetches events from mttrapd, ITNM, ITM, and TNPM.

        Please advice.

        Thank you.
        • Sammy1984
          Sammy1984
          46 Posts
          ACCEPTED ANSWER

          Re: Users in Object server comes back after deleting

          ‏2012-04-16T07:00:58Z  in response to Sammy1984
          Is there any Netcool expert who can help me in resolving this issue???
          • SystemAdmin
            SystemAdmin
            1283 Posts
            ACCEPTED ANSWER

            Re: Users in Object server comes back after deleting

            ‏2012-04-16T10:38:55Z  in response to Sammy1984
            It may help people formulate a response if you include details on what method you are using to "delete" the users.
            • Sammy1984
              Sammy1984
              46 Posts
              ACCEPTED ANSWER

              Re: Users in Object server comes back after deleting

              ‏2012-04-16T13:34:05Z  in response to SystemAdmin
              Hello Mr. Donald Wildman,

              I am trying to delete user by login into TIP console => Users and Groups => Manage Users => Check the required user => click on "Delete" button.

              Also I am trying to delete user by login into Omnibus administration console => Users => Right click on the required user => Select "Delete" option.

              In either case deleted user comes back after some time. There is only one object server running in the entire environment. We did not configure back-up or failover object server.

              Please advice.

              Thank you.
              • SystemAdmin
                SystemAdmin
                1283 Posts
                ACCEPTED ANSWER

                Re: Users in Object server comes back after deleting

                ‏2012-04-17T10:10:03Z  in response to Sammy1984
                Hi

                I would suggest running the ObjectServer at messagelevel debug (this can be set in the nco_config tool, in the properties dialog without having to restart the ObjectServer).

                This will capture the SQL being sent to the ObjectServer in the messagelog. It should then be a simple case for you to review the log file for the CREATE USER commands that are creating users that you have previously removed. The log file will show which client is issuing the commands which should help you determine the root cause of your reappearing users.

                An example of the typical log file entry you should be looking for is given below.
                
                2012-04-17T11:08:33: Debug: D-OBX-105-010: Client language command on connection ID 1: [root][isql][][testbox22] [create user 
                'JohnSmith' full name 
                'John Smith';
                


                You can see in this case that root created the user JohnSmith from an isql session running on testbox22.
                Regards

                Steve
  • EngBernie
    EngBernie
    7 Posts
    ACCEPTED ANSWER

    Re: Users in Object server comes back after deleting

    ‏2012-07-11T07:47:11Z  in response to Sammy1984
    Look for server.init in your WebGUI installation directory (it should be installed as part of ITNM). Look for the property 'users.credentials.sync.groupname'. Note the group name (by default it should be 'vmmusers'). Users that belongs to this group will be synced to the object server. If you want to prevent tipadmin from being synced over, remove tipadmin from the group.
    • neil.billett
      neil.billett
      51 Posts
      ACCEPTED ANSWER

      Re: Users in Object server comes back after deleting

      ‏2012-07-17T13:00:31Z  in response to EngBernie
      Hi,

      I've also seen a similar issue occur in two situations:

      a) When two or more TIP servers have been set-up to use the same ObjectServer as a user repository - which is probably not an ideal set-up. The user syncing can then get very confused. Can you verify that no other TIP servers are connecting to your ObjectServer (and maybe resyncing deleted users back into that ObjectServer)?

      b) A second Tivoli product has been incorrectly installed into the existing TIP WebGUI set-up which has added another tipadmin user into TIP and hence into the ObjectServer.

      Can you talk us through your wider system as a whole?

      thanks,

      Neil
  • NoelIzquierdo
    NoelIzquierdo
    4 Posts
    ACCEPTED ANSWER

    Re: Users in Object server comes back after deleting

    ‏2012-08-06T17:51:28Z  in response to Sammy1984
    Sammy1984, Not sure if you resolved the issue but it is a simple one to address. I would suspect that you have granted ncw_user or ncw_admin to the tipadmin user and that you are also using the ObjectServer to atuhtenticate users. VMM_sync by default queries for users with ncw_user and ncw_admin it then syncs these user with the ObjectServer. When using a Federated repository in WebSphere the user has to be Unique (.i.e exist in one and only repository (LDAP, OS or File-based)). Anyway as a Best Practice the Tipadmin user should only be used to adminster TIP and WebSphere and not be used to manage Events.