Topic
  • 3 replies
  • Latest Post - ‏2014-04-17T18:18:18Z by mtexter
mmaliakas
mmaliakas
11 Posts

Pinned topic DS4700 Clean Disk DACStore

‏2012-03-26T08:33:36Z |
hello

we have 2 DS4700 Storages. The first has 06.xx.xx firmware and the second one 07.xx.xx
we have a need to use disks from the second storage to the first but we run into the incompatible disk error due to different DACStore format when we do the swap.

firmware upgrade on the fist storage is not currently an option.

i have read about some procedure but it doesn't work

1) unplug all drives
2) connect to the serial or via rlogin to one controller (doesn't matter
which one)
3) insert a drive
-> you get an output like this:
04/01/08-11:13:27 (GMT) (ssmDriveSpinTask): NOTE:
cfgCommonReplaceCode: dev = 0x400002
04/01/08-11:13:29 (GMT) (ssmDriveSpinTask): WARN: Unsupported
dacstore: dev = 0x400002
(ssmDriveSpinTask): NOTE: cfgCommonReplaceCode: complete dev =
0x400002
4) note down the devnum (0x400002 in this case)
5) rewrite the dacstore area: isp cfgWipe1,<devnum>
(isp cfgWipe1,0x400002 for this example)
6) repeat steps 3 to 5 for all drives
7) if done, reboot both controllers and you will see all drives

the isp cfgWipe command doesnt work
it doesn't accept the cfgWipe parameter. i try this with telnet connection
thanks in advanced
Updated on 2012-03-27T21:44:47Z at 2012-03-27T21:44:47Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    4779 Posts

    Re: DS4700 Clean Disk DACStore

    ‏2012-03-27T21:44:47Z  
    Plug the drive into the second storage then try running the command there
    To see if it is a version problem
  • mtexter
    mtexter
    12 Posts

    Re: DS4700 Clean Disk DACStore

    ‏2014-04-17T17:53:29Z  

    Yeah i think the cfgWipe command is only on the 6.X firmware, i believe it's not available in 7.X.  If i'm flip-flopping those, i apologize.

  • mtexter
    mtexter
    12 Posts

    Re: DS4700 Clean Disk DACStore

    ‏2014-04-17T18:18:18Z  

    Yeah i think the cfgWipe command is only on the 6.X firmware, i believe it's not available in 7.X.  If i'm flip-flopping those, i apologize.