Topic
  • 6 replies
  • Latest Post - ‏2015-03-10T12:35:00Z by dikkini
CodyBurleson
CodyBurleson
4 Posts

Pinned topic Error attempting OpenID config with enable-identityprovider-tai task

‏2012-03-25T20:56:16Z |
In attempting to configure OpenID against Google as an identity provider, I entered the following ConfigEngine command and received an error, which doesn't give much of a clue as to why it's failing.

Following is the directory from which I executed the command on a Windows 7 machine:

C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine>

Following is the command I entered:

ConfigEngine.bat enable-identityprovider-tai -DWasUserId=username -DWasPassword=password -Dopenid.servicenames Google -Dopenid.servicenames.endpoints https://www.google.com/accounts/o8/id -Dprovider.openid.nonce_valid_time 10 -Didp.providerlist openid

Following is the result:

Licensed Materials - Property of IBM
5724-E76, 5724-E77, 5724-I29, 5655-W49
(C) Copyright IBM Corp. All Rights Reserved.

Running Configuration Engine task '-profileName'
Current profile: cw_profile
DB2 instance is:
DB2ADMIN
propertiesPath is ConfigEngine_temp.prop
rootDir is C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine
Systems architecture is: amd64
Executing native2ascii with native encoding 'Cp1252': ConfigEngine_temp.prop_ -> ConfigEngine_temp_ascii.prop_
Native2ascii execution was successful!
ConfigEngine: setting system property JAVA_HOME=C:/IBM/WebSphere/AppServer/java
ConfigEngine: setting system property local.cell=mojoNode01Cell
ConfigEngine: setting system property was.root=C:/IBM/WebSphere/AppServer
ConfigEngine: setting system property NodeName=mojoNode01
ConfigEngine: setting system property local.node=mojoNode01
ConfigEngine: setting system property ws.ext.dirs=C:/IBM/WebSphere/AppServer/java/lib;C:/IBM/WebSphere/AppServer/classes;C:/IBM/WebSphere/AppServer/lib;C:/IBM/WebSphere/AppServer/installedChannels;C:/
IBM/WebSphere/AppServer/lib/ext;C:/IBM/WebSphere/AppServer/web/help;C:/IBM/WebSphere/AppServer/deploytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime;C:/Program Files (x86)/IBM/WebSphere/ConfigEngine
/lib;C:/Program Files (x86)/IBM/WebSphere/ConfigEngine/shared/app
ConfigEngine: setting system property was.install.root=C:/IBM/WebSphere/AppServer
ConfigEngine: setting system property jvmArgFor64bit=-D64bit.args=none
ConfigEngine: setting system property cfg.trace=C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine/log/ConfigTrace.log
ConfigEngine: setting system property was.user.root=C:/IBM/WebSphere/AppServer/profiles/cw_profile
ConfigEngine: setting system property CellName=mojoNode01Cell
ConfigEngine: setting system property was.repository.root=C:/IBM/WebSphere/AppServer/profiles/cw_profile/config
ConfigEngine: setting system property server.root=C:/IBM/WebSphere/AppServer
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:611)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:269)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:611)
at com.ibm.wps.config.launch.ConfigEngineLauncher.process(ConfigEngineLauncher.java:324)
at com.ibm.wps.config.launch.ConfigEngineLauncher.main(ConfigEngineLauncher.java:366)
Caused by: java.lang.NullPointerException
at com.ibm.wps.config.ConfigEngine.process(ConfigEngine.java:314)
at com.ibm.wps.config.ConfigEngine.main(ConfigEngine.java:217)
... 11 more
Return Value: 0

C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine>

Attached is the ConfigEngine trace file referenced by that output.

A more detailed journal of my notes on this experiment can be found here:

http://www.codyburleson.com/ibm-customer-experience-suite-guide/supporting-google-yahoo-facebook-and-other-openid-logins/

If anybody knows what I might be doing wrong or what I might try differently, I would appreciate feedback.
Updated on 2012-10-14T16:53:19Z at 2012-10-14T16:53:19Z by JohnDelRosario
  • Stefan_Schmitt
    Stefan_Schmitt
    1 Post

    Re: Error attempting OpenID config with enable-identityprovider-tai task

    ‏2012-03-26T08:29:13Z  
    Hey Cody

    If this is the command you use you have used the Java cmd line options in a wrong way.

    ConfigEngine.bat enable-identityprovider-tai -DWasUserId=username -DWasPassword=password -Dopenid.servicenames Google -Dopenid.servicenames.endpoints https://www.google.com/accounts/o8/id -Dprovider.openid.nonce_valid_time 10 -Didp.providerlist openid

    Each of the -D properties gets its values with an '=' sign so the correct syntax would be

    ConfigEngine.bat enable-identityprovider-tai -DWasUserId=username -DWasPassword=password -Dopenid.servicenames=Google -Dopenid.servicenames.endpoints=https://www.google.com/accounts/o8/id -Dprovider.openid.nonce_valid_time=10 -Didp.providerlist=openid
  • CodyBurleson
    CodyBurleson
    4 Posts

    Re: Error attempting OpenID config with enable-identityprovider-tai task

    ‏2012-03-26T13:27:55Z  
    Hey Cody

    If this is the command you use you have used the Java cmd line options in a wrong way.

    ConfigEngine.bat enable-identityprovider-tai -DWasUserId=username -DWasPassword=password -Dopenid.servicenames Google -Dopenid.servicenames.endpoints https://www.google.com/accounts/o8/id -Dprovider.openid.nonce_valid_time 10 -Didp.providerlist openid

    Each of the -D properties gets its values with an '=' sign so the correct syntax would be

    ConfigEngine.bat enable-identityprovider-tai -DWasUserId=username -DWasPassword=password -Dopenid.servicenames=Google -Dopenid.servicenames.endpoints=https://www.google.com/accounts/o8/id -Dprovider.openid.nonce_valid_time=10 -Didp.providerlist=openid
    Thanks, Stefan. I feel kind of silly for not having thought of it. Indeed the equal signs were necessary between the -DParam and its value.

    Now, however, I am getting a BUILD FAILED, stating that the "Target `enable-identityprovider-tai' does not exist in this project."

    I get the same result when entering any sort of personally invented "garbage" command that should not be recognized by the ConfigEngine..

    Following is the command line result. Please let me know if you have any ideas about how I might be failing now. By the way, what does the new "cw" in "cw_profile" (versus "wp_profile") stand for?
    MY PATH:

    C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine>

    MY COMMAND:

    ConfigEngine.bat enable-identityprovider-tai -DWasUserId=username -DWasPassword=password -
    Dopenid.servicenames=Google -Dopenid.servicenames.endpoints=https://www.google.com/accounts/o8/id -Dprovider.openid.nonce_valid_time=10 -Didp.provider
    list=openid

    Licensed Materials - Property of IBM
    5724-E76, 5724-E77, 5724-I29, 5655-W49
    (C) Copyright IBM Corp. All Rights Reserved.

    Running Configuration Engine task '-profileName'
    Current profile: cw_profile
    DB2 instance is:
    DB2ADMIN
    propertiesPath is ConfigEngine_temp.prop
    rootDir is C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine
    Systems architecture is: amd64
    Executing native2ascii with native encoding 'Cp1252': ConfigEngine_temp.prop_ -> ConfigEngine_temp_ascii.prop_
    Native2ascii execution was successful!
    ConfigEngine: setting system property JAVA_HOME=C:/IBM/WebSphere/AppServer/java
    ConfigEngine: setting system property local.cell=mojoNode01Cell
    ConfigEngine: setting system property was.root=C:/IBM/WebSphere/AppServer
    ConfigEngine: setting system property NodeName=mojoNode01
    ConfigEngine: setting system property local.node=mojoNode01
    ConfigEngine: setting system property ws.ext.dirs=C:/IBM/WebSphere/AppServer/java/lib;C:/IBM/WebSphere/AppServer/classes;C:/IBM/WebSphere/AppServer/li
    b;C:/IBM/WebSphere/AppServer/installedChannels;C:/IBM/WebSphere/AppServer/lib/ext;C:/IBM/WebSphere/AppServer/web/help;C:/IBM/WebSphere/AppServer/deplo
    ytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime;C:/Program Files (x86)/IBM/WebSphere/ConfigEngine/lib;C:/Program Files (x86)/IBM/WebSphere/ConfigEn
    gine/shared/app
    ConfigEngine: setting system property was.install.root=C:/IBM/WebSphere/AppServer
    ConfigEngine: setting system property jvmArgFor64bit=-D64bit.args=none
    ConfigEngine: setting system property cfg.trace=C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine/log/ConfigTrace.log
    ConfigEngine: setting system property was.user.root=C:/IBM/WebSphere/AppServer/profiles/cw_profile
    ConfigEngine: setting system property CellName=mojoNode01Cell
    ConfigEngine: setting system property was.repository.root=C:/IBM/WebSphere/AppServer/profiles/cw_profile/config
    ConfigEngine: setting system property server.root=C:/IBM/WebSphere/AppServer
    ConfigEngine instance home variable found and successfully replaced
    loaded registry from WAS: C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine/registry.xml
    Buildfile: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\base_dynamic.xml
    Trying to override old definition of task property
    Trying to override old definition of task java
    Trying to override old definition of task exec

    cleanup-work-dir:
    Mon Mar 26 08:22:55 CDT 2012
    echo Cleaning up...
    echo Done.

    action-set-time-property:
    Mon Mar 26 08:22:55 CDT 2012

    action-init-zos:
    Mon Mar 26 08:22:55 CDT 2012
    echo Setting property isZos to ${isZos}
    echo Setting property jvmArgForZos to -Dzos.argsconversion=none

    action-set-managed-node-flag:
    Mon Mar 26 08:22:55 CDT 2012
    echo Is this a Managed Node ? false

    action-set-conntype-property:
    Mon Mar 26 08:22:55 CDT 2012
    echo wsadminConnType set to: NONE

    init-cfg-files:
    Mon Mar 26 08:22:55 CDT 2012
    mkdir Created dir: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    copy Copying 28 files to C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    copy Copying 5 files to C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    copy Copying 7 files to C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    copy Copying 2 files to C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\was

    set-wsadmin-scripting-classpath-in-jacl-properties-1:
    Mon Mar 26 08:22:55 CDT 2012
    echo C:\IBM\WebSphere\AppServer\profiles\cw_profile
    echo wsadmin.properties com.ibm.ws.scripting.classpath: '${com.ibm.ws.scripting.classpath}'
    echo com.ibm.ws.scripting.classpath.initial: 'C:/Program Files (x86)/IBM/WebSphere/ConfigEngine/lib/wkplc.misc.jar;C:/IBM/
    WebSphere/AppServer/deploytool/itp/batchboot.jar;C:/IBM/WebSphere/AppServer/deploytool/itp/batch2.jar;${Wp.baseHome}/shared/app/wp.base.jar;c:/IBM/Web
    Sphere/Portal/shared/app/wp.base.jar'

    set-wsadmin-scripting-classpath-in-jacl-properties-2:
    Mon Mar 26 08:22:55 CDT 2012
    echo jacl.properties com.ibm.ws.scripting.classpath: 'C:/Program Files (x86)/IBM/WebSphere/ConfigEngine/lib/wkplc.misc.jar;C:/IBM/
    WebSphere/AppServer/deploytool/itp/batchboot.jar;C:/IBM/WebSphere/AppServer/deploytool/itp/batch2.jar;${Wp.baseHome}/shared/app/wp.base.jar;c:/IBM/Web
    Sphere/Portal/shared/app/wp.base.jar'

    set-wsadmin-scripting-classpath-in-jacl-properties:
    Mon Mar 26 08:22:55 CDT 2012

    action-init-cfg-files-zos:
    Mon Mar 26 08:22:56 CDT 2012

    setup-additional-init-files:
    Mon Mar 26 08:22:56 CDT 2012

    init:
    Mon Mar 26 08:22:56 CDT 2012
    echo 2012-03-26-08-22
    property_cleanup File: C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine/properties/wkplc_dbdomain.properties does not exists and will not
    be processed
    property_cleanup File: C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine/properties/wkplc_sourceDb.properties does not exists and will not
    be processed
    Trying to override old definition of task wplc-modify-server
    Trying to override old definition of task wplc-create-server
    Trying to override old definition of task wplc-remove-server

    set-properties:
    Mon Mar 26 08:22:56 CDT 2012
    setproperty Property PortalAdminId was set to wpsadmin
    setproperty Property PortalAdminGroupId was set to wpsadmins
    setproperty Property WpsDocReviewer was set to ${WpsDocReviewer}
    setproperty Property WpsContentAdministrators was set to ${WpsContentAdministrators}
    setproperty Property UserSuffix was set to ${LDAPUserSuffix},${LDAPSuffix}
    setproperty Property GroupSuffix was set to ${LDAPGroupSuffix},${LDAPSuffix}

    start-wsadmin-listener:
    Mon Mar 26 08:22:56 CDT 2012

    action-pre-config:
    Mon Mar 26 08:22:56 CDT 2012
    echo executing pre-configuration tasks
    isWas7 overwriting previous definition of property: null
    isWas7 +++value of property is 8.0.0.2

    action-set-config:
    Mon Mar 26 08:22:56 CDT 2012
    echo executing set-configuration tasks
    echo contains@empty_string@

    BUILD FAILED
    Target `enable-identityprovider-tai' does not exist in this project.

    Total time: 2 seconds

    stop-wsadmin-listener:
    Mon Mar 26 08:22:56 CDT 2012

    delete-temp-dirs:
    Mon Mar 26 08:22:56 CDT 2012
    delete Deleting: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work\was\wp_portal.properties
    delete Deleting: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\properties\wkplc_comp_ascii.properties
    delete Deleting: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\properties\wkplc_ascii.properties
    delete Deleting 2 files from C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\properties

    cleanup-work-dir:
    Mon Mar 26 08:22:56 CDT 2012
    echo Cleaning up...
    delete Deleting directory C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    echo Done.

    cleanup-config:
    Mon Mar 26 08:22:56 CDT 2012
    echo executing post-configuration tasks
    BUILD FAILED
    isIseries currently set to: null

    update-registry-sync-property:
    Mon Mar 26 08:22:56 CDT 2012
    echo updated RegistrySynchronized in file wkplc.properties with value: true
    Return Value: 1

    C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine>
  • Rohit_Khanna
    Rohit_Khanna
    1 Post

    Re: Error attempting OpenID config with enable-identityprovider-tai task

    ‏2012-07-11T11:06:28Z  
    Thanks, Stefan. I feel kind of silly for not having thought of it. Indeed the equal signs were necessary between the -DParam and its value.

    Now, however, I am getting a BUILD FAILED, stating that the "Target `enable-identityprovider-tai' does not exist in this project."

    I get the same result when entering any sort of personally invented "garbage" command that should not be recognized by the ConfigEngine..

    Following is the command line result. Please let me know if you have any ideas about how I might be failing now. By the way, what does the new "cw" in "cw_profile" (versus "wp_profile") stand for?
    MY PATH:

    C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine>

    MY COMMAND:

    ConfigEngine.bat enable-identityprovider-tai -DWasUserId=username -DWasPassword=password -
    Dopenid.servicenames=Google -Dopenid.servicenames.endpoints=https://www.google.com/accounts/o8/id -Dprovider.openid.nonce_valid_time=10 -Didp.provider
    list=openid

    Licensed Materials - Property of IBM
    5724-E76, 5724-E77, 5724-I29, 5655-W49
    (C) Copyright IBM Corp. All Rights Reserved.

    Running Configuration Engine task '-profileName'
    Current profile: cw_profile
    DB2 instance is:
    DB2ADMIN
    propertiesPath is ConfigEngine_temp.prop
    rootDir is C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine
    Systems architecture is: amd64
    Executing native2ascii with native encoding 'Cp1252': ConfigEngine_temp.prop_ -> ConfigEngine_temp_ascii.prop_
    Native2ascii execution was successful!
    ConfigEngine: setting system property JAVA_HOME=C:/IBM/WebSphere/AppServer/java
    ConfigEngine: setting system property local.cell=mojoNode01Cell
    ConfigEngine: setting system property was.root=C:/IBM/WebSphere/AppServer
    ConfigEngine: setting system property NodeName=mojoNode01
    ConfigEngine: setting system property local.node=mojoNode01
    ConfigEngine: setting system property ws.ext.dirs=C:/IBM/WebSphere/AppServer/java/lib;C:/IBM/WebSphere/AppServer/classes;C:/IBM/WebSphere/AppServer/li
    b;C:/IBM/WebSphere/AppServer/installedChannels;C:/IBM/WebSphere/AppServer/lib/ext;C:/IBM/WebSphere/AppServer/web/help;C:/IBM/WebSphere/AppServer/deplo
    ytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime;C:/Program Files (x86)/IBM/WebSphere/ConfigEngine/lib;C:/Program Files (x86)/IBM/WebSphere/ConfigEn
    gine/shared/app
    ConfigEngine: setting system property was.install.root=C:/IBM/WebSphere/AppServer
    ConfigEngine: setting system property jvmArgFor64bit=-D64bit.args=none
    ConfigEngine: setting system property cfg.trace=C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine/log/ConfigTrace.log
    ConfigEngine: setting system property was.user.root=C:/IBM/WebSphere/AppServer/profiles/cw_profile
    ConfigEngine: setting system property CellName=mojoNode01Cell
    ConfigEngine: setting system property was.repository.root=C:/IBM/WebSphere/AppServer/profiles/cw_profile/config
    ConfigEngine: setting system property server.root=C:/IBM/WebSphere/AppServer
    ConfigEngine instance home variable found and successfully replaced
    loaded registry from WAS: C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine/registry.xml
    Buildfile: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\base_dynamic.xml
    Trying to override old definition of task property
    Trying to override old definition of task java
    Trying to override old definition of task exec

    cleanup-work-dir:
    Mon Mar 26 08:22:55 CDT 2012
    echo Cleaning up...
    echo Done.

    action-set-time-property:
    Mon Mar 26 08:22:55 CDT 2012

    action-init-zos:
    Mon Mar 26 08:22:55 CDT 2012
    echo Setting property isZos to ${isZos}
    echo Setting property jvmArgForZos to -Dzos.argsconversion=none

    action-set-managed-node-flag:
    Mon Mar 26 08:22:55 CDT 2012
    echo Is this a Managed Node ? false

    action-set-conntype-property:
    Mon Mar 26 08:22:55 CDT 2012
    echo wsadminConnType set to: NONE

    init-cfg-files:
    Mon Mar 26 08:22:55 CDT 2012
    mkdir Created dir: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    copy Copying 28 files to C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    copy Copying 5 files to C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    copy Copying 7 files to C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    copy Copying 2 files to C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\was

    set-wsadmin-scripting-classpath-in-jacl-properties-1:
    Mon Mar 26 08:22:55 CDT 2012
    echo C:\IBM\WebSphere\AppServer\profiles\cw_profile
    echo wsadmin.properties com.ibm.ws.scripting.classpath: '${com.ibm.ws.scripting.classpath}'
    echo com.ibm.ws.scripting.classpath.initial: 'C:/Program Files (x86)/IBM/WebSphere/ConfigEngine/lib/wkplc.misc.jar;C:/IBM/
    WebSphere/AppServer/deploytool/itp/batchboot.jar;C:/IBM/WebSphere/AppServer/deploytool/itp/batch2.jar;${Wp.baseHome}/shared/app/wp.base.jar;c:/IBM/Web
    Sphere/Portal/shared/app/wp.base.jar'

    set-wsadmin-scripting-classpath-in-jacl-properties-2:
    Mon Mar 26 08:22:55 CDT 2012
    echo jacl.properties com.ibm.ws.scripting.classpath: 'C:/Program Files (x86)/IBM/WebSphere/ConfigEngine/lib/wkplc.misc.jar;C:/IBM/
    WebSphere/AppServer/deploytool/itp/batchboot.jar;C:/IBM/WebSphere/AppServer/deploytool/itp/batch2.jar;${Wp.baseHome}/shared/app/wp.base.jar;c:/IBM/Web
    Sphere/Portal/shared/app/wp.base.jar'

    set-wsadmin-scripting-classpath-in-jacl-properties:
    Mon Mar 26 08:22:55 CDT 2012

    action-init-cfg-files-zos:
    Mon Mar 26 08:22:56 CDT 2012

    setup-additional-init-files:
    Mon Mar 26 08:22:56 CDT 2012

    init:
    Mon Mar 26 08:22:56 CDT 2012
    echo 2012-03-26-08-22
    property_cleanup File: C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine/properties/wkplc_dbdomain.properties does not exists and will not
    be processed
    property_cleanup File: C:/IBM/WebSphere/AppServer/profiles/cw_profile/ConfigEngine/properties/wkplc_sourceDb.properties does not exists and will not
    be processed
    Trying to override old definition of task wplc-modify-server
    Trying to override old definition of task wplc-create-server
    Trying to override old definition of task wplc-remove-server

    set-properties:
    Mon Mar 26 08:22:56 CDT 2012
    setproperty Property PortalAdminId was set to wpsadmin
    setproperty Property PortalAdminGroupId was set to wpsadmins
    setproperty Property WpsDocReviewer was set to ${WpsDocReviewer}
    setproperty Property WpsContentAdministrators was set to ${WpsContentAdministrators}
    setproperty Property UserSuffix was set to ${LDAPUserSuffix},${LDAPSuffix}
    setproperty Property GroupSuffix was set to ${LDAPGroupSuffix},${LDAPSuffix}

    start-wsadmin-listener:
    Mon Mar 26 08:22:56 CDT 2012

    action-pre-config:
    Mon Mar 26 08:22:56 CDT 2012
    echo executing pre-configuration tasks
    isWas7 overwriting previous definition of property: null
    isWas7 +++value of property is 8.0.0.2

    action-set-config:
    Mon Mar 26 08:22:56 CDT 2012
    echo executing set-configuration tasks
    echo contains@empty_string@

    BUILD FAILED
    Target `enable-identityprovider-tai' does not exist in this project.

    Total time: 2 seconds

    stop-wsadmin-listener:
    Mon Mar 26 08:22:56 CDT 2012

    delete-temp-dirs:
    Mon Mar 26 08:22:56 CDT 2012
    delete Deleting: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work\was\wp_portal.properties
    delete Deleting: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\properties\wkplc_comp_ascii.properties
    delete Deleting: C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\properties\wkplc_ascii.properties
    delete Deleting 2 files from C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\properties

    cleanup-work-dir:
    Mon Mar 26 08:22:56 CDT 2012
    echo Cleaning up...
    delete Deleting directory C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine\config\work
    echo Done.

    cleanup-config:
    Mon Mar 26 08:22:56 CDT 2012
    echo executing post-configuration tasks
    BUILD FAILED
    isIseries currently set to: null

    update-registry-sync-property:
    Mon Mar 26 08:22:56 CDT 2012
    echo updated RegistrySynchronized in file wkplc.properties with value: true
    Return Value: 1

    C:\IBM\WebSphere\AppServer\profiles\cw_profile\ConfigEngine>
    Hi , I am also facing the below issue.

    Target `enable-identityprovider-tai' does not exist in this project.

    Please update how you have resolved this issue.
    Thanks in Advance
  • JohnDelRosario
    JohnDelRosario
    4 Posts

    Re: Error attempting OpenID config with enable-identityprovider-tai task

    ‏2012-10-14T16:52:33Z  
    Hi I would just like to up this thread. Have there been any solutions to this? Thanks.
  • JohnDelRosario
    JohnDelRosario
    4 Posts

    Re: Error attempting OpenID config with enable-identityprovider-tai task

    ‏2012-10-14T16:53:19Z  
    Hi I would just like to up this thread. Any solutions to this? Thanks.
  • dikkini
    dikkini
    1 Post

    Re: Error attempting OpenID config with enable-identityprovider-tai task

    ‏2015-03-10T12:35:00Z  

    OpenID supported start from IBM WSP 8+