Topic
  • 3 replies
  • Latest Post - ‏2012-03-20T21:12:42Z by SystemAdmin
P51
P51
2 Posts

Pinned topic Can't install the Explorer SDK and JAVA SDK

‏2012-03-20T17:22:57Z |
I just downloaded and installed the CICS Explorer, Version: 1.1.0.1.

I'm attempting to install the CICS Explorer SDK and the CICS SDK for JAVA, following instructions in the CICS TS 4.2 Java Applications in CICS manual.

I'm getting the following error:

Cannot complete the install because one or more required items could not be found.
Software being installed: IBM CICS SDK for Java 1.1.1.201201261838 (com.ibm.cics.java.feature.feature.group 1.1.1.201201261838)
Missing requirement: CICS Bundle OSGi Handler 1.1.1.201201261838 (com.ibm.cics.bundle.ui.osgi 1.1.1.201201261838) requires 'bundle org.eclipse.pde.ui 3.4.0' but it could not be found
Cannot satisfy dependency:
From: IBM CICS SDK for Java 1.1.1.201201261838 (com.ibm.cics.java.feature.feature.group 1.1.1.201201261838)
To: com.ibm.cics.bundle.ui.osgi http://1.1.1.201201261838

Any suggestions?

Regards,
Mark Wittie
Fidelity Investments
Updated on 2012-03-20T21:12:42Z at 2012-03-20T21:12:42Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    270 Posts

    Re: Can't install the Explorer SDK and JAVA SDK

    ‏2012-03-20T20:40:41Z  
    Hi there Mark,

    Thanks for downloading Explorer! I'm sorry you're having troubles installing it.

    Some of the code in our CICS SDK requires a part of Eclipse called 'PDE' (plugin development environment).

    This is provided with some builds of Eclipse (e.g. Eclipse Classic) but not with others (e.g. Eclipse for Java Developers). What are you trying to install CICS Explorer into?

    If you're installing into an Eclipse, you should find that there are some built-in update sites that you could enable which would allow Eclipse to automatically download the required dependencies.

    Thanks in advance,

    Dave
  • P51
    P51
    2 Posts

    Re: Can't install the Explorer SDK and JAVA SDK

    ‏2012-03-20T20:58:19Z  
    I'm new to this Explorer stuff. I simply downloaded CICS Explorer and installed it, then tried to install the SDK. I take it from your reply that I need to install some version of Eclipse first, then install CICS Explorer after that. What I'm trying to do is look at the sample Java CICS programs, and possibly modify those or write some new programs and run them in CICS. I need to do some testing of the JVM server in TS 4.2.

    Thanks for the reply.
  • SystemAdmin
    SystemAdmin
    270 Posts

    Re: Can't install the Explorer SDK and JAVA SDK

    ‏2012-03-20T21:12:42Z  
    • P51
    • ‏2012-03-20T20:58:19Z
    I'm new to this Explorer stuff. I simply downloaded CICS Explorer and installed it, then tried to install the SDK. I take it from your reply that I need to install some version of Eclipse first, then install CICS Explorer after that. What I'm trying to do is look at the sample Java CICS programs, and possibly modify those or write some new programs and run them in CICS. I need to do some testing of the JVM server in TS 4.2.

    Thanks for the reply.
    Ah OK - I understand. That is a bit confusing, sorry.

    We have two deliveries - they are meant to be used separately but it sounds to me like you're innovating in a way we didn't intend and are trying to combine them!!!

    1) The CICS Explorer - this is what you 'installed' first of all - it's a zip file containing a cicsexplorer.exe and will start up a CICS Explorer that you can use to connect to, and manage, CICS systems, z/OS systems and so on.

    2) The CICS Explorer SDK - this is a zip containing an update site (Eclipse terminology) which you can add into a pre-existing Eclipse installation. As well as giving you all of the function provided by the CICS Explorer main installable, it contains the code required to develop OSGi bundles to use within CICS (and is also what you need if you want to write a plugin to extend CICS Explorer's function, although from what you've said that's not what you're after!).

    So - to look at the sample Java CICS programs and try writing your own, you will need to download a copy of Eclipse Classic from http://eclipse.org. For 1.1.0.1, our primary supported version of Eclipse is 3.6.2 (http://download.eclipse.org/eclipse/downloads/drops/R-3.6.2-201102101200/index.php), but 3.7 should work. Once you've downloaded and unzipped Eclipse, install the SDK into it in the same way as you tried to install it into CICS Explorer before.

    I hope that helps - do get back in touch if you have any more questions.

    Dave