• 1 reply
  • Latest Post - ‏2012-04-06T14:58:43Z by DGawron
1 Post

Pinned topic Using WSDL based Web Service

‏2012-03-19T04:19:33Z |
In one of the models we are connecting to a wsdl based service. For that we are using Web Service Multiple Operation Builder. I have enabled testing support for the builder. But when I am testing by launching the model and try to invoke any methods I get the follwing error -

An error has occurred. The error message returned was: "Error in method sd_WSMultiOpServicesGetOrdersGotoOperation. Error in method sd_WSMultiOpServicesGetOrders_ShowResults. Error in method getOrdersExecute. Error in method getOrders.invoke. Error in method getOrders.invokeInternal. (404)Not Found".

I even tried the sample at the follwing link -
and even in it the provider model with the web service multiple operation builder does not run and gives the same error message wrt the methods exposed by it.
Is there anything else that needs to be done to run the model to test the output of the service.
Updated on 2012-04-06T14:58:43Z at 2012-04-06T14:58:43Z by DGawron
  • DGawron
    50 Posts

    Re: Using WSDL based Web Service

    That stack trace looks like a SOAPFaultException that is thrown when we get an AxisFault while trying to invoke the service's end-point. From the "404" message I'd say the end-point address in the WSDL is wrong or something in the network (firewall maybe) is preventing the request from reaching the end-point.