Topic
  • 3 replies
  • Latest Post - ‏2012-04-12T16:32:06Z by bodily
SystemAdmin
SystemAdmin
69 Posts

Pinned topic PowerHA restore during P6 to P7 migration

‏2012-03-15T13:24:30Z |
I'm trying to migrate standalone LPARS (no VIO) from P-6 to P-7 using mksysb restore. there are 3 nodes in the HA cluster and needs to be migrated one by one. whats the best way to restore the first node on P-7 with HACMP cluster operational. can we use snapshot restore? or I need to recreate that node in cluster?
Updated on 2012-04-12T16:32:06Z at 2012-04-12T16:32:06Z by bodily
  • bodily
    bodily
    33 Posts

    Re: PowerHA restore during P6 to P7 migration

    ‏2012-03-16T17:41:09Z  
    Well like most tech answers, it depends. If your new P7 really has the same IP addresses and sharedvg names, app scripts came back with restore, /etc/hosts is correct,clcomd, rhosts file is correct is running etc. Then if truly doing ONE at a time, simply try syncing to the new node from one of the other two nodes in the cluster. Then repeat one at a time.

    If roughly trying to do all three in a very close time frame then restoring the configuration from a snapshot should work just fine. Ideally, you shouldn't even have to do that, but historically mksysb restores have not been kind to PowerHA clusters. When you restore the snapshot, it will want to automatically push the config over to the other nodes in the cluster. So it may be one, if not the last things you would do.

    Hope this helps.
    Shawn
  • SystemAdmin
    SystemAdmin
    69 Posts

    Re: PowerHA restore during P6 to P7 migration

    ‏2012-04-12T09:27:18Z  
    • bodily
    • ‏2012-03-16T17:41:09Z
    Well like most tech answers, it depends. If your new P7 really has the same IP addresses and sharedvg names, app scripts came back with restore, /etc/hosts is correct,clcomd, rhosts file is correct is running etc. Then if truly doing ONE at a time, simply try syncing to the new node from one of the other two nodes in the cluster. Then repeat one at a time.

    If roughly trying to do all three in a very close time frame then restoring the configuration from a snapshot should work just fine. Ideally, you shouldn't even have to do that, but historically mksysb restores have not been kind to PowerHA clusters. When you restore the snapshot, it will want to automatically push the config over to the other nodes in the cluster. So it may be one, if not the last things you would do.

    Hope this helps.
    Shawn
    Thanks Shawn,

    We are plannning to move the lpars to P-7 with a couple of weeks difference. Hence after mksysb restoration all the IPs and VG's (importvg) will be same but the network interface numbers will be different like en3 may having service IP on P-6 and that interface will become en5 here then do i have to make the changes (specially network) in extended configuration before discovery and cluster synchronization??

    Regards,
    MMP
  • bodily
    bodily
    33 Posts

    Re: PowerHA restore during P6 to P7 migration

    ‏2012-04-12T16:32:06Z  
    Thanks Shawn,

    We are plannning to move the lpars to P-7 with a couple of weeks difference. Hence after mksysb restoration all the IPs and VG's (importvg) will be same but the network interface numbers will be different like en3 may having service IP on P-6 and that interface will become en5 here then do i have to make the changes (specially network) in extended configuration before discovery and cluster synchronization??

    Regards,
    MMP
    If the IP address and label stay the same, you shouldn't have to change the topology info about the new en device. (I don't believe, worst case delete and re-add). I THINK if you restore AIX and the HA filesets (or re-install the hafilesets and not so much restore the ha cluster confg) when you sync/push the config over from one of the existing nodes it will automatically update the en device info in topology.

    Another option is, not widely known, that if you restored the HA config (or when you make changes you can do this too) and came back with the wrong en device you can run an SMIT HACMP option called "Update PowerHA SystemMirror Communication Interface with AIX Settings". Choose the label, and that too should make the update occur.

    Delete and re-add should be last resort, though it too should work.