IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 3 replies
  • Latest Post - ‏2012-03-21T15:30:31Z by Forrest_Xia
heidiibm
heidiibm
2 Posts

Pinned topic WASCE 3 plugin in IBM Data Studio

‏2012-03-14T08:46:56Z |
Please help. I am new to WAS and IBM Data studio. I have downloaded and installed wasce3 and IBM Data Studio V 3.1 full client. When I try to configure the server it does not provide an option for wasce 3. I have downloaded the wasce3.0 Eclipse plugin but do not know how to install it in IBM Data studio.
Updated on 2012-03-21T15:30:31Z at 2012-03-21T15:30:31Z by Forrest_Xia
  • pientka
    pientka
    9 Posts

    Re: WASCE 3 plugin in IBM Data Studio

    ‏2012-03-15T19:53:16Z  
    just add http://download.boulder.ibm.com/ibmdl/pub/software/websphere/wasce/updates/
    or
    https://www.apache.org/dist/geronimo/eclipse/updates/
    as new site under install software and search
    Then
    'File' | 'New' | 'Other...' | '[+] Server' | 'Server' | 'Next >' | 'Download additional server adapters' | 'Geronimo v3.0 Server Adapter' or WAS CE 3.0 | 'Next >' | 'OK'.
    further infos under
    https://geronimo.apache.org/2011/12/06/apache-geronimo-eclipse-plugin-30-beta-1-released.html
    http://publib.boulder.ibm.com/wasce/V3.0.0/en/installing-eclipse-plug-in.html
    regards
    Frank
  • heidiibm
    heidiibm
    2 Posts

    Re: WASCE 3 plugin in IBM Data Studio

    ‏2012-03-16T13:01:59Z  
    • pientka
    • ‏2012-03-15T19:53:16Z
    just add http://download.boulder.ibm.com/ibmdl/pub/software/websphere/wasce/updates/
    or
    https://www.apache.org/dist/geronimo/eclipse/updates/
    as new site under install software and search
    Then
    'File' | 'New' | 'Other...' | '[+] Server' | 'Server' | 'Next >' | 'Download additional server adapters' | 'Geronimo v3.0 Server Adapter' or WAS CE 3.0 | 'Next >' | 'OK'.
    further infos under
    https://geronimo.apache.org/2011/12/06/apache-geronimo-eclipse-plugin-30-beta-1-released.html
    http://publib.boulder.ibm.com/wasce/V3.0.0/en/installing-eclipse-plug-in.html
    regards
    Frank
    Thanx for the reply. I added the upload site, but when I try to select the wasce 3 adapter for installations I get an error :

    Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.

    Current configuration problems
    Geronimo v3.0 Server Adapter (3.0.0) requires feature "org.eclipse.jst.server_ui.feature (3.2.0.v201005241530)", or later version.
    Optim Database Administrator UI (2.2.401.v20110923_0824) requires plug-in "com.ibm.datatools.core (2.0.0)", or compatible.
    CME DB2 LUW Feature (2.2.401.v20110920_0255) requires plug-in "com.ibm.db.models.sql.query.db2 (1.0.0)", or compatible.

    Configuration problems after the operation
    Geronimo v3.0 Server Adapter (3.0.0) requires feature "org.eclipse.jst.server_ui.feature (3.2.0.v201005241530)", or later version.
    Optim Database Administrator UI (2.2.401.v20110923_0824) requires plug-in "com.ibm.datatools.core (2.0.0)", or compatible.
    CME DB2 LUW Feature (2.2.401.v20110920_0255) requires plug-in "com.ibm.db.models.sql.query.db2 (1.0.0)", or compatible.
    WASCE v3.0 Server Adapter Assembly (3.0.0) requires feature "org.eclipse.jst.server_ui.feature (3.2.0.v201005241530)", or later version.
    I think it seems as if it needs V 3.2 of the jst package? When I go to the about IBM Data Studio option the jst package is as follows:

    J2EE Standard Tools

    Version: 3.0.5.v200904070500-7U19A9LJLHQaz-gMbljgxLAYoUT8.

    Do I need to update the jst package? and if so, how do I do it?
  • Forrest_Xia
    Forrest_Xia
    82 Posts

    Re: WASCE 3 plugin in IBM Data Studio

    ‏2012-03-21T15:30:31Z  
    • heidiibm
    • ‏2012-03-16T13:01:59Z
    Thanx for the reply. I added the upload site, but when I try to select the wasce 3 adapter for installations I get an error :

    Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.

    Current configuration problems
    Geronimo v3.0 Server Adapter (3.0.0) requires feature "org.eclipse.jst.server_ui.feature (3.2.0.v201005241530)", or later version.
    Optim Database Administrator UI (2.2.401.v20110923_0824) requires plug-in "com.ibm.datatools.core (2.0.0)", or compatible.
    CME DB2 LUW Feature (2.2.401.v20110920_0255) requires plug-in "com.ibm.db.models.sql.query.db2 (1.0.0)", or compatible.

    Configuration problems after the operation
    Geronimo v3.0 Server Adapter (3.0.0) requires feature "org.eclipse.jst.server_ui.feature (3.2.0.v201005241530)", or later version.
    Optim Database Administrator UI (2.2.401.v20110923_0824) requires plug-in "com.ibm.datatools.core (2.0.0)", or compatible.
    CME DB2 LUW Feature (2.2.401.v20110920_0255) requires plug-in "com.ibm.db.models.sql.query.db2 (1.0.0)", or compatible.
    WASCE v3.0 Server Adapter Assembly (3.0.0) requires feature "org.eclipse.jst.server_ui.feature (3.2.0.v201005241530)", or later version.
    I think it seems as if it needs V 3.2 of the jst package? When I go to the about IBM Data Studio option the jst package is as follows:

    J2EE Standard Tools

    Version: 3.0.5.v200904070500-7U19A9LJLHQaz-gMbljgxLAYoUT8.

    Do I need to update the jst package? and if so, how do I do it?
    WAS CE eclipse plugin only works with the latest Eclipse JEE assembly and certain version of RAD 8.0.x.