Topic
5 replies Latest Post - ‏2012-03-20T12:55:00Z by SystemAdmin
SystemAdmin
SystemAdmin
557 Posts
ACCEPTED ANSWER

Pinned topic Webservice timeout is not working - web service call builder

‏2012-03-06T13:44:55Z |
Hi,

I couldnt able to make the timeout working in the web service call builder.
I created simple Webservice demo application where i added thread sleep code to simulate the timeout.

Added webservice call builder to invoke the demo webservice created above and tested. It is not getting timed out at all.. timeout is set to 30 seconds in the builder
tested with 1) 45 seconds
2) 90 seconds
3) 190 seconds

I even tested with "com.bowstreet.util.soap.SOAPRequest.defaultTimeout" property to 30 in override.properties still with no luck..

Could someone please guide me where i'm wrong or is there any known issue with WEF?

WEF : v 6.1.5.1
Thanks and regards
Updated on 2012-03-20T12:55:00Z at 2012-03-20T12:55:00Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    557 Posts
    ACCEPTED ANSWER

    Re: Webservice timeout is not working - web service call builder

    ‏2012-03-06T14:35:43Z  in response to SystemAdmin
    Hi All,

    Further to that, it is evetually timing out after 5 min. But we are specifying as 30 seconds in the webservice call builder. :(

    Thanks and Regards
    Selva
    • mburati
      mburati
      352 Posts
      ACCEPTED ANSWER

      Re: Webservice timeout is not working - web service call builder

      ‏2012-03-06T16:04:03Z  in response to SystemAdmin
      The 6.1.5.x version is pretty old by now (you may want to consider upgrading at some point), but I believe that may have been the first version to offer the option of the older Apache AXIS web service support or the newer JAX-WS web service support. I believe there's an option in the WS builder that allows you to specify whether to use JAX-WS if it's available.

      It's possible that the Apache AXIS Connection timeout was only a network "connection" timeout (how long to wait for issues connecting to the remote server) and not a read timeout. You may want to make sure you're using the newer JAX-WS support and see if the timeout works more like what you're expecting there. In either case, WEF doesn't manage the timeout itself, it passes it down to the web services layer (AXIS or JAX-WS) and asks it to manage the WS connection.

      ..mb1
      • SystemAdmin
        SystemAdmin
        557 Posts
        ACCEPTED ANSWER

        Re: Webservice timeout is not working - web service call builder

        ‏2012-03-06T16:43:27Z  in response to mburati
        I checked again, Under Advanced sectionm, Use JAX-WS if available is enabled and i'm testing my client portlet in WAS v7.0. So it should be JAX-WS client.

        I will check my demo web service also again and update.

        Cheers,
        Selva
        • DGawron
          DGawron
          50 Posts
          ACCEPTED ANSWER

          Re: Webservice timeout is not working - web service call builder

          ‏2012-03-07T16:40:28Z  in response to SystemAdmin
          Sounds like a bug in the JAX-WS implementation of WEF. If this is something you really need, then contact support and have them create a PMR.
          • SystemAdmin
            SystemAdmin
            557 Posts
            ACCEPTED ANSWER

            Re: Webservice timeout is not working - web service call builder

            ‏2012-03-20T12:55:00Z  in response to DGawron
            Created a PMR.

            But it is going at very slower than a turtle on mountain. I never faced these kind of un responsiveness with WAS support.